No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Autodiscover Not working

  •  

    Hi Kindly advise me.

    I have added Mx record and Autodiscover record in External DNS as below 

    DNS- Gankee.com MX  - 0 -               =gankee-com.mail.eo.outlook.com

     Autodiscover-                                   =autodiscover.outlook.com. 

    But when configure outlook prompt username password. even i enter correct credential. and also i test autodiscover connection using remote connection analyzer its failed

  • I think your autodiscover is working fine - if it weren't you wouldn't get the login prompt. It looks ok in NSLOOKUP.

    Are you sure you are entering the credentials properly?

  • Hello R Kumar,

    I'm sorry to hear that you are having trouble configuring Outlook for Office 365. You can see the following article for troubleshooting information about other issues which can prevent Outlook from configuring even though you have your CNAME setup:
    http://support.microsoft.com/kb/2566899 (Issues preventing Outlook from configuring)

    You can also see the following articles for additional help resolving this issue:
    http://support.microsoft.com/kb/2404385 (Manually configure Outlook without Autodiscover)
    http://help.outlook.com/en-us/140/ms.exch.ecp.useoutlookanywhere.aspx (Manually configure Outlook)
    http://onlinehelp.microsoft.com/en-us/office365-smallbusinesses/ff637585.aspx (Manually configure Desktop Apps)

    Please let us know if you are able to resolve your issue or if you still need more help configuring Outlook.
  • Are you also deploying the records on your internal DNS? Especially if you are running outlook on a client that is doing lookup on the internal DNS and not the external.

    You have to authenticate the first time after autodiscover has run and choose to save them in the Credential Manager (Win7). No prompt will appear til the user has to change the domain password. This is due to MS using the proxy functionality in outlook and authenticating with basic authentication to the o365 exchange proxy server. If they had used NTLM there would not be any prompts...

    Hope this helps  

  • Hi

    Thanks For your reply.

    I trying to setup outlook outside of my organisation.network(external netwok not in internal network) is it still trying to lookup internal records. kindly assist your co-operation is highly appriciated.

  • Hello R Kumar,

    I'm sorry to hear that you are still having difficulty setting up Outlook. Were you able to configure Outlook manually from the articles I sent?

    Please also run the following commands from a command prompt to clear your DNS resolver cache to make sure that the autodiscover records are viewed live from the Internet and are not being saved pointing to the old location on your local computer:
    ipconfig /flushdns

    You can also follow the steps from the following article to make sure that your firewall is not preventing the connection to Office 365:
    http://support.microsoft.com/kb/2410859 (Firewall preventing connection to Office 365 to configure Outlook)

    Please let us know if you need more help.
  • R_Kumar,

    How are you testing "external network" access? From a domain joined computer on the company network?

     

    When you say lookup internal records I am thinking that you have an on-premise exchange infrastructure. Outlook clients on domain joined computers will always check AD for autodiscover records prior to checking DNS. Maybe thats where you are getting "internal network" data from?

     

    Note: Autodiscover.outlook.com requires a successful Authentication before autodiscover.xml data will be returned.

     

    -Neil