No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

(homepage) web apps do not work

This question is not answered This question is not answered



Hopefully I can get some help on a very frusturating issue.


Firstly, on the homepage I am unable to access web apps. More specifically when I click on the Excel web app icon I get the following error message:


"You do not
have appropriate permissions to create a new workbook in the specified

The path specified to create a
workbook must be a SharePoint Document Library, and an Excel Services
Application Trusted Location. Additionally, you must have permissions that
enable you to save workbooks there."


and on the word app:


"List '|0' does not exist at site with URL '|1'."


I am not too sure how I can go about ensuring these links work. Any assistance in this would be appreciated.


My second issue is with the web apps in a shared document library. When clicking on new document, the item tries to use a desktop app. I thought that it might be defaulting to use my computers application so I even went so far as to remove any office application from my computer.


I have also tried in the site settings to set web apps to be the default. However none of the options seem to work.


Is there something else that I might be missing. I do not want to commit to this product until this issue can be resolved.


Thirdly, and this issue is just a nice to know type thing. (so if you are tired with answering the above I understand :). When a person opens a document in a library (such as excel) and then it does go to the web app in this case (the only time), after changing what needs to be changed and saving as to a new file name the new screen shows the original document and the newly named document. The issue is that they are essentially the same document. This is not the desired affect. I do not want the old file to be changed. Similar to using an offline office program. Using the save as option and using a new name does not overwrite the original. This might be confusing, but hopefully someone will understand me.


I look forward to your answers as I could not find anything in the forums that worked for me.






All Replies
  • Hello Simply,

    What version of Office 365 are you using? I ask only because P1 and E3 are set-up very different, and since I do have access to both, I will take a look.

    On your first problem, is this from the existing icon, or did you add links to the web apps yourself? I ask because that is exactly the error I got when I added my own links to them.

    On second issue there is a set-up to add each type to the new documents so it will open with web app, I have th elink saved on another PC and will add it Thursady if no one adds it before then.

    For your third item, that one is easy, did you notive there was no save button, but rather a choice that said where is the save button? That is because all changes are saved as you make them, so in your case as you made the changes they wre all saved then you did a save as, which in fact just made a copy. If what you want to do is say have a new sheet for each week to show sales, then what you would do is open the sheet from last week monday morning, do a save as then start adding new data. I know it is odd, but that is because we used to haveing a save button.

  • Thank you Robert for your quick reply.

    I am using P1. Quite honestly I would prefer E3 but the size of my organization does not warrant the extra cost.

    In regards to the first problem I am refering to the existing icons on the homepage (after user logon) but not the included website homepage to avoid any confusion for anyone else who might reply.

    I would really appreciate the link for opening new documents in the web ap :)

    I can see why the document would auto save...but this also creates issues. With the example you have given it would make sense, but for my own uses it involves invoices. I wanted to have a document that served as a template (since the above could not work) and then have users open the template document that was uploaded and make their updates then save a copy. The problem is that all users have different rates and such so if they were all using the same document template each user would in effect be able to see the changes from the last user which could cause issues. It is funny that the only reason I discovered this slight issue was because the new document link would not work. Once that is up and running then I should have no issues, but still interesting.

    Thank you once again for your help

  • Hi Simply,

    You'll need to create a Service Request to help get the issue with the Apps resolved.  You can do so by clicking this link:  

  • Mike. I can not seem to get a service request to go through. Looks like I will need to submit a serice request to submit a service request. :) Thanks for the help though.

  • Hi Simply,

    We are currently investigating this on our end.  In the meantime, could you please contact one of us via the Private Message system so that we can get a bit more information from you to be able to get a Service Request opened on your behalf?

  • Did you have any further questions Simply?

  • Yes I do. The issue has not been resolved. I will attempt to use the private message system and report back if there is still no solution. This is absolutely detrimental to my organization and hopefully we can get it resolved. With Microsoft phasing out it's old SharePoint system this replacement will not suffice.

    Thank you for your help so far.

  • Could you please create a Service Request for this issue Simply Satellites?

  • I spent some time with a support rep on this and their conclusion was docs have to have been created in a newer version of Office to open in web apps. I often have to use older files (.xls or .doc) and these can't be opened in the browser. Since I can open these files in the free Sky Drive with no problem, this seems like another bizarre 365 restriction.

    Can someone explain why Sky Drive is more open than 365?
  • mch,

    I have opened old Doc files using the web apps, no problem viewing them, when you try to edit it say old format must be updated, it then updates it, and saves a second copt with " Converted " Tagged onto the end of the name in the document folder. Have seen the same with old excell files to.

  • Robert,

    No, i don't even see "edit in browser" unless it's a file created in 07 or 10.


  • Were you able to create a Service Request for this Simply Satellites?

  • Hi, Im have same problem.