No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Cannot create a new doc with Office Word Web App - Sharepoint

This question has suggested answer(s) This question has suggested answer(s)
When tryng to create a new Word doc online in Sharepoint I get the error - The document cannot be created. The required app may not be installed properly, or the template for this document library cannot be opened.

All other web apps work fine and Word (on the web) will open existing documents. It just refuses to create new ones.

Any ideas?

Thanks
Colin
All Replies
  • Dumb question but you are using a global admin id - or "owner" right?
  • I am using the ID of the mailbox/domain which also has admin rights

  • Hello ColinG,

    You can follow these steps to troubleshoot the issue:
    1.Run Office 365 desktop setup, you can refer to http://onlinehelp.microsoft.com/en-us/office365-smallbusinesses/ff637537.aspx.
    2.Configure your Internet Explorer.
    •Click Internet Options of Internet Explorer.
    •Click Manage add-ons in the tab Programs.
    •Select All add-ons in the drop-down box, and make sure the status of “SharePointOpenXMLDocuments”  is Enabled. If not ,enable it.
    •Click OK, and restart your Internet Explorer.

    If you have any other concerns about this issue, please feel free to post here.

    mchv2.0, thanks for your suggestion and appreciate your time.

    Thanks,
    Cherry Wang

  • Did the above. There is no “SharePointOpenXMLDocuments”  listed in IE9. Cannot therefore enable this!

  • There's no “SharePointOpenXMLDocuments”  in IE8 either so I don't know what this is referring to. I also think it's ridiculous we're always told to turn this on and that off to get what should be a simple out of the box functionality to work. All of this should be handled when you run the desktop setup so just like in Sky Drive and Google Docs when you click "create", it creates.  
  • I moved from Google Apps as I like Outlook's functionality and also prefer MS web apps. I think though I will dump Office 365 and go back to Windows Live or maybe Google Apps which gives a lot, even in its free version - but I do not like the web apps in Google. Windows Live and Sky Drive is looking good but lacks the control given by Google. Maybe the cut down version of Office 365 is the answer. Here there is no Sharepoint but it could be run alongside Sky Drive.

  • ColinG, 

     

    I just want to say,if you are admin user, why there's only Site libraries and lists under  the Site Administration? Why there's only Site Administration when clicking Site Settings in Site Actions?  

    I have confirmed it when using general user to logon ,there would be only Site libraries and lists under  the Site Administration, and then several "Custom……". 


    I'm confused with what you said.  Check the permission in case of time-consuming.


    But, I'm willing to share something with you. Just follow Cherry's suggestion to run O365 desktop setup,reset IE(http://support.microsoft.com/kb/923737),and make sure the status of "SharePoint OpenDocuments Class" in the Manage add-ons is Enabled. Or,first disable it, and enable it again.Finally, restart IE and try again.



  • Cherry didn't mention "SharePoint OpenDocuments Class" . She said:

     

    "Select All add-ons in the drop-down box, and make sure the status of “SharePointOpenXMLDocuments”  is Enabled. "

     

    Was she wrong? If you read the answers above you'd see that isn't listed in the user's IE9 or my IE8. What's also funny is I was specifically told by a MSFT rep that to get the create docs to work I should DISABLE  SharePoint OpenDocuments Class.

    And I still maintain we shouldn't even have a need to discuss this. It should just work.

  • This is all completely confusing. This is not the way it should be. Please forget it, I will be closing the account.

    By the way, I am logged in as admin user.
  • Hi,

    You can try the method in this link: http://blogs.technet.com/b/lystavlen/archive/2012/06/27/s.aspx
    It helps me a lot.

    Sarah

  • Hello ColinG,

    Thanks for your reply.

    If you have any other questions about Office 365, welcome to ask in the forum. It’s always our pleasure to be of assistance.

    Thanks,
    Cherry Wang

  • I am having similar issues - and judging by the many posts on this topic, it is unfortunately not uncommon.

    We are using Plan E3.

    I am an admin with full rights to everything with O365.

    Using Windows 7 x64 and IE9 - all current patches.

    I have followed the directions mentioned in this thread, including the steps in this article:

    office.microsoft.com/.../add-multiple-office-templates-to-a-document-library-HA102409514.aspx

    What I am attempting to do is simply have new documents of type .docx or .xlsx opened in the webapp vs the client.

    If I manually upload a .docx or xlsx and click on the link within the library, it opens in the WebApp, which validates the ActiveX control is installed/enabled and working properly. IE 9 shows that the 'SharePoint OpenDocuments Class' is enabled. If I disable it, then clicking on an existing file in the library displays the error dialog indicating the ActiveX is required.

    The library settings have been set as indicated above and verified, the empty templates uploaded and added to the Content types. But, new documents are still opened in Word/Excel on the client - NOT the webapp.

    Site collection features shows Office WebApps enabled and 'Open Documents in Client Applications by Default' is NOT activated.

    I have also reset IE9 : http://support.microsoft.com/kb/923737#method1

    If I use Outlook.com / skydrive, I can create new documents (of all types) within the WebApp w/out issue.

    I have verified this/have the same issue on 3 separate systems - Win7x64, Win7x32 and 2008R2 RDS, all with IE9 installed, so it would seem to indicate some setting with SP.

    What other settings might affect this?

  • I went through this maze and compared a working library with a non working one. Since one was working I'd already ruled out all the browser claptrap mentioned above. The only difference was:

    WORKING-allow management of content types=NO

    NOT WORKING -allow management of content types=YES

    When I changed the non working lib to NO, it opened new docs in web apps. I'm pretty sure a MSFT tech here recommended it should be set to YES.

    This was in an E3 account under library settings>>advanced settings. 

    I find it hard to believe that this wasn't intended to be as complicated as possible...............

  • Hello topry,

    Based on your current description, you can refer to the following steps to narrow down this issue.
    1.Run Office desktop setup.
    2.Disable the SharePoint OpenDocuments Class add-on in your IE9.
    3.Locate the Library Settings, Advanced settings, and in the Opening Documents in the Browser, click Open in the browser.
    4.Try to see if the document can be opened in Office Web Apps.

    If the issue persists, I would suggest you post a new thread for more efficient help.

    Thanks,
    Cherry Wang

    1 out of 1 people found this post helpful.

  • Thank you.

    Steps 1 and 2 resolved the issue. (actually only #2 was required, I later realized that this ActiveX control only appears in the Manage AddOns dialog when you are viewing the library).

    (Step 3 had already been done).

    FWIW - I agree with other posters that this process is a bit to convoluted. With Outlook.com / Skydrive users can immediately open/create new documents within the WebApps - requiring this number of steps / configuration for O365 is an IT managers nightmare.

     

    Is there a way to disable this addon without going to each and every user and doing it manually?