No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Sharepoint Workspace fails with Office365 Document Library Folders

This question is not answered This question is not answered

 Syncing to Office365 via Sharepoint Workspace 2010 is failing due to a schema error in relation to folders in the document library.


  • Microsoft Office Sharepoint Workspace 2010 (64-bit)
  • Internet Explorer 9 (64 and 32-bit)
  • Exploerer (Windows Server 2008 R2)
  • Office365


  1. Log into Office 365
  2. Sync the document library to Sharepoint Workspace 2010
  3. Create a new folder by either:
    1. Clicking "New Folder" under the "Library Tools -> Documents" ribbon
    2. Opening the document library in Explorer by clicking the "Library Tools -> Library -> Open with Explorer" ribbon and creating a new folder.
  4. Sync the workspace (or wait for it to aut-sync)


Sync fails with error:


An error occurred while attemptingn to synchornize this tool.


Data in this list references content type "", which is no longer in the list schema.




Clicking resolve error does nothing.

Deleting the new folder from either the web interface or by Opening in Explorer causes Sharepoint Workspace 2010 to return to normal functionality.


Other Notes:


I have other Sharepoint workspaces (non Office365) synced in Sharepoint Workspace 2010 and they have the option to create a new "Folder" or "Document" when right-clicking on an unoccupied area in the document list. The Office365 only has the option of "Word", and no option to create a folder through Sharepoint Workspace 2010.


Looking for any hints towards a resolution.

All Replies
  • Hi Filmore,
    This is Bob Kasper from Microsoft Office 365 SharePoint Support.  Thank you for letting us know about the error you are getting when trying to sync your SharePoint Workspace.
    After researching this error message I found a forum post on the Microsoft Developers Network.  In Corey Roth’s post on May 16th there is a link that gives more details about the issue.  Please check this out to see if it has any bearing on your issue. 
    Please let me know if this helps as I will be watching this thread for your update and will reply accordingly.
    Thank you,

    0 out of 2 people found this post helpful.

  • Hi Bob, Thanks for the post. I noticed that post as well, but unfortunately we are not using OneNote, and the problem explicitly appears (and clears) when adding and removing a directory.
  • Hi Filmore,
    Sorry about the long delay in my reply, after reading the error message that you are receiving, I have seen this issue once before and it turned out to be a CSV file that had line breaks in it.  Could this possible be the same in your situation?
  • Hi Filmore,
    I’m just checking in to see if you saw my last post and the issue with line breaks in a CSV file?
    Please let me know if there is anything else that you need assistance with as I will be watching this thread for the next few days.
    Kind Regards,
  • Hello Bob,

    I have the same issue. I cannot sync with Workspace because of the same error message. I've removed a little while ago the OneNote files, and we had one CSV file, also removed him, but even after that, I'm not be able to sync it.

    What is the issue?

    Kind regards,


  • We see the same issue in our environment. I removed all the onenote files we had. But still we have the error. There are some posts that refer also to PDF files. For us it's no option to remove all our PDF files, because those are mandatory to work with..

    Hope support can determine the real cause of this issue.

    Kind Regards,


  • I'm also having the same problem. We only have pdfs, jpg and .docs in the sharepoint doc library and none of them have line breaks in the name. Surely it can't refer to line breaks in a PDF doc file. Can someone form O365 support please post on this. The last reply in feb hasn't fixed the problem

  • Same problem here as well...

    We do not have onenote. Just pdf and word docs.

  • Seems to be a common problem.  We only have xls files in the folders that are giving us problems.

    Even if it problem caused by OneNote files it needs fixing please, Microsoft.  OneNote is an instrinsic part of the Office365/Sharepoint Online offering and should work with Workspace.

    Bob, can you please send link so we can log this problem and get it looked at by an engineer.  

  • Bob -

    This error is very simple to reproduce. Simply adding a Folder to the document library that's included in the default Office365 Team Site results in this error. The folder doesn't need to have any files in it - it can be empty and you'll get the error.

    It's ironic that MSFT hasn't caught this error, since it doesn't seem like an obscure or uncommon use case. I've deployed Office365 sites now for quite a few clients, and one of the very first things most of them try to do is organize documents in folders, which immediately breaks the Sharepoint Workspace synchronization.

    Has anyone come up with a workaround for this yet?


  • I'm going to add my voice to the chorus of users seeking a resolution to this issue.  I'm trying to sync Office 365 and Sharepoint and getting the same error - no OneNote or CSV files.  Without the file synch functionality, it makes SharePoint dead on arrival for my use.

  • I had an empty folder in the Office 365 document library on-line. When I deleted it, I was able to synch to my local SharePoint. There were no files in the folder or unusual character names or properties.  I'm left confused how to organized and move documents and have sync.  

  • Is anyone from MSFT monitoring this question thread? I'm encountering this error again and have scoured the support forums at SharePoint and Office 365.  Now, I have no subfolders and the error has re-occured saying:     [Data in this list references content type "0x010100FA2E53E037C18845AA10BA269B7F5DA1005347C33A39E35245BE66BE167205E741", which is no longer in the list schema.]  I'd love some help.

  • Yes, same problem here. Simply creating a new empty folder in either SharePoint online, or windows file explorer, breaks the sync. We are using Office 2013 and SkyDrive Pro.

  • Suitable work-around/solution from pjaadmin. Confirmed to work with E3, office 2013 and SkyDrive Pro:

    Hi HK Mike,

    You need to stop using the standard 'Documents Library' that comes with the Office 365 subscription and create a new Library for your shared documents.  

    To do this select the 'Site Actions' menu from your Team site and select 'New Document Library' from the drop down menu. Once you have done this you will be able to highlight the library and then access the library option from the 'Libray Tools' box which will give you the 'sync to sharepoint' option on the ribbon.  

    This works and once you have done it this way allows you to create new folders either in sharepoint workspace or in sharepoint on-line that synchronise properly.