No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Outlook kept asking for credential

  • Hi, i have ADFS working fine, OWA is working fine for our users, and we are doing staged migration, domain is configured to shared in exchange settings,

    When configure outlook, i used manual configuration, enter the server name as the first 10 letters of the exchange online CAS found in the about from OWA, and proxy using the same (and also tried the host name, with basic authentication selected, after click check name, outlook just kept prompting for credential,

    activesync has same issue,

    on the other hand with the same exact server info, but using works fine,

    I am thinking something related to ADFS, ADFS is using internal certificate, not 3rd party cert,

    Please help, requesting service help from admin get no responses for 3 days...

  • Hi Leon_Y,

    Before going further, I would like to know the version of your Outlook. Is it Outlook 2007, or Outlook 2010?

    At this point, please run Microsoft Remote Connectivity Analyzer to troubleshoot this issue.
    1. Go to the site:
    2. Click Office 365.
    3. Select Outlook Autodiscover under Microsoft Office Outlook Connectivity Tests. Click Next.
    4. Type in the required information and click Perform Test.
    If Autodiscover works properly, I suggest you configure your users’ Outlook via Autodiscover instead of manually configuration.

    Meanwhile, I understand that you have submitted a service request. I have sent you a private message to collect the service request ID, so that I can monitor the status of the service request for you.  

    • Go to the Your details section on the right side of the community site.
    • Click Private messages.
    • Click the subject title of the response to read the message.
    • You can reply by using the form in this display.
    • Click Submit Reply.

    Mindy Pan

  • Hi Leon_Y,

    Thank you for sending me the Service Request ID.

    After checking the service request, I find that a support engineer has tried to  call you. Are there any updates about this issue?

    Meanwhile, I would like to confirm if you have run Microsoft Remote Connectivity Analyzer.

    Mindy Pan
  • Hi Mindy,

    I have been called for 3 times, and none of them were really helpful, this should be escalate to the engineer team since we spending 3, 4 hours trying and repeating the same steps but it just won't work, I will be sending you the result of the analyzer shortly,

    Thank you,


  • Hi Leon,

    I understand the inconvenience caused by this issue. Sometimes, troubleshooting can be a little time-consuming. Your patience and efforts are appreciated.

    After doing some deeper research, I found that the issue might be related to the internal certificate of your ADFS. When we use a none public trusted certificate for form based authentication, the web browser will stop from requesting the service and prompt an link “Click here to continue”, and we can click this link to continue. However, rich client such as Outlook cannot prompt this link, so it will keeps asking for credential. Based on the situation, to help narrow down the issue, I suggest you create a test user account in Microsoft Online Portal with the onmicrosoft domain directly(not synced from local AD), and configure this user’s mailbox in your Outlook to check if it works properly.

    Meanwhile, I will continue to monitor the service request for you.

    Mindy Pan

  • Hi Leon,

    I notice that the service request has been closed. Given this situation, I would like to confirm if you need further assistance on this issue.


    Mindy Pan

  • $LiveCred = Get-Credential -Credential
    $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri "" -Credential $LiveCred -Authentication Basic -AllowRedirection

    Error Message:

    [] Connecting to remote server failed with the following error message : The WinRM client cannot complete the operation within the time specified. Check if the machine name is valid a
    nd is reachable over the network and firewall exception for Windows Remote Management service is enabled. For more information, see the about_Remote_Troubleshooting Help topic.
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportException
        + FullyQualifiedErrorId : PSSessionOpenFailed