No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Lync 2013 "Lync can't connect to Exchange. Your Contacts list and co.."

This question has suggested answer(s) This question has suggested answer(s)

Ever since the updates last month, I have had this problem with Lync.  Outlook works fine.   I cannot add any people to my contacts.   Is there any diagnostics to run which can tell me what my problem is?   Other folks in my organization are fine, but some of us are experiencing this issue.




All Replies
  • Hi Robert,

    In order to narrow down the issue, I would like to collect the following information:
    1. Can you sign into the Lync client correctly?
    2. How many users are impacted with this issue in your organization?
    3. Could you capture a screenshot of the issue and post here for further troubleshooting?
    4. What do you mean “I cannot add any people to my contacts”? Is it “Add a Contact” button not working or Lync is failed to connect to the Server? 


  • 1. yes I can sign in correctly

    2. at least 4 of the 50 users

    3. here is a screenshot of that error message:



    4.  I searched for someone who is in my organization and just tried to add her to my favorites and got the following error:


  • Hi Robert,

    Respectively the screenshots you had provided aren't display well.
    Could you please post both the screenshots again for further troubleshooting?

    To post a screenshot in the reply, you may refer to the following steps:
    1. Choose rich format to post your reply.
    2. On the top ribbon, click the button Insert Image, and then browse the picture to upload.
    3. Click Insert.
    For an example see below screenshot:



  • Hi Robert,

    How is everything going? Do you have any updates about the status of the issue?


  • We are facing the same problem with some users (where others in the same networt, same timesettings etc. work fine). We have an open ticket on that with mosdal reporting, screenshots, powershellscripted logs etc. but no result so far. We have Username works absolutly over Office 365 with all exchange (incl. autodiscover and mx.-settings) dns settings right. But Users have  SMTP: where lync-dns-settings are for Office 365 but Exchange are NOT. Think this is part of the problem, but no one at the support can confirm that or even answers on that point.

  • Hi Andreas,

    Since it is possible that your environment is different from Robert’s, I recommend you post a new thread in our forum. By doing this, one of our support engineers will focus on your environment and provide you with effective support.


    Allen Zhang

  • I no longer have the problem.   all computers seem to work and have access to contacts from Lync.....   I did not do anything.   I suspect there was a fix on the server side or something, but I dont know how to find out.   It would be really nice if there was a diagnostics or logging function in Lync so I can get a clue about what the problem is.

    I think we can close my side for now.  I would like to find out how Andreas solves the problem since it is so similar to ours....

  • Hi everyone, our Problem seems to be solved. If you dont have the autodiscover dns Settings for your  set to Exchange Online, Lync is not able to connect to your Exchange Online. We cant set this dns-setting because we have a not fully migrated the old exchanges (lots of) and we are not able to have a hybrid configuratio.

    We set the autodiscover in our local Networks that have been migrated, that helps in the lan, but not with the roaming users. Thinking about local Hosts Settings.

    What really makes me angry is that this took more than 3 weeks with Microsoft Support. I mentioned the missing Settings in nearly every call.

  • I was suffering from the same issue for a while. By analysing the traffic between Lync and Exchange Online, I managed to work out it was an authentication issue when trying to get details from Exchange (SOAP service call). The authentication header in the message contained a timestamp which got me thinking that maybe my clock was off. Googling the current time, I realised my PC clock was indeed about 6 minutes fast. I closed Lync, reset my clock and restarted Lync et voila! Lync is now able to retrieve contact information. I hope this helps someone else.

  • I am facing the same issue since couple of weeks now. Can anyone help me out to resolve the issue.