No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Can't click on anything in Outlook Web Access

This question has suggested answer(s) This question has suggested answer(s)



Recently signed up 1 user to play with MS Exchange.   I currently use another software that basically does the same as MS Exchange, just without the brand recognition so to speak lol


Anyway, DNS is all set, test emails came in just fine.  However I can't click on a single one of them to read lol

I mean NOTHING is clickable.  If I hover my mouse over messages, calendar, options, sign out, the whole shabang.


The pointer icon does change to a finger so it is registering that it is a link, and when I hover over an object it shows a link at the bottom of the browser, and it is always the same link.


I read in a few posts similar to mine to try private browsing, and disabling add ons etc.  I have tried doing all of the above and more.


I have tried the following browsers:


IE 9

Firefox 17

Waterfox 14 and 16

Chrome 22

Safari 5


All with no joy. 


I kind of expected OWA to work out of the gate, and for some of the users who mentioned that "disabling add ons" fixed their issue, I would not prefer doing that as I have my browsers set up exactly as I wish them.


Any suggestions folks would be greatly appreciated.


Thank you,



1 out of 1 people found this post helpful.

All Replies
  • Hi Scott,

    Firstly, I’d like to suggest you try using another computer to log in OWA as the same credential to see if same behavior applies.

    Next, if OWA works fine on the other machine, I’d like to suggest you change to OWA light version and use the original machine to log in to see if the issue still persists when using light version. To use light version, please refer to Accessibility for Blind and Low Vision Users.

    Moreover, it will be better if you can provide a screenshot for further troubleshooting.

    Kent Gu

  • I am also have the same issue and have tried with numerous browsers with no change.

    Also you can not do "Accessibility for Blind and Low Vision Users" because you can not click in the page, it appears static.

  • I started having the exact same problem a day or two ago. I can log in, however nothing on the screen is clickable, including emails, folders, dropdowns, the logout button, etc. I can type in the Search TextBoxes though, although hitting Enter or clicking the Search button does nothing. This is happening in both IE9 and Chrome on my primary computer, however everything works just fine from another machine (both running Windows 7). My browsers are up-to-date, and a reboot does not fix the issue.

  • Thanks for the responses everyone,

    Kent I had tried from another computer with no joy as well.  Chris C nails it on the head:

    "Also you can not do "Accessibility for Blind and Low Vision Users" because you can not click in the page, it appears static."

    That is also true for me.  Ironically, after seeing these replies I can now log in properly from my Windows 7 pc, my laptop is still a no go.  Both have the same exact browsers with same exact addons running.

    So as it stands right now, I can at least get in and click items, albeit only from one PC.  Kind of a bummer.

    Will try to take screenshots later, although as no error pops up, nor anything being clickable I don't know what insight could be gained from a screenshot.

    But it will wait until after Xmas lol  I refuse to let a pecan pie burn trying to fix something that should work from the get go lol

    Have a happy holiday everyone!


  • Hi Scott,

    I’d like to suggest you run desktop setup and try again.

    @Chris and @Rachel I’d also like to suggest you perform same action.


    Kent Gu

    0 out of 1 people found this post helpful.

  • Hello Kent,

    What do you mean by "Run Desktop Setup" and try again?  This is web access, no software was installed to either PC.  Solely browser based.

    Thanks all,  Merry Christmas!!


  • Yes, in my case my email address is provided through my school, and we used to login through Hotmail. About a year or two ago they migrated to the new Outlook portal, so there is no desktop install. I login through or

  • Hi Scott,

    I discovered if I opened a new Incognito window it works, so based on that information I deleted my cache and cookies for my browser, and that appears to have fixed the problem.

    I'm still not sure why the problem was occurring in multiple browsers though. My best guess is I had logged in with the other browsers at some point in the past, and something in Outlook got updated which made the cache or cookies invalid.

    Merry Christmas


  • All,

    Deleting all Browsing history and *not* preserviing Favorties website data helped me.

    This is defnintely a Microsoft side issue. Not sure if it is an Exchange update or a Windows update (e.g. security update) or another issue. There is another thread in the Web Apps forum about this: that was started 12/22.

    I use Office 365 as a volunteer at a non-profit but at work we have Exchange in-house and I am the Exchange admin. After reading the above thread I tried today to use Office 365 OWA and IE 9 crashed/restarted automatically but could not recover the OWA web page.  Sorry, I did not take screenshot but that was the gist of message. Also got message about maybe I am logged into another window and have IE open there, which doesn't make senese as I use OWA in another window or tab separate from Home or SharePoint all the time but may help diagnose issue.

    I closed IE, reopened it, and as mentioned, deleted all Browsing History and did not preserve Favorites web site data; note this will delete all cookies and passwords for Favorites), closed IE again, reopened, logged into OWA, replied to an existing email, the reply opened fine but I could not type into body, saw "Not Responding" message in IE top bar, ignored it but X'ed out of reply, IE responded, and after that I did not have another issue (so far). I was able to move around, click Inbox, move around, reply, create, etc.

    Hope this helps.


  • Hi Scott,

    Yes, I mean by “run desktop setup” or manually adding https://* to IE trust site. Meanwhile, I’d also like to suggest you try using InPrivate Browsing to access OWA, as Rachel and Joan have fixed the issue by doing that.

    @Rachel and Joan, I am glad to hear that the issue you met have been solved and thanks for you kind sharing.


    Kent Gu

  • Hello Kent,

    Thanks again for the response.  As I mentioned in my first post, I have tried running in Private browsing, and without any add ons installed.

    I also can't think it would be a cache issue because:

    1.  I loathe IE, and as such I have not used it in probably 3 years?  So there should not have been cookies, cache, nothing.  Also as I don't use it unless forced too, I have 0 add ons, accelerators etc installed.  I use CCleaner  as well.

    2.  I am a privacy nut so I have all cache wiped out at each reboot by keeping cache mapped to a ram drive that isn't saved on power down.

    3.  I have browsers set to delete all cookies on close as well.  Not to mention CCleaner redundantly does this too.

    I had issues with two pc's I had tried so far.  Absolutely nothing changed and now 1 will work, but not the other.  This is what worries and bothers me most, if I had changed something and that had caused it to work I can rationalize that and accept it.  But the service not working and then MS "magic" happens and now it works only on one lol  That terrifies me.  With my current service the web access simply works on all of my machines windows or not.   I still have not tried ms excahnge from my Linux boxes with Iceweasel / Firefox or from the one mac in the house.

    I will try adding the domain to trusted sites in IE and Firefox but honestly if I have to use IE I would rather stay with the service I am at now.  I enjoy my current providers service but their mail server app does not handle delegation / send as very well.  That's what brought me here in the first place.  I guess the good news is I only set up a few users to play with it, so if I can't get the reliability I want I only waste a few C notes.

    I truly appreciate everyone's input and help.  I hope you all had a wonderful holiday!


  • Hi Scott,
    This issue should be fixed now, please check the update information about this issue in Service Health.
    Meanwhile, please sign out and sign in OWA again to check if the issue still persists. If it is, please try the following steps to narrow down this issue and let me know the result:
    1.Create a new account in your tenant to test this issue.
    2.Test this issue in Outlook client.
    In addition, I would like to collect the following information for further troubleshooting:
    1.The tenant domain(
    2.The custom domain(
    3.The region you chosen when singing up.
    To request the above information, I have sent a private message with a subject of <Request Information> to you.
    Here are the steps to access the private message:
    -Go to the Your details section on the right side of the community site.
    -Click Private messages.
    -Click the subject title of the response to read the message
    Jolin Qiao
  • Hello Jolin,

    I tried from my laptop today and it is apparently working now.  Nothing was changed on the laptop, however, which is worrisome.  I did see the outage listed under service health, albeit it only listed the 22nd of December.  My timeline went as follows:

    Dec 22 & Dec 23----Neither Laptop nor main PC would allow clicking of any kind in exchange.

    Dec 24 through Dec 26-----Main PC could view and click items in exchange but Laptop was still no joy.

    Dec 27-----Both Main PC and Laptop PC can both view and click items in exchange.

    I still have not tried from the mac or Linux boxes, but I have family still in town and they are occupying those bedrooms.  I will just assume this situation has been resolved.  I will add some more users this weekend so that I may play around with delegation and send as functionality.

    Thanks again to everyone who replied and tried to help.

    Hope your holidays have been wonderful!!