No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Samsung Galaxy S3: Security update required - Update Security settings to use account

This question has suggested answer(s) This question has suggested answer(s)

I just migrated from iphone to an android Galaxy S3. I have two office 365 mailboxes setup with activesync, and one of them is working while the other one is giving me error messages such as:

Security update required - Update Security settings to use account

Unable to open connection to server: security error occured

 

I am receiving emails, but sometimes they stop and restart only if I click on OK at the notification screen for update security.

 

I have tried all the suggestions I found on the forum and elsewhere...

 

Sending messages from that mailbox also fails often but seems to work if I switch from WiFi to LTE!

 

So far I am unable to get a reliable send and receive functionnality on that mailbox.

 

Alan Guggenheim

All Replies
  • I suggest you delete this problematic account from Samsung Galaxy phone, and then reconnect it referring to help.outlook.com/.../dd940179.aspx.

    Once you properly add your account, on the top bar where the menu is, drag it down, then you will see where the "security settings" message will appear, then click on it and then click on ACTIVATE.

    0 out of 2 people found this post helpful.

  • Thanks, but I have done that several times, and I am still getting the same error every minute or so, and my mail is stuck until I swipe and click on the security message.

  • Alan,

    I'm in the same boat. We've got several other phones (not Samsung Galaxy S III's) setup using exchange active sync, however this is the only one that has problems.

    I too have tried deleting and re-adding the account,  and clicking on the security settings popup. Nothing happens, and intermittently my email decides to load. Most of the time I get server errors or the security popup will come up.

    Thanks,

    Braden Pitts

  • I'm having the same issue, and it's making my S3 really hot & draining the battery.

  • I am having the same issue. It looks like I have all the appropriate security settings set up on my phone too. My phone's battery does seem to be dying quicker than normal. Please help correct this issue.

  • I have the same problem on a Samsung Galaxy S III syncing with Office 365.  It just started a couple of days ago.  Randomly, the security message will pop up, I have a screen shot of the message.  It stops syncing for long periods of time (12 hours at one time).  Then it will start again.  It had  been running fine for a couple of weeks and just started this behavior a couple of days ago.  Could it be a security change to the Office 365 product?

  • Just found an update on the Samsung Galaxy S 3 phone.  Installed the update and all the emails began to sync immediately.  Check it out.

    1 out of 1 people found this post helpful.

  • Good catch. Upgrading right now. I will let you guys know.

  • I tried, did the update, but I am still getting the error message.

  • Now ATT is saying that Samsung phones only support one Activesync connection or "account". Has anybody heard abouth this limitation?

  • Try using a pin number screen lock.

    0 out of 1 people found this post helpful.

  • Actually, this update does not fix anything, but it removes the search on the phone function that is one of the patent that apple is fighting Samsung on!

  • I tried all the options there, it does not help

  • I have the same problem. The message just appeared today

    0 out of 1 people found this post helpful.

  • I have spent the whole night tweaking, creating and recreating my Office365 account on my Samsung Galaxy S3 without any success.  So this morning I called Verizon and has them conference in Samsung.  Guess what they said:  MICROSOFT OFFICE 365 IS UNSUPPORTED ON THE SAMSUNG GALAXY S3.  That's right folks....even though it says it supports Microsoft Exchange, senior tehcnical folks at both Verizon and Samsung have confirmed that this is unsupported.  So, if you have Office 365, return your phone.