No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Outlook 2010 Proxy settings revert to internal e-mail server

This question is answered This question is answered

Having a problem that I've seen some others are having, but have yet to come across the resolution.

 

I've migrated ourselves to Exchange Online, mailboxes are syncing every 24 hours. I have not yet changed the MX records as I want to make sure it's fully functional before pulling the plug.

 

I have an autodiscover record in our public DNS zone, and Outlook 2010 connects perfectly to cloud e-mail outside of our network.

 

Internally, when I create the new mail account it connects fine, but after a couple of minutes the Exchange Proxy settings are converted from the cloud settings to the internal mail server.

 

We are running DNS internally.

I don't want to use Directory Sync as I have a lot of remote users who don't need an active directory account. I also have SBS 2008 as the current internal mail server and will have more than 75 email users.

I've tried adding an autodiscover records in the hosts file for

 

autodiscover.maildomain.com 157.56.240.137 (which is the IP address for autodiscover.outlook.com)

 

Is there a way around this issue without using Directory Sync?

Verified Answer
  • Hi VirtualGeek79,

    Thanks for your post. Actually, SCP is always the first thing that Autodiscover checks for, and if it isn't found then it moves on to a DNS check.  The registry key that you setup to block the SCP check will prevent that, but won't stop it from doing an autodiscover check that reaches out to the local DNS server.

    Learn more about SCP, you can take a look at : technet.microsoft.com/.../bb124251.aspx

    Thanks, Neo Zhu

All Replies
  • p.s. an autodiscover record added to our internal DNS server did not work.

  • Hi VirtualGeek79,

    Thanks for your post. Actually, SCP is always the first thing that Autodiscover checks for, and if it isn't found then it moves on to a DNS check.  The registry key that you setup to block the SCP check will prevent that, but won't stop it from doing an autodiscover check that reaches out to the local DNS server.

    Learn more about SCP, you can take a look at : technet.microsoft.com/.../bb124251.aspx

    Thanks, Neo Zhu

  • Hi VirtualGeek79,

    How are you doing? I am just writing to see if there is any progress on this issue. I do not mean to push you. I just want to ensure that you do not encounter any problems during the troubleshooting. Thank you.

    Neo Zhu

  • Just now getting a chance to follow up on this. Do you have instructions for blocking the SCP check?

  • Hi VirtualGeek79,

    You can take a look the following steps:

    Outlook 2007:  HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\AutoDiscover

    Outlook 2010: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\AutoDiscover

    "ExcludeHttpRedirect"=dword:0
    "ExcludeHttpsAutodiscoverDomain"=dword:0
    "ExcludeHttpsRootDomain"=dword:0
    "ExcludeScpLookup"=dword:1
    "ExcludeSrvLookup"=dword:0
    "ExcludeSrvRecord"=dword:0

    You can also see the detail information at blogs.technet.com/.../some-autodiscover-fun.aspx

    Thanks, Neo Zhu

  • This seems to have done the trick.

    I had actually set up a CNAME record in our internal DNS server in the mail domain zone. autodiscover > autodiscover.outlook.com Not sure if this is necessary but I have no reason to remove it right now.

    I also created a .cmd file to make the changes to the registry easily.

    Thanks for your help.

  • Hi VirtualGeek79,

    I'm glad to hear that. If the internal DNS cname record is working properly for all the users, you can keep it.  If you have feature question about this thread, please feel free to post them here.

    Thanks, Neo Zhu