No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Samsung Galaxy S2 - cannot open connection with server due to security error

This question has suggested answer(s) This question has suggested answer(s)

I created a new ActiveSync account for my Office 365 mailbox just fine (using as the server address since did not work). However, when I got to my inbox I get the message "Cannot open connection  with server due to security error"


Any ideas?

2 out of 3 people found this post helpful.

All Replies
  • Hello ccorneillie,

    Try using the steps from our website:

    If wasn't working, that could indicate that another part of the configuration needed to be changed as that server address should always work in this case.

  • Hello,

    Can you also confirm that your phone supports TLS connections?


  • ActiveSync cannot conenct to but can connect to (this is also the owa address).  I can create the ActiveSync profile, however when I go to my inbox I get the message "Cannot open connection  with server due to security error".

  • The device has the "Accept all SSL certificates" and the "Use secure connections (SSL)" check boxes enabled.

  • It seems the issue is with the SamSung Galaxy S2 Android phone since when I use a Windows Mobile 6.5 powered device ActiveSync works fine (in combination with

  • Hello ccorneillie,

    Make sure that you're leaving the domain section blank when you setup that profile.  It's possible that could be what's preventing your phone from adding that account.

  • The issue is with the Samsung Galaxy S2 Android phone which cannot connect to Office 365 via ActiveSync. IMAP4 as a workaround works fine. When I use a Windows Mobile 6.5 powered device, ActiveSync connects just fine to my Office 365 mailbox....

    I guess I need to wait for some sort of fix by Android or Microsoft?

  • I think this is something to do with the Samsung galxy S2 specifically - I have managed to set this up on my Samsung Galxy Tab but cannot do it with Samsung Galxy S2 - Either this is something about the phone or the newer version of Android Microsoft ActiveSync account application thing - I get either Authentication faile or Server not available errors

  • This error occur on a range of Android phones. I have not yet found a fix, my HTC Hero (Android 2.1) does not work, and I have never seen anybody here managed to get a phone with this error to work with activesync, although there are clearly others who successfully sync.

  • Have you tried doing an update of Android to the latest version supported by your device?  Did that have any effect?

  • Yes, I am on the latest and greatest release of firmware available from my carrier, .2.1 Update 1.

    IMAP/SMTP workaround does work, but it would have been nice to have activesync.  The end of the log always say;

    AccessState :


    AccessStateReason :


    DeviceAccessControlRule :

    htchero (DeviceModel)

    ResponseHeader :

    HTTP/1.1 449 Retry after sending a PROVISION command

    MS-Server-ActiveSync: 14.1

    ResponseBody :

    [No XmlResponse]

  • Hello Raggy,

    I've been doing some research on your issue and I think I might have a better idea of what's going on.  It looks like the HTTP 449 message is part of a communication chain between Exchange and your device.  As the device doesn't send the appropriate HTTP header that Exchange is asking for, it falls back to a second way to execute the requests, which relies on PROVISION commands.  The error you're seeing indicates that the device didn't respond to the 2nd attempt to send the PROVISION command to the phone.

    Unfortunately, I don't have a clear way to suggestion on how to fix the problem.  From what I've seen it looks like this could be a bug in the Android software that's been fixed but may not have been deployed by your phone vendor as of yet.  The first thing I'd recommend is opening a support request with your phone vendor to troubleshoot this issue, as it does look like a problem that's occurring because of the device itself.

    That said, I do have a few suggestions.

    Try opening your Exchange Control Panel from your Office 365 Admin Portal.  Go to the Phone & Voice section, and then the ActiveSync Device Policy.  Try changing the default policy to require a password.  Also, check on the ActiveSync Access page and look for the Device Access Rules.  See if there's one applied for your device, it might be labeled htchero, and remove it.

    Also, I found someone who figured out a workaround for their system.  This isn't Microsoft affiliated so I can't suggest or support the options here, but looking at their page may be of some assistance to you:

  • Hi, I just wanted to confirm the workaround of changing the default ActiveSync policy to require a password solved my issue. I can now use ActiveSync on my Samsung Galaxy S2 device in combination with Office 365! Thanks for the tip!

  • Hello ccorneillie,

    That's great, I'm glad to hear it's working for you.  Please let us know if you have any additional questions or problems.

  • Didn't work for me sadly. Maybe a good excuse for a new phone? :-)