Enable Archiving after migrating users.

This question is answered This question is answered

Hi,

 We have setup for rich-coexistence between on-prem and Office365.  Users have their mailboxes on-prem Exch07 servers currently. We deployed also the Exchange 2010 server for coexistence, free/busy sharing and migrating mailboxes.

 We started moving a few users but we do not have the ability to Enable hosted archiving for them. Is there any aditional configuration that we need to make ?

 According to the documentation, to enable archiving I need to right click on the recipient contact (Mail User or Remote User Mailbox) and select "Enable Hosted Archive". However, this option is only present for Mail contacts of type "Remote User Mailbox" and not for "Mail User".

 "Remote User Mailbox" are created automatically only for users that I have tested, and that were originally created on the Exchange2010 coexistence server, for which I believe their objects had Exchange2010 version.

 

 

Thanks,

AlexB

0 out of 1 people found this post helpful.

Verified Answer
  • Hi Monica and thanks for your replies.

    See below what my findings are and how I could finally get it work:

    1. Because users on prem are DirSynced to Cloud, Enabling Archiving in the portal is not possible and throws an error that the user must be archive-enabled from the on prem Exchange Management Console.

    2. After a user's mailbox have been migrated from Exch07 to Cloud, it will appear as a Mail User under EMC-Recipient Configuration - Contacts . If you right click a Mail User on prem you will not have the option to enable Archiving. This option is only availble for contacts of type: Remote Mailbox User.

    3. So finally I needed to convert MailUser to RemoteUserMailbox. To do that on Exch2010 coexistence server, in Exchange management shell you run this :

     

    [PS] C:\Windows\system32>Get MailUser user001 | Enable-RemoteMailbox

     

    Here is how an original user moved to cloud looks like, and how it looks after I converted it to Remote-Mailbox type:

     

    1 out of 1 people found this post helpful.

All Replies
  • Hi AlexB,

    I understand that you would like to enable the archive feature for the users who migrating from the on-premise Exchange 2007 Servers and Exchange 2010 Server to Office 365 on the cloud.

    You can log on the Office 365 Portal to create an archive mailbox for a user's primary cloud-based mailbox. Users can use the archive mailbox, also called a personal archive, to store historical messaging data by moving or copying messages from their primary mailbox to their archive mailbox. The archived messages reside in the cloud, and users can access it from any computer using Microsoft Outlook 2010 or Outlook Web App.

    Please refer steps below to enable the archive mailbox:

    1. Log on the Office 365 Admin Home Page portal.microsoftonline.com with your user name and password.

    2. Click Outlook, and click My Mail. Then click See All Options.

    1. Select Manage My Organization > Users & Groups > Mailboxes.

    2. Select the mailbox you want to enable the archive mailbox for and click Details.

    3. Under Mailbox Features, select Archive and click Enable.

    4. In the Archive Mailbox window, accept the default archive name (Archive Mailbox - <display name>) or type a new name.

    5. Click Save. Note that the status for Archive is now Enabled.

    After you save the change, the archive icon is displayed in the mailbox list for the user's mailbox to indicate the archive mailbox is enabled.

    For detail information on enable the archive mailbox, please refer to the article below.

    help.outlook.com/.../ff628726.aspx

    Does the reply above answer your question?

    Best Regards,

    Monica Tong

  •  

    Hi AlexB,

     

    The previous reply is to enable archive feature on Office 365 Microsoft Online Portal.

     

    Based on the further research on the issue through Exchange 2010, I found that the mailbox for Mail User or Mail contact under Mail contact wasn’t located on the local host. It is expected situation that we couldn’t right click on them to choose Enable Archive on Exchange Management Console. To enable archiving, you need to right click the user’s Mailbox on the right panel of Mailbox under Recipient Configuration and click “Enable Archive”. We will got the below options.

    If you couldn’t enable archive on the mailbox, please capture a screenshot and post on the thread for further discussion.

     

    Does the reply above answer your question?

     

    Best Regards,

    Monica Tong

  • Hi Monica and thanks for your replies.

    See below what my findings are and how I could finally get it work:

    1. Because users on prem are DirSynced to Cloud, Enabling Archiving in the portal is not possible and throws an error that the user must be archive-enabled from the on prem Exchange Management Console.

    2. After a user's mailbox have been migrated from Exch07 to Cloud, it will appear as a Mail User under EMC-Recipient Configuration - Contacts . If you right click a Mail User on prem you will not have the option to enable Archiving. This option is only availble for contacts of type: Remote Mailbox User.

    3. So finally I needed to convert MailUser to RemoteUserMailbox. To do that on Exch2010 coexistence server, in Exchange management shell you run this :

     

    [PS] C:\Windows\system32>Get MailUser user001 | Enable-RemoteMailbox

     

    Here is how an original user moved to cloud looks like, and how it looks after I converted it to Remote-Mailbox type:

     

    1 out of 1 people found this post helpful.

  • Hi AlexB,

    I am very glad that the issue has been fixed after converting MailUser to RemoteUserMailbox.

    Thank you for your sharing on your finding and how you fix the issue. I will mark your question as answered. This is so others may benefit from your suggested resolution.

    Best Regards,

    Monica Tong

  • Excellent post. I have a hyrbid setup as well. I have migrated over a few users and they are all listed as mail users. Should I be converting them all to Remote User Mailboxes even if I don't care about enabling their archive mailbox? Not sure if it is relevant,but my ultimate goal is to kill the hybrid server once all users have been migrated.

  • Hi Mvozila,

    You do not need to covert them to Remote User Mailboxes. It is ok to keep the current situation. If the information doesn’t address your concern, to better follow up the issue, I suggest posting a new question in the forum with the detailed problem description and requirements.
     
    Thanks,
    Monica Tong
     

  • Monica, I rather we keep this discussion in this blog because I feel it will complete the answer for future techs. I have a hybird setup. It seems the only way that I can enable an archive mailbox is by first converting it to a remote user mailbox. This is why I was asking do I need to convert all my moved users to remote mailboxes. Alex, if you can provide any feedback from your experiences that would be greatly appreciated.

  • So when our hybrid server was exchange 2010 SP1 converting to remotemailbox and then enabling the archive as outlined above use to work. Now we are on exchange 2010 SP2 RU1 and when I try to convert the mailbox it tells me it is already of type remotemailbox.

    SO fine I run

    enable-remotemailbox -identity username -archive

    And get

    Property ArchiveGuid can't be set on this object because it requires the object to have version 0.10 (14.0.100.0)

    The only way I'm able to resolve this is to disable the remote mailbox and re-enable it and dirsync. Then I can run the command enable-remotemailbox -identity ttmigrate -archive

    Is this normal after applying SP2?

  • I'm going to create a new post with my question.