No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Your IMAP server closed the connection. This can occur if you leave the connection idle for too long

This question is not answered This question is not answered

When connecting to O365 email account in Outlook 2007 via IMAP. Outlook periodically errors out with a modal popup error message: "Server closed the connection.... idle for too long". It appears to happen to Outlook 2010 as well except that it does not generate a modal popup message; it only says "Trying to connect...".


I can understand if O365 wants to close the connection; as long as it reconnects when I am browsing the mailbox, it is fine. However, the pain is the modal popup message dialog.


Furthermore, I read from the internet other sources that this message may not be what it says it is, and can be due to other error. How can I further troubleshoot the error? Any known issues in KB? Any workaround?

e.g. http://www.office-outlook.com/outlook-forum/index.php/m/168216/ presents a hacky method.


Note that this Outlook profile already has 1 primary Exchange account (also O365) and hence the secondary account has to be IMAP.




All Replies
  • Just a heads up (not sure if this is related to your issue), but some recent update they did now limits you to 1 concurrent connection to a mailbox.  If other people are trying to access the IMAP account you are going to get bounced out a lot or constantly get prompted with the username/password box (experienced this the hard way).

    1 out of 1 people found this post helpful.

  • Hi Jake,

    I understand it is annoying that you always have to face the pop-up window. Just want to check if there is some check box like remember credential to save the credential to auto provide for the pop window.

    Indeed Outlook 2007 only support one Exchange account, will it be ok if you can create multi Outlook profile for each Office 365 account? You can go to control panel, mail, show profiles and click add to create additional outlook profile.

     

    Hi Nick,

    Is there any solid resource you can share that indicates the IMAP concurrent connection has been set to 1? Per my latest tests, I can connect multi clients to use IMAP to connect to Office 365 account. No connection drop if a new one was added.

     

    Thanks,
    Lester Zhang

  • Hi Lester,

    The pop up looks like this:

     

     

    After I click OK, the dialog goes away. Then when I click on one of the IMAP folders, the connection is auto re-establlished. There is no need to provide password.

     

    And Thanks Nick for Sharing.

     

  • You can reference my old ticket: [SR number removed by Moderator]

    "This is George Bonte with Microsoft Online Services Technical Support.

    Unfortunately with the latest version of Exchange Online, we only support a maximum of 1 concurrent connection(s) to an IMAP mailbox. "

  • Hi Jake,

    Thanks for the shapshot.

    Based on the error information, I found some solutions mentioned that disabling Schedule and automatic send/receive option in Tools>Options>Mail Setup> Send/Receive, this solution has also been provided in the discussion thread of your first post. Have you tired this option?

     

    Hi Nick,

    Thanks for the information. To protect privay, I have removed SR number.

    I will contact the case owner to get this confirmed.

     

    Thanks
    Lester Zhang

  • Hi Lester,

    But disabling automatic/send and recieve is not ideal, right? I want to have it automatically send and recieve.

     

    Also, in regards to Nick's responses, I also indeed have 2 users concurrently accessing via IMAP on outlook 2007 on that account.

     

    Only one user has this problem.

     

    Is there anything to do with Permissions?

  • Hi Jake,

    Thanks for your information. The setting can improve this situation is entened the server idle time. (by default the setting is 10mins). Further, I'd like to know you mentioned there are 2 user use the same email configuration . Are they in the same location? Have you tried to test with only one computer in a non-peak time?

    Thanks., Neo Zhu

  • Hi Jake,

    Disabling the schedule send/receive will not break the sending and receving.

    Based on my tests, even Schedule and automatic send/receive option disabled, the email will be sent and received almost immediately.

    Thanks,
    Lester Zhang

  • Hi Jake,

    How is the thing going? Is there any update of this issue?

    Thanks,
    Lester Zhang

  • Hi Lester,

    Still no go. The error pop up is still around, although less frequent.

    I am still trying to reproduce the issue consistently. On some set ups, the pop up is more frequent than some others.

  • Hi Jake,

    One of the easiest workarounds for this issue with Outlook 2007 is to create a second Outlook profile, and have the user switch between the two profiles to check the mail for each,.  This avoids having to set up a secondary account as a non-Exchange connection and actively keeping it from timing out.

    Another option would be to replace Outlook 2007 with Outlook 2010.  In 2010 you can have multiple Exchange mailbox connections, which would allow your user to actively monitor both mailboxes from the same profile.

    Best regards.

  • Hi Kenneth,

    Your "easy workaround" will not work because users need to transfer files between the two accounts. Please tell me, how can I accomplish that with 2 profiles?

  • Hi Jake,

    If you are unable to upgrade to Outlook 2010, you can set up the secondary account using POP settings.  This allows you to display both mailboxes on the same profile.

  • I am having this same issue on Outlook 2007.  Was there a resolution to this?  Was there a hotfix released for this issue?

  • Hi ryanlucas13

    Thanks for finding this my post. This problem is not resolved. I had to upgrade to 2010 or live with it at the moment.