No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

DExchange online OWA: Add public folder pup up in OWA not working

This question is not answered This question is not answered


Add public folder pup up not working, any known issue?


All Replies
  • Tried different browsers?

    I have the same issue in firefox.

  • have tried in latest editions of IE, firefox and chome but issue persists

  • Mgerio:

    I reproduced the issue as well.

    I know that Microsoft recently updated some services in Exchange and this could very well be one of the unforeseen results. I would recommend submitting a service request to let them know of this behavior.


  • I've opened a case, will keep thread updated.

  • Hi All,

    Currently, we haven’t received the report that the “add public folder” option can’t be used in OWA. But I also reproduced the issue on my side.

    The problem has been in investigation and I’ll reply to the post once I get the updates. Sorry for the inconvenience caused.

    In addition, I have sent the private messages (your details > Private messages) to all of you. If you have an SR (service request), could you please share the SR number there? With that, we can check the logs and get more information about the problem.

    Thanks for your understanding.

    Best regards,


  • Same issue here, seems to be tenant/mailbox version related. On the same PC, same browser, etc, I get the popup in one of my tenants, and no popup in another. Issue was also reported in the Yammer O365 groups, seems it's affecting others as well.

    Please keep us posted.

  • Hi all,

    This is Neo from Office365 support.

    We are currently aware of the issue and reproduced it on our side. We also sent the feedback to the engineering team for the verification.  During this time,  You may need to provide other personal information about the issue in the future. As a result, we would need to continue the troubleshooting directly to avoid publishing some personal information, such as domain information. Your post was responded in a private message with a subject of "Submit a service request". Please check it on the community side.

    We will update you as soon as we have a possible resolution for this issue. I apologize for any inconvenience caused by this issue, and do appreciate your patience and understanding.

    Best Regards,

  • Just to update here as well, the Org versions are the same for working and non-working tenants. The mailbox versions are the same as well, so the only thing that seems to differ is the server on which the mailbox is residing, or the actual farm.

    In addition, I am able to access the public folders using the "Add shared folder" functionality, only showing the popup is not working as expected.

  • Hi Vasil,

    Thanks for your information.
    I have sent a private message to you to collect the tenant information for further troubleshooting.

    Best Regards,
    Jason Jiang

  • Hi Support,

    Any updates here? problem persists. Been days.


  • This issue is being investigated by the relevant team.

  • Hi Mgerio,

    I have checked the status of the issue and got the feedback from the related team: they are still working on the issue and it will be fixed in next build.
    Once the fixed is worked out, it needs some time to take effect.
    We will continue monitoring the progress of the case and keep you updated. Thanks for your understanding and continued patience.

    Best Regards,
    Jason Jiang

  • This should be fixed now.

  • Hi All,

    Thanks again for your time and efforts.
    The issue will be fixed in the next build. However, there is no detailed timeline now.

    As a workaround for the mail-enabled Public Folders, please refer to the following steps:
    In OWA, right-click on the name of the mailbox in the folder list, and then select to add mail-enabled public folders via the “add shared folder” option.
    There is no known workaround for Public Folders that are not mail-enabled.

    We will check the progress of the issue and let you know if there is any update.
    Thanks for your patience and understanding.

    Best regards,
    Jason Jiang