No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Email sync stopped working today - invalid certificate?

This question is answered This question is answered

Hi there,

I've been happily syncing my Exchange Online (via Office365 subscription) to my Windows Mobile 6.5 phone with no problems... getting emails, contacts, etc.  It sync'd fine this morning then started reporting:

The security certificate on the server is not valid. Contact your Exchange Server administrator or ISP to install a valid certificate on the server.

Support Code: 0x80072F0D

I can open a browser on the phone and login through OWA, no problem.  My Win8 tablet and Win 7 laptop are still working fine (using Outlook clients and Windows 8 mail).

I tried dropping the exchange partnership on the phone and the re-adding it... it sync'd the first time, telling me the certificate was invalid but giving me the option to ignore it which I did... brought down everything fine but now won't sync again.

I've googled and looked for solutions but to be honest get a little lost on what certificate I need to put where... and why I even need to worry about certificates with a hosted Exchange service from Microsoft running on a Windows mobile. 

So what do I do?  Is this a problem with my hosted Exchange and can I do anything about it or is it a problem on my phone?  Don't know where to go from here or why it would stop working this morning.

Many thanks for any advice!

1 out of 1 people found this post helpful.

Verified Answer
  • Hi all,

    Very pleased to see it looks like we're al up and running again - thanks all for contributing to the post and keeping the pressure up.

    Cheers all!

All Replies
  • Hi WebGeorge,

    In order to narrow down the cause, please try setting up another user’s account on your Windows Mobile 6.5 phone if possible.

    And could you please do the following steps for me? I want to check whether a complete refresh can fix the issue:

    1. Login to Outlook Web App.
    2. Click the gear icon on the upper right corner and click Options.
    3. Navigate to phone > mobile devices. Remove your phone from the list.
    4. Wait for several minutes, and then remove the account from your phone.
    5. Then set up the account again. Please make sure that you are following the steps from this article: Set up email on Windows Mobile 6.5.

    If there are any updates, please don’t hesitate to post back.

    Henry Huang


  • Hi there, I have exactly the same problem since today and described it in the german community. Seems that something general goes wrong:



    1 out of 1 people found this post helpful.

  • Well at least it's nice to know I'm not alone :-)

    If I find a solution I'll be sure to post it here for you to see.  

  • Thanks Henry.  Unfortunately I can't try another account... but as Carsten below has reported the same problem I'm pretty sure it's not my phone or my account - I think it's a problem with the certificate on the Exchange server.

    I'm trying your other steps above right now...

    Steps 1 - 4 all good (FYI at step 3 it's under "Phone" not "Mobile Devices" in case others are looking).

    Step 5 my phone again complained about the invalid certificate (same as it did when I previously tried deleting the account and recreating it though not through OWA) and again gave me the option to proceed which I did.  Everything synced fine as reported previously.

    I then tried to sync again - same problem.

    So summary - have now tried 2 different ways to delete the partnership and re-do it... both time it works first time only because it gives me an option to ignore the invalid certificate on initial setup but never gives you that option again.

    Can it be as simple as an expired certificate on the Exchange Server that only impacts older Windows Mobile devices (with older certificates)?  I don't know much about certificates but it seems to point that way?

  • Great - thank you!

    In case I get a valid answer in the german community, I'll let you know...

  • Hello WebGeorge & Carsten,

    Thanks for your reply.

    After checking from our side, I have not yet found any on-going service incidents about Windows Mobile 6.5. And at this moment, we haven’t received other users' reports regarding the similar issue.

    @Carsten, do you have any colleagues also using Windows Mobile 6.5 and don’t encounter the same issue? If possible, please try setting up another account on your phone to see if the issue occurs. It can really help us identify where the root cause lies.

    Best Regards,
    Henry Huang

  • Henry - I utilize Office 365 and I have a single device that stopped working on Thursday July 10th (3 days ago).  I use a WebOS Palm Pre Plus.  It was working perfect until July 10th at which point it started reporting SSL Certificate Invalid.  The native logging on the device is poor and I'm still working to get more specifics on what the issue truly is.  It was reporting the error on the 10th, but still sporadically receiving email until it finally stopped the next day.  I have completely wiped the phone and reinstalled everything from the HP doctor tools (including establishing a completely separate and new profile for the device with Palm / HP), the SSL certificate error continues.  This was of course after attempting to re-setup the account multiple times with no positive results.

    I have utilized Office 365 admin tools to completely remove the phone from account and re-establish the connection, but still nothing but certificate error.  After the last setup - I did get a partial sync, but I haven't had a successful message come down in about 36 hours.  Office 365 eventually denies access to the phone as it must be attempting to sync to often due to the failures.  I can "force grant" access to the device, but it has no impact on the issue.

    I know we are talking about different platforms here - but it would appear that we have a common timeframe and same error regarding the certificate.  I'm happy to add additional comments or provide additional info.  Right now, my phone has become a glorified paper weight and I will likely have to replace it this week if there is no solution in sight.  I am however happy to see that I am not alone - and that there may be a service related issue yet to be discovered.

    Also, I use an Android based tablet (Nexus 7) as well as Outlook 2013 running on Win 7 - no issues or interruption of service in either of those environments.  We also have an Android based phone used on Office 365 (older version of Android 2.2 - no issues experienced).

    Thank you.


    1 out of 1 people found this post helpful.

  • Hi Michael,

    Sorry to be welcoming you the problem!

    Definitely seems like it's platform / account independent and related to certificates which are only used when syncing to some mobile devices.  Maybe an older certificate no longer used by newer platforms - hence our other devices are still working fine?

    Henry any updates / thoughts?

    Weirdly my phone has started working rarely...  as in it seems to work once a day and then immediately starts failing again, and it works differently to before.  It used to be that if I went into my inbox (on my phone) and then went Menu >  Send/Receive it would fail, but if I went into ActiveSync directly it would work (and it also worked on the schedule).  Now it's the opposite.... it seems to work once a day through the inbox option but never through ActiveSync.  Seems weird - but true.  (i.e. my schedule is set to sync between 8:30 and 18:05 - and my phone sync'd at 8:30 this morning but has failed ever since)

  • Hello everybody,

    We have like 100 users using Windows Mobile 6.5 devices (Motorola MC75/MC75A). Their email is not syncing anymore since July 10th. The error is the same, regarding the invalid certificate.

    We have opened a service request but so far no solution.

    We have tried installing on the devices also the intermediate certificates from No luck.

    The email can be accessed via anything (OWA, Outlook, Windows Phone, Android, iOS), but Windows Mobile.

    A question on which we didn't found yet an answer is if Windows Mobile is supporting SHA2 certificates. It looks that whatever change was made on the Office365 infrastructure, now the certificate used is the SHA2. Maybe Windows Mobile 6.5 is not supporting SHA2?


  • Hi WebGeorge,

    I have spent 3 hours on the phone to Microsoft to various support staff this morning due to this issue. We originally logged a ticket last Friday and no-one seems to have helped at all. We're using Windows Mobile 6.5 on Opticon H-22a's. We're also receiving the exact same support code across various users and a variety of Office365 licenses.

    However, there hasn't been any service interuptions on other devices though (currently using Andriod and Windows Mobile 8).

    Any help or advice would be greatly aprreciated.


  • we are in the same boat.  All of our Windows Mobile devices stopped syncing at some point on 7/10.  The Sync gives a 0x80072F0D error and says the security certificate of the server is not valid.  My guess is the CA certificate expired within the Mobile OS.  If I browse to, I get the same expired certificate message.  Browsing the same site on any other device works fine.  I've tried exporting each certificate from the chain and manually installing it on my device, but that hasn't helped.

  • @MatthewSRoach Sorry to hear of your situation but I'm glad this isn't localised to our company. I've been bounced around from various MS deparments (XBox Customer Support, Windows Mobile Support, Office365 Support) and no one seems to be able to help. Currently have 2 tickets open so I'll post up an resolution (If there is one!). My biggest fear is that MS has decided to discontinue support for Mobile 6 and 6.5, which will leave us with 50 obsolete devices.

  • Ouch.  I've only got 2.  We've moved almost everyone else off these devices.  I also posted something to the Spiceworks form.  There are lots of smart people there too.

  • I can confirm that I have similar results to Matthew (on WebOS - version  When I attempt to access the site through the browser it states that the certificate at is expired - although the Exchange error says it is invalid (but does not state it is expired).  Even though I was able to still accept/trust the certificate this had no impact on the Exchange connection on the device and the problem persists.  I also attempted to install all of the certs in the chain on the device after manually exporting from my Windows 7 workstation, but that also had no impact.

    From a WebOS standpoint, I setup a WebOS 3 device (HP Touchpad) and that had no issues performing the Exchange sync (like most other devices I have attempted to use).  Granted it is a newer version of WebOS, but it did work without issue.

  • Hello Everyone,

    Apologies for spamming this forum by posting excessively but we've just had an update from Microsoft Support. Looks like they have dropped support for Windows Mobile 6 and 6.5.

    Here's a link to the current life cycle support:

    Since Mobile 6 and 6.5 aren't listed, the support has already been discontinued.

    Good luck to all.