not receiving email

This question is answered This question is answered
We've setup a test Office 365 account and have no trouble sending out email but are not receiving any email at all, whether addressed to user@domain.onmicrosoft.com or user@domain.com.  Mail sent to these addresses disappears with no delivery receipt.  We've been through the available configuration and nothing is out of place.  DNS validates properly.  This is not a BPOS migration.  This appears to be a problem with Office 365 mail routing.  How do we go about getting it fixed?

1 out of 1 people found this post helpful.

Verified Answer
  • Found the problem.  Forwarding set.

All Replies
  • Found the problem.  Forwarding set.


  • Dear Reolf,
     
    Thank you for your reply and the additional feedback on the root cause what you have found in resolving this issue. I understand that after setting forwarding, the issue was resolved. I have marked your answer as an answer for this issue. This is so others may benefit from the suggested resolution.
     
    If you have any other questions when using Office 365 in the future, please feel free to post it in the forum. In addition, you can also find useful information on the websites below:
     
    For Office 365 Enterprise: http://onlinehelp.microsoft.com/en-us/office365-enterprises/default.aspx
    For Office 365 Professionals and Small Businesses: http://onlinehelp.microsoft.com/en-us/office365-smallbusinesses
     
    Thanks,
    Monica Tong
  • Monica/Reolf,

    Can you expound a little more on what "forwarding set" means?  I'm having what might be the same problem.  

    Thanks,

    John

  • Hi John,
     
    When you say "I'm having what might be the same problem”, are you referring to the same issue that you can send emails successfully but not be able to receive on your side, as Reolf experienced?
    If so, would you please refer to the troubleshooting inbound mail flow wizard below to see if I have addressed the issue?
    http://community.office365.com/en-us/w/exchange/inbound-mail-flow.aspx
     
    If the issue persists, I also suggest you opening a new thread about your questions and detailed information for us to better help solve the problem.
     
    Thanks,
    Grace Shi
  • Grace,

     

    That's the problem I'm having.  I can not receive email from a non-Exchange account.  I've followed all steps in the instructions you referenced.  When I run the domain troubleshooter I get the following conflicting message:

     

    Troubleshoot domains

    Some DNS records at your registrar are not correct.

    If you already made changes to your account at your registrar, ensure that you entered the information correctly. Learn how

    Exchange Online

    The DNS records for Exchange Online are correctly configured with your domain registrar.

     

    I was able to verify the domain settings through the "verify" link on the domains page.  I've tried to set them according to instructions, but my registrar, MyDomain.com, has a weird interface, so I'm not sure.  I was able to verify the domain settings through the "verify" link on the domains page.  What else can I try?

     

    John

  • Hi John,

    Thank you for your updated information about your situation.

    I understand that you were able to verify the domain settings through the “Verify” link. John, is the status for domain show “Verified”? If so, it means that the domain has been successfully added and Office 365 has verified that you own it.

    After you add and verify your domain, to complete the process so that you can use your domain in Office 365, you must update your name server records, the DNS records that direct your domain traffic, for your Office 365 account. After you switch your name server records, Office 365 hosts all DNS records for your domain and automatically creates the required records for services, such as email and Lync Online.

    Need detailed instructions for changing the domain name server records on popular domain registrar websites? If you’ve just completed the Add a domain wizard, click Change name server. Otherwise, see Change name server records at a domain registrar

    If the issue persists after changing Name Server records, you can refer the following article to troubleshoot the issue.
    http://onlinehelp.microsoft.com/en-us/office365-smallbusinesses/gg549199.aspx#bkmk_added

    The causes are different from the configuration. If the issue persists, to better follow up the issue, I suggest posting a new question in the forum with the detailed problem description and error message.
     
    Thanks,
    Monica Tong