No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Fail to sync with Exchange ActiveSync on an Android - "unable to open connection to server due to security error"

This question is answered This question is answered
Hi
I'm using Android 2.3.3 on Samsung Galaxy S2.
I confogured the mail account as described here:
I used the pod address I got from my OWA settings.
The account definition went fine. At the end of the defenition i got a message that the admin of my exchange server need to have some security access to my device and i approved it.
But when i get into the acount and try to sync it i get the following error: "unable to open connection to server due to security error"
I tried to go back and redefine the connection to the server, but now I consistently getting "Setup  could not finish - unable to connect server" error. This is for the same settings that passed this stage earlier.
Thanks
Lior

6 out of 10 people found this post helpful.

Verified Answer
  • I had the same problem with my new Galaxy s2. After spending a lots of wasted hours reconfiguring the account, changing settings, etc. I discovered that when the account is set up correctly on the phone a notification is sent to it. This has to be opened in order for the account to work. Unfortunately the Galaxy phone hides the notification window and gives no indication that a notification is present. Try swiping down from the top of the screen to open it. It worked for me. My phone is now syncing just fine and I can send and receive emails from my exchange server.

    0 out of 3 people found this post helpful.

All Replies
  • solved.

    there was an additional security confirmation waiting and hiding in a background process. found it eventually, confirmed it, and it solved the issue.

    0 out of 2 people found this post helpful.

  • I had the same problem with my new Galaxy s2. After spending a lots of wasted hours reconfiguring the account, changing settings, etc. I discovered that when the account is set up correctly on the phone a notification is sent to it. This has to be opened in order for the account to work. Unfortunately the Galaxy phone hides the notification window and gives no indication that a notification is present. Try swiping down from the top of the screen to open it. It worked for me. My phone is now syncing just fine and I can send and receive emails from my exchange server.

    0 out of 3 people found this post helpful.

  • Also note: You might want to try connecting using "m.outlook.com rather than podxxxxxxx.outlook.com in case your mailbox moves to a different POD.

    (that is try to connect with m.outlook.com, if that does not work THEN use the podxxxxxxxx.outlook.com)

    -Neil

    0 out of 2 people found this post helpful.

  • This is exactly what happened.

    also have Galaxy S2. also got the confirmation page hidden.

    finding it after few hours solved the ptoblem.

    thanks

    Lior

    0 out of 2 people found this post helpful.

  • This isnt fixing the problem for me. I swipe down and allow the security change to the phone and 30 sec later it is back.

    Window heading     ! Security update required

    body                       Update security settings to use domain name

                                        OK or Cancel

    I delete the account from my phone and readded the account everything was working fine for a hour or 2 but now its back to the same "Update security settings".

    This Just started today 6/1/2012 and NO changes have been made on my part to my phone or office365.

    Please help!!!

    0 out of 1 people found this post helpful.

  • same here. same notifications, I open it, ask to update and it does not work.

    I have deleted my account and rebuild it. It always hang up when it reaches the first mail dated 06/06/2012

    Any suggestion?

    0 out of 1 people found this post helpful.

  • I have a Samsung tablet with the same issue.  For me, I had to change the security on the device from PIN protection to PASSWORD protection.   It seems like the requirement to "at least have a PIN protecting the device" and Samsung's PIN locking system don't jive.  The password is a more secure option of locking down the device and Exchange/Samsung seem to play well when it's set that way.    Hope that helps.

    1 out of 2 people found this post helpful.

  • I have had no luck with this problem either on my Galaxy Note running Android 4.0.  I have tried changing the lock from PIN to password, and this had no effect.  I have tried accessing any latent dialogs that might have shown up to no avail.  I've tried deleting the account and re-adding it, and it only works for a brief period before failing again.  

    I did notice last night that I could connect via HSDPA / HSDPA+ but not via WiFi.  As soon as the WiFi was turned on, I started getting the 'unable to connect to server due to security error' messages; as soon as I turned it off, I was able to download and send emails.  Outside of email, the WiFi connection seemed to be OK.  

    On Android 2.3 on the Galaxy Note, I never ran into any email problems like this.

  • This problem is due to the latest updates for Samsung Galaxy. The active sync downloaded is not 100% compatible with office 365.

    Hence, after a lot of researches, the only solution I have chosen was, to buy from google play the following email client "touchdown".

    You can try it for 30 days and then, the license is 20.99.

    It works fine, it synchronises email, calendar, contacts and... very fast without any problem.

    Good luck

  • Same problem on a Galaxy S3. One mailbox is working but not the other one! Both on Office 365.

  • Lior, can you elaborate?  How does one find the background process and reply to it?

  • this is very helpful, I change it and it immediately worked!