No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Delivery Report AD Error

This question has suggested answer(s) This question has suggested answer(s)

When I attempt to run a delivery report I get the following message:

! Server in domain encountered an error reading an Active Directory object or attribute. Diagnostic information for this error: DefaultDomain not found in Organization First Organization.

Sounds like an error that could have larger implications; how can I fix it?

Using Exchange Online (only) in trial E3


Wes Jones

All Replies
  • Hi Wes,

    I understand you received an error message when you run the Delivery Report.

    Are you using custom domain with Office 365 service?  And is there any other users in this Office 365 tenant who have the same problem?

    If you are using custom domain, please follow the steps below to change the custom domain as a default domain.

    1.Connect PowerShell to Exchange Online.

    You can refer to this link to configure PowerShell.

    Then follow the steps to connect PowerShell to Exchange Online.

    2.Run the Cmlet below.

    New-AcceptedDomain -DomainName <>-DomainType Authoritative -Name Yourdomain
    Set-AcceptedDomain -Identity Yourdomain -MakeDefault $true

    If you encounter any error message when you are running PowerShell, please capture and post to this thread.
    After the above steps finished, please try to run the Delivery Report in Exchange Control Panel (ECP) again.

    Ray Yang

  • Thanks for the reply - this is what I get, though. Couldn't copy and paste from PS..?


  • Was this just a one time error? Was the error for an address with a domain you've verified as being authoritative for (if so, was it just recently verified)? I just did a quick browse through the powershell commandlets for O365 and I am wondeirng it (assuming it is the right step, you shouldn't actually be using new-msoldomain (check here for how to create a pssesion for msol commands but before you do anythign like that... please let us know if the error was a transient one.

  • I think this is something other than to do with my domain - the shell doesnt even recognize the cmdlet. I have missed something in the setup or something is missing. I will try it on another computer this afternoon (too busy now) I ran it more than once..

    The domain is functioning in ExO as a verified primary domain and we are routing mail through it.

    Could this be related to the same error that I got initially referencing Active Directory?

  • Ah... I originally parsed the issue as an NDR when sending or receiving mail. But it isn't.... you're looking at/for a delivery report. So I'm not sure that the instructions you were initially given apply. In a stand alone org, your issue is basically this one:

    In the hosted world... well, um... check here and see if your domain is listed as verified and possibly fire up the troubleshooter to see if it yields anything?

  • As far as I can tell, the above does not apply here. I am new to Exchange, so I definitely may be wrong, but I think you guys are missing it - the error is essentially 'command not recognized'. It's like theres some library i don't have loaded or something...

    "The term 'New-AcceptedDomain' is not recognized as the name of a cmdlet, function, script file, or operable program... "


  • I did note in the bottom of my first message that I am using Exchange Online. We do not have an on premises server. Is the New-AcceptedDomain command even supposed to work in my situation? Every reference I see to it is in Exchange 2010...

    If not, I guess I am back to my original question which seemed to get lost somewhere along the way... ;)


  • Hi WesJones8480,

    It doens't appear that the command New-AcceptedDomain is supported in Office 365. Here is what I find in the list of commands in PS:

    PS C:\Windows\system32> get-command *-*domain

    CommandType     Name                                                Definition

    -----------     ----                                                ----------

    Function        Get-AcceptedDomain                                  ...

    Function        Get-RemoteDomain                                    ...

    Function        Get-RMSTrustedPublishingDomain                      ...

    Function        Import-RMSTrustedPublishingDomain                   ...

    Function        New-RemoteDomain                                    ...

    Function        Remove-RemoteDomain                                 ...

    Function        Remove-RMSTrustedPublishingDomain                   ...

    Function        Set-AcceptedDomain                                  ...

    Function        Set-RemoteDomain                                    ...

    Function        Set-RMSTrustedPublishingDomain                      ...

    (PS - To copy and paste from PowerShell, left click in the window and drag a box around the desired text, then right click the box. This will copy the text to your clipboard.)

    I do see that the initial issue (not able to run delivery reports) appears to be a known issue:

    with a fix coming sometime in July.

    Let me know if you have any questions,


  • Thanks, Dave -

    I do have a question related to the fact that my error message refers to an Active Directory issue, but it might be getting off the track of this thread so I should probably start a new post..


  • Wes,

    The error points to a disconnect between the Exchange server and the acive directory server. If you had an on premise Exchange server, I would say you need to make sure the two servers could talk to each other. In this case, I believe the Exchange server and Active Directory server in question are both on our side (dirsync just replicates your active directory to our servers), so there isn't anything you need to fix. Since they are predicting a fix in July, I would expect that they have already identified the problem and are testing potential solutions.

    Let me know if you have any questions,