No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Apple Mail "Cannot send message using the server ..."

This question is not answered This question is not answered


I have one user who is using Apple Mail (the version included with OSX 10.7) and every so often gets an error message saying "Cannot send message using the server <email here> (Exchange)". This happens maybe once a day. Sometimes less frequently, sometimes more. The error is the same one shown in the first post of this thread:

The answer in the thread mentioned above is that Apple Mail doesn't support Office 365. Well, I refuse to believe that (as many users did in that very thread). Apple mail has an 'Exchange' mode which as far as I can tell is using EWS to connect to the exchange server. All the user needs to do is put in their email and password and it automatically sets up email, contacts, and calendars (just like Outlook would do). 

Anyways, if the user waits a few seconds, or sometimes minutes, the issue resolves itself and the message will send. I would also like to point out that if the user tries to move any emails between folders around the same time this message appears, they fail with a "Cannot execute move operation" error message. Which to me seems like an error you would get from an IMAP server or an exchange server in online (non-cached) mode. 

This problem in itself is mostly just annoying - until it starts sending multiple emails. If the user chooses to send the email with an alternate SMTP server (as prompted by the initial error box) sometimes, hours later, the same message is resent through the exchange server. I have no idea why that is happening.

All Replies
  • Hi devinwyatt,

    I understand that when you sent email, you often got the error message that “Cannot send message using the server <email here> (Exchange)”. When you try to move the email from one folder to another, you get the error message “Cannot execute move operation”.

    If this is the case, please try to sign in your exchange account from here:, and check if you will meet the some issues of sending email.
    Based on my experience, these error messages indicate that your connection with exchange server is unstable.
    Please try to test your exchange account on other Mac computer or in other network.

    Robert Li

  • Hi Robert,

    I will get my user to try using the online portal for a bit and see if the problem occurs there. I got a typical order of events from him regarding this issue:

    1. At some point during the day while organizing emails (this user keeps <20 emails in his inbox, everything gets sorted into folders) he gets the "Cannot execute move operation" error message. Note that this only happens a few times per day maximum, sometimes it doesn't even happen on a given day.
    2. After receiving that error message, any attempt to send an email immediately after that results in the "Cannot send message using the server" message.
    3. Within a few minutes (usually less than 1 minute) the issue resolves itself and he can send mail again and move emails between folders.
    4. Sometimes, but not always, an email that was sent using an alternative SMTP server (as prompted by the "Cannot send message using the server" message) gets sent again later on using the Exchange connection. This ends up with duplicate emails from him.

    Some other things possibly worth noting:

    1. This user has a large mailbox. Currently using 7.6GB with 10's of thousands of emails.
    2. These emails are all organized into about 1000 folders.

    What I'll get him to do is go to the site and try to send an email next time he gets the "Cannot execute move operation" error. I'll report back with what we find out.



  • Alright, so my user has reported back that when he gets the error messages he has no problem logging in online and sending emails from there. Are there any OSX tools for diagnosing connectivity problems?

  • The following links may be helpful for you from Apple forum.

    0 out of 1 people found this post helpful.

  • Okay so we moved the mac in question to a different network today (completely different physical location) and he has the exact same problems. This issue is usually repeatable if he grabs 100 emails in one folder and tries to drag/drop them into another folder. They will start moving but then error out after 10-20 of them are completed. This is the same "Cannot execute move operation" error mentioned before.

    Also worth noting: the same users iPad and iPhone have started behaving erratically. They will sometimes not be able to connect to the exchange account (he gets a "Cannot connect to server" message). That's bizarre to me because they are a) using ActiveSync not EWS, and b) no one else in our organization are having problems with their iPhones. The fact that he's having problems with both his mac and iPhone/iPad leads the user to be 100% sure it is a microsoft server issue. I'm still not convinced though. I have zero problems connecting to his account in online mode using Outlook on my Windows machine. No errors when moving stuff between folders.

    One thing we are trying now is I moved most of the emails in his sent items (he has 36,000 of them!). I've read about there being issues with more than 10,000 in any of the main exchange folders (Inbox, Sent Items, Deleted Items, Junk). So we'll see if that fixes anything. He was also going to delete and re-add the account in Apple Mail (As well as deleting the account folder and even apple mail plist file).

  • Okay, another update. I have now setup the users account on a different mac on a different network. I'm just waiting for it to sync up before I start to move files around but I'm noticing this assertion failure in the logs. My  user reports that he has the exact same failure in his logs. This message is repeated about 10 times per second while Apple Mail is downloading files.

    06-06-2012 12:22:05.518  Mail: *** Assertion failure in -[EWSGetFolderResponseOperation handleResponseMessage:withObject:], /SourceCache/Message/Message-1278/MessageStores.subproj/EWSResponseOperation.m:340

    EWS did something wrong: An internal server error occurred. The operation failed. on EWS response <EWSGetFolderResponseOperation: 0x7fb9cb1ae620> (EXECUTING)


    0   Message                             0x00007fff8f712ef8 -[MFAssertionHandler _handleFailureWithPreamble:description:arguments:] + 116

    1   Message                             0x00007fff8f71308e -[MFAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 185

    2   Message                             0x00007fff8f662c64 -[EWSResponseOperation handleResponseMessage:withObject:] + 556

    3   Message                             0x00007fff8f656eb6 __-[EWSGetFolderResponseOperation executeOperation]_block_invoke_1 + 77

    4   CoreFoundation                      0x00007fff87979cee __NSArrayEnumerate + 718

    5   Message                             0x00007fff8f6572ae -[EWSGetFolderResponseOperation executeOperation] + 453

    6   Message                             0x00007fff8f73397f -[MonitoredOperation main] + 228

    7   Foundation                          0x00007fff9152e6b4 -[__NSOperationInternal start] + 705

    8   Foundation                          0x00007fff91541912 ____NSOQSchedule_block_invoke_2 + 124

    9   libdispatch.dylib                   0x00007fff8a798a86 _dispatch_call_block_and_release + 18

    10  libdispatch.dylib                   0x00007fff8a799965 _dispatch_worker_thread2 + 255

    11  libsystem_c.dylib                   0x00007fff8c83b3da _pthread_wqthread + 316

    12  libsystem_c.dylib                   0x00007fff8c83cb85 start_wqthread + 13


  • Hi devinwyatt,

    The Apple Mail application is not supported for Office 365.
    Please see for supported software.
    Since this is unsupported, we cannot offer support.

    Robert Li

    0 out of 2 people found this post helpful.

  • Okay how about this: I've now encountered the same (or similar?) problem in Outlook 2011 for Mac. Screenshot below. This happened when moving 200 emails to a new folder on this same users account.

    I setup my own account on a mac to test as well. Doing the same move operation in Outlook 2011 Mac results in NO errors. I can move 1000 at a time with no errors at all. I also tested another users account in Outlook 2011 (he actually uses Outlook 2011 all the time) and he doesn't get errors either. It's just this one user who gets them. I'm thinking it has to be something wrong with his mailbox - is there anyway to run a diagnostic on it or something?

    Oh, and should I make a new thread for this since now we're talking about Outlook 2011?

    1 out of 1 people found this post helpful.

  • You can try to use un-cached mode.

    Or backup your emails, unchecked this user's exchagne online license.

    Save, assign license to this user again.

    Then check this email account. 


  • Thanks for the reply deadline ... it seems that Microsoft has stopped answering (or are just taking their sweet time :p). I think I will create a new thread with my Outlook 2011 issues.

    Do you know how to enable un-cached mode in Outlook 2011 Mac? I don't see any options for it anywhere.

    Do you have a suggestion on what the best way to backup an exchange account is? Something that would be easy to revert to should something go wrong.



  • Hi,

    My previous issues with a user's account in Apple Mail (see this thread: now seem to be happening in Outlook 2011 Mac. When moving a bunch of messages between folders it will give me errors as shown below ("The message could not be moved"). I have also seen sync errors (will try to get a screenshot) after the move fails. This is the exact same error we were getting in Apple Mail. 

    This only happens on one user's account (the same one who has Apple Mail problems). My account and another user's account both work perfectly with Outlook 2011 Mac (the other user uses Outlook 2011 Mac all the time). We can both move 500 messages at a time to another folder and it just works. No error messages, no nothing. Trying that with the problem user's account and it will fail after 50 messages (or sometimes 2, or 30, it's pretty much random). 

    Is there anyway to run diagnostics on an account? Or check it for errors? Another user in the forums suggested I uncheck the user's exchange license, save, and then check it again. Will that do anything? And how can I make a proper backup of the account before I try that - I don't want to lose anything.



  • Alrighty, here's the other error I'm getting. After I move a bunch of messages, the progress windows shows that Outlook is "Updating the server" as well as "Uploading" messages (The ones I moved I guess). While it is doing this I get a bunch of the errors shown below. You will note that it has the same error code (-19907) as the previous errors I showed.


  • Interesting ... my new thread got merged with this one? I've now rejected the previously accepted answer so that Microsoft support might take a look at it.

    Thanks for the link FromMars, but I don't think creating a new identity (the suggested answer at that link) will solve anything. When I initially setup this account for testing it was on a brand new OSX user account so that in essence was a new clean identity.

    At this point I can't see how this can be a client side issue - this one particular user's account gives 19907 errors in both Apple Mail and Outlook 2011 (which both use EWS), as well as "Cannot connect to the server" errors on iPhone and iPad. No other accounts have these problems on any platform.

    0 out of 1 people found this post helpful.

  • Still looking for an answer to this. I have two users, 1 with a MacBook Pro and 1 with a MacAir using Office 11. I've read through multiple forums. They have been working until today.