No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

This account does not have an Outlook Web App mailbox.

This question has suggested answer(s) This question has suggested answer(s)

I have the exact same problem as in this thread:

I moved from a P1 to E3 plan, and after about a week, any users that are given an email address at the primary vanity domain can't access an OWA account.  The account can send and receive email through Outlook, and changing the domain for the email account will allow it to be accessed through OWA.  I've created multiple users, all have the same result.  I checked permissions via powershell and they have OWA access enabled.  

What steps do I need to take now?


All Replies
  • Hi Southbound,


    Thanks for posting here, please check if you have assigned Exchange Online license to this user. If you have already assigned an Exchange Online license to it, please remove it, wait for about 20 minutes, and re-assigned the license to see if it works.


    In addition, I would suggest you use the following cmlet to see if OWA has been disabled for your account:

    Get-CASMailbox -Identity usermailbox| FL *owa*

    The expected output is:


    OWAEnabled :True

    If the result show false for your mailbox, please enable it with this cmdlet:

    Set-CASMailbox -Identity usermailbox -OWAEnabled:$true


    Additional information:


    Connect Windows PowerShell to the service:


    If there are any other questions, please feel free to contact me.



    Allen Qiu

  • I have tried  both of those solutions and neither worked for me.  Is there something else I can try?

  • Hello Southbound,

    If I understand correctly, everything worked for a week, and then users with the primary vanity domain started getting errors? Is the error the same as the linked forum thread above? ("This account does not have an Outlook Web App mailbox".)

    When users' email address is set to the primary vanity domain, is their login set to the same address, or do their login ID and primary email address not match?

    Also, are you in any kind of coexistence?

  • Hi southbound,

    Deleting the domain and reassigning it might work. I had similar issues after moving my account from a P1 plan to Exchange Online and tried several things. Eventually deleting the domain and adding it again did the trick.