No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Failed to update one of the recipient properties

  • Failed to update one of the
    recipient properties. Couldn't find a user or contact with identity
    "/o=AVALONGLOBAL/ou=FIRST ADMINISTRATIVE GROUP/cn=RECIPIENTS/cn=username

     

    Performing cutover migration on Exchange 2003

  • Tried the information in both KB articles

    support.microsoft.com

    support.microsoft.com/.../en-us

    And still getting the same error

  • Hi WidePoint2012,

    Thanks for posting here.
    I understand you choose to Cutover Exchange migration to migrate mailboxes from on-premises Exchange server to Exchange Online and got this error message.

    Failed to update one of the recipient properties. Couldn't find a user or contact with identity "/o=AVALONGLOBAL/ou=FIRST ADMINISTRATIVE GROUP/cn=RECIPIENTS/cn=username”. This error indicates the object of user name cannot be found. Please make sure the user's email address is valid, and can be accessed by the account which you provided at the step 1 of migration. Are all the recipient distribution groups which have this user as member?

    Thanks,
    Grace Shi

     

  • The account I'm using for the migration, which is the same that is giving the error, is the enterprise admin account for our entire domain. It was added to the exchange 2003 database as full access as well.

    This error is occurring on about 90% of our mailboxes that we're trying to copy over.

  • Hi WidePoint2012,

    Thanks for your update.
    Since this issue is occurring on about 90% of mailboxes, it may be caused by the migration administrator permission to access mailboxes in your organization.
    Would you please refer to the articles below and make sure the on-premises account that you used to run a migration batch have the necessary permission?

    Microsoft Knowledge Base article 268754 -  How to assign users or groups full access to other user mailboxes

    Microsoft Knowledge Base article 821897 - How to assign service account access to all mailboxes in Exchange Server 2003

    Thanks,
    Grace Shi

     

  • Grace, as I mentioned in my 2nd post, I followed both of those articles. The administrator account I am using has Full Access on the exchange 2003 database as well as all the mailboxes and the entire domain.

  • first, from the returned information, the user's legacyExchangeDN is missing, you can go to check it by using tool ADSIEDIT or run this cmdlet in Exchange 2010:

    Get-Mailbox 'your mailbox' | fl name,legacy*

    if the value is missing, try to "remove exchange attribute" ->run cleanup agent on the mailbox store which host the mailbox -> reconnect the mailbox to reset the value. Or use adsitedit tool to configure the property manually.

    second, ensure the option “include inheritable permission” is checked in the securit tab on the user from ADUC

    third, I think you can  move mailbox to a new created database store in on-premises side to have a try

    0 out of 1 people found this post helpful.

  • Hi WidePoint2012 ,

    Did answers from James help you? Let us know if you need further assistance from us.

    0 out of 1 people found this post helpful.

  • The legacyExchangeDN is present and correct

    The include inheritable permission is checked and the user has Full Control

    We've moved the mailboxes to a seperate server and still getting the same error

    I have opened a ticket with support and they are recommending we do a staged migration since they can't figure out what's wrong.

  • Hi WidePoint2012 ,

    OK, please update us if do a staged migration will fix the issue. Thank you.

  • Already having issues with the staged migration, the email migration job we created to run is listed as corrupted and we cannot delete.

    Can't find the migration batch "C1" for "namprd06.prod.outlook.com/Microsoft Exchange Hosted Organizations/widepointsolutionscorp.onmicrosoft.com - namprd06.prod.outlook.com/Configuration/Services/Microsoft Exchange/ConfigurationUnits/widepointsolutionscorp.onmicrosoft.com/Configuration".

    This is happening on every job we try to create, despite following the instructions to the letter.

  • I have the exact same error when I try to delete current migration jobs.

    on the other hand any new migration I'm trying to make I get the Corrupt status and I can't change it.

    anyway eventually I'll have to delete the current migrations. I also try to remove them using powershell but even thought the identity exists - I get the error message: Can't find the migration batch "test" for "mydomain.onmicrosoft.com"

    did you manage to solve it ?

    thanks

  • Hello WidePoint2012,

    is your issue resolved from the service ticket?

  • yesterday I saw the corrupted migration batches were deleted from my queue finally.

    but at the Planned Maintenance I can see that the issue still exists and I'm afraid to start a new migration and to be stuck for another week with this issue

  • Has this issue been resolved and, if so, can you post a solution?  We are in the midst of a migration and have the identical issue occurring with four accounts.  We are seeing  the error:

    Failed to update one of the recipient properties. Couldn't find object "/o=<name>/ou=<domain name>/cn=Recipients/cn=<user name>". Please make sure that it was spelled correctly or specify a different object.

    This is a show-stopper for us on this migration.  The accounts this is happening on are four of the upper-level corporate executives.

    The user account referred to in the error does exist, is in use, and we have confirmed that the "legacyExchangeDN" exists correctly on that account.  The account referred to does have at least "send as" permissions on the accounts returning the error (the user referred to in the error is the administrative assistant for the executives).  I've tried removing the user from "send as" permissions and adding it back, and I've tried adding the permissions through powershell, but the error still shows up.

    I will, most likely, open a direct phone support ticket on this, but any assistance I can also get from here will be appreciated.

    Regards,

    Scott