Windows Mobile 6.5 Outlook stuck on Connecting... and does not sync emails

This question has suggested answer(s) This question has suggested answer(s)

I have an old HTC Touch Pro2 Windows Mobile 6.5 phone that I would like to connect Outlook to my Office 365 accounts via Exchange. I followed the steps at: http://technet.microsoft.com/en-us/exchangelabshelp/dd125428

I can send myself an email to any other account and I get it on my computer. However, if I reply to the test message, it either takes forever to come to the phone, or doesn't at all. Plus, it never downloads any old messages. 

ActiveSync says that it is trying to sync but has been running for a while. There are very few emails in the account I'm trying to setup on the phone. 

Outlook on the phone just says "Connecting..." when I tap Send/receive. 


This phone is no longer activated on Verizon, but it is connected and working fine through my wifi network. 


What can I do to get my emails working?

All Replies
  • Hi TC10284,

    Thanks for posting here. I understand that you would like to configure Exchange ActiveSync account on your mobile device, and experienced this sync issue. Is it right?

    If it is the case, as you could not receive emails on your mobile device as expected, would you please verify if this account has enable Exchange ActiveSync, and then follow this article and check if the issue persists?

    Verify that Exchange ActiveSync is enabled or disabled for this user.
    http://help.outlook.com/en-us/140/ms.exch.ecp.editeasmailbox.aspx

    Set Up Exchange ActiveSync E-Mail on Windows Mobile 6.5
    http://help.outlook.com/en-us/140/dd125428.aspx

    Thanks,
    Grace Shi

     

     

     

  • I am still unable to sync. I just took a look at the settings you requested and they have not changed. I did delete an old Android phone from ActiveSync Allow list just now, as well as gave permission to Sync on the iPhone I have. But this should not have any effect on the RHOD500 (HTC Touch Pro2 Win Mobile 6.5).

    Here is the information:



  • Hello TC10284,

    Sorry for the delay in response; I would like to know if this issue has been resolved or is it still outstanding?

    All the best,
    Ryan E. Geiger