No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

365 email unable to connect to SMTP server

This question is not answered This question is not answered

I am unable to send email via the SMTP server from one of the server.  The server was working for a few months and suddenly not working since yesterday.  I tried to reboot the server but still have the problem.  I also tried to telnet to the SMTP server port 587, and it failed, I can telnet to the same port from my other servers.  I checked the hosting company of my server, they said they won't block the outgoing port and they suspect that its the SMTP server that is blocking my ip.  Any idea on how to solve this problem?

All Replies
  • Hello Chunhui,

    Which email client you are using to connect to Exchange Online, Outlook 2007, Outlook 2010? Did you add your mailbox account into outlook client using autodiscover service, or configure it manually?

    Since users' mailboxes could be moved to another server due to upgrade, maintance, failover, etc, to narrow down the problem, please refer to steps in article below to repair the connection to your acount in cloud to check if the problem can be fixed.

    Repair the Connection to Your Account in Outlook

    Thank you.

    Jack Sun

  • Hi Jack,

    We are sending email by sqlserver trigger and a in house C# program at this server.  We have setup the SMTP relay server so that the email can be sent to  The OS is Windows 2008 R2 Server.   Do you have any idea on what may go wrong?

  • Hello Chunhui,

    Thank you for your clarification.

    Just as I mentioned in the previous post, the server name of users' mailbox might be changed over time. To troubleshoot this problem, please try the steps below to verify if the server name of user mailbox has been changed.

    1. Access your mailbox via OWA at

    2. On the Outlook Web App toolbar, click Help > About.

    3. On the About page, you'll see the entry for the Host name listed.

    4. Use the value next to the Host name as the server setting of your application on your sql server.

    Thank you.

    Jack Sun

    1 out of 1 people found this post helpful.

  • Hi Jack,

    I checked the host name, the host name  has been changed to  I changed the address but still can't connect to the SMTP server.  

  • Hi Jack,

    The followings are some screenshot for the setting I made and the error I got in event viewer.

  • Hi,

    Have you tried to setup your SMTP relay as suggested in this article?

  • Hello chunhui,

    Sorry for the delay in response; I would like to know if this issue has been resolved or is it still outstanding?

    All the best,
    Ryan E. Geiger