No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Cannot publish/share calendar

This question has suggested answer(s) This question has suggested answer(s)

In Office365 OWA I have tried Share/Change Publishing Settings on the calendar and get the following error:

The input object cannot be bound to any parameters for the command either because the command does not take pipeline input or the input and its properties do not match any of the parameters that take pipeline input.

I have tried Share/Send Links to this Calendar and the links do not work.

I saw in another post this recomendation:  

Please try to resolve it by creating a new Calendar sharing policy with the cmdlet below:


 -Name "POLICYNAME" -Domains 'Anonymous : CalendarSharingFreeBusyDetail'

After that, apply the policy to the affected user by the cmdlet:


 "user@domain" -SharingPolicy "POLICYNAME"

The results are as follows, failing on the final statement of setting the mailbox policy due to the error -2146233088 (User and mailbox are in different Active Directory sites...)

Windows PowerShell

Copyright (C) 2009 Microsoft Corporation. All rights reserved.

PS C:\Users\kevin.justice.BCH-MD1> get-executionpolicy


PS C:\Users\kevin.justice.BCH-MD1> set-executionpolicy remotesigned

Execution Policy Change

The execution policy helps protect you from scripts that you do not trust. Changing the execution policy might expose

you to the security risks described in the about_Execution_Policies help topic. Do you want to change the execution


[Y] Yes  [N] No  [S] Suspend  [?] Help (default is "Y"): y

PS C:\Users\kevin.justice.BCH-MD1> get-executionpolicy


PS C:\Users\kevin.justice.BCH-MD1> $LiveCred = Get-Credential

cmdlet Get-Credential at command pipeline position 1

Supply values for the following parameters:


PS C:\Users\kevin.justice.BCH-MD1> $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https:/

/ -Credential $LiveCred -Authentication Basic -AllowRedirection

WARNING: Your connection has been redirected to the following URI:

" "

WARNING: Your connection has been redirected to the following URI:

" "

PS C:\Users\kevin.justice.BCH-MD1> Import-PSSession $Session

ModuleType Name                      ExportedCommands

---------- ----                      ----------------

Script     tmp_05249412-646e-4a62... {Start-ProvisioningRequest, Set-MailboxAutoReplyConfiguration, Set-PopSu...

PS C:\Users\kevin.justice.BCH-MD1> New-SharingPolicy -Name "DefaultSharePolicy" -Domains 'Anonymous:CalendarSharingFreeB


This operation is not allowed for the organization with disabled customizations. In order to enable this operation, you

 need to execute Enable-OrganizationCustomization task first.

    + CategoryInfo          : NotSpecified: (Microsoft.Excha...n.SharingPolicy:String) [New-SharingPolicy], InvalidOpe


    + FullyQualifiedErrorId : CB6694F3,Microsoft.Exchange.Management.SystemConfigurationTasks.NewSharingPolicy

PS C:\Users\kevin.justice.BCH-MD1> Enable-OrganizationCustomization

PS C:\Users\kevin.justice.BCH-MD1> New-SharingPolicy -Name "DefaultSharePolicy" -Domains 'Anonymous:CalendarSharingFreeB


Name                      Domains                                  Enabled    Default

----                      -------                                  -------    -------

DefaultSharePolicy        {Anonymous:CalendarSharingFreeBusyDet... True       False

WARNING: You're allowing users to access the feature that lets them publish their calendars. Make sure that the

Calendar virtual directory has been enabled on the Client Access servers so that published calendars will be


PS C:\Users\kevin.justice.BCH-MD1> Set-Mailbox "" -SharingPolicy "DefaultSharePolicy"

Error code -2146233088 occurred with message The user and the mailbox are in different Active Directory sites..

    + CategoryInfo          : NotSpecified: (:) [Set-Mailbox], RecipientTaskException

    + FullyQualifiedErrorId : 12AD4ECF,Microsoft.Exchange.Management.RecipientTasks.SetMailbox

Additionally, we did convert our Office 365 from an on-premise Exchange server (which makes me wonder if that is why we are getting the odd error about different Active Directory sites).  I have not found any workaround to this problem.  Can you please assist?

All Replies
  • Hi Kevin,

    Thanks for your post. I fully understand your situation when you tried to publish a calendar in OWA. It was coming from OWA interface can't get a properly response from Exchange Online service or Office365 AD back-end service. (could be related to service maintenance or user's profile corruption). However, as a walk-around solution to publish a calendar in Powershell, you can do the following steps:.

    1, connect Exchange online via Powershell (what you have done)
    2,Set-MailboxCalendarFolder -Identity mailbox-alias:\calendar -PublishEnabled $true  (replace mailbox-alias as your user's alias)
    3,Get-MailboxCalendarFolder -Identity mailbox-alias:\calendar (use the information from PublishedCalendarUrl as the publish URL address)

    Thanks, Neo Zhu

  • Neo -

    I was able to do that however I may have a subsequent issue.  The links that the GetMailboxCalendarFoler provided are as follows however both take me to a login page.  The rule I created was a public free/busy calendar so there should not be a need to see a login prompt (especially an Office 365 login).

    I am wondering if I have my DNS setup improperly?  We are aliasing to in DNS (we have DNS hosted elsewhere).  Is that correct?

  • Hi Kevin,

    Thanks for your reply. DNS will not cause this issue. As for this case, could be related to the sharing policy. Could you export all your sharing policy out?

    "get-shareingpolicy"  detail information "Get-SharingPolicy -Identity "Default Sharing Policy" |fl"

    On the other hand, you can publish other user's calendar with OWA UI and see what's going on.

    Thanks, Neo Zhu

  • Here is the output from the sharing policy:

    ModuleType Name                      ExportedCommands

    ---------- ----                      ----------------

    Script     tmp_1e33feae-f16a-4e7c... {Start-ProvisioningRequest, Set-MailboxAutoReplyConfiguration, Set-PopSu...

    PS C:\Users\kevin.justice.BCH-MD1> Get-SharingPolicy -Identity "Default Sharing Policy" |fl

    RunspaceId        : e9ef4270-52d4-475e-af73-b3cdc17b9773

    Domains           : {Anonymous:CalendarSharingFreeBusyReviewer, *:CalendarSharingFreeBusySimple}

    Enabled           : True

    Default           : True

    AdminDisplayName  :

    ExchangeVersion   : 0.10 (

    Name              : Default Sharing Policy

    DistinguishedName : CN=Default Sharing Policy,CN=Federation,CN=Configuration,,CN=Configuration

                       Units,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=namprd06,DC=prod,DC=outlook,DC=com

    Identity          : Default Sharing Policy

    Guid              : 0844526d-2711-44f7-9c1a-fc67d4781c6b

    ObjectCategory    :

    ObjectClass       : {top, msExchSharingPolicy}

    WhenChanged       : 3/14/2012 2:27:41 PM

    WhenCreated       : 3/14/2012 2:27:41 PM

    WhenChangedUTC    : 3/14/2012 6:27:41 PM

    WhenCreatedUTC    : 3/14/2012 6:27:41 PM

    OrganizationId    : Exchange Hosted Organizations/ - namprd06



    OriginatingServer :

    IsValid           : True

  • I posted what was requested.  Please advise.

  • Hi Kevin,

    I have checked the detailed information of your sharing policy, and haven't found any incorrect settings about it. My suggestion is to re-publish the calendar in OWA. Please see Calendar Publishing.

    Reken Liu

  • I reshared the calendar and in the email, there is a link to the calendar.html page and it takes me to a login screen.  I've I've given rights to allow anyone to see my free/busy info, why would the person need to login (which they can't anyway).

    The link it provided is:

  • Hi Kevin,

    I have just published my calendar to the internet, and compared my link with the link you provided. I noticed that there are something differences in the format. I list the two links here for your reference:

    Your calendar publish url:

    My calendar publish url:


    Based on the situation, would you please edit the url by replacing the complex strings in the url with your alias, and the calendar name you are publishing? After that, please try to access it to see if it can be accessed without login.

    Reken Liu

  • Can you advise how I find the calendar name?

  • I was able to get this working but there is still an underlying problem.  To get it working I went into OWA and clicked calendar/share/changepublishingsettings.  When I did this I got the following error:

    The input object cannot be bound to any parameters for the command either because the command does not take pipeline input or the input and its properties do not match any of the parameters that take pipeline input.

    I noticed the url of that page is this:

    So I changed the url to this:\calendar&pspid=_1332854304838_17353588

    and the page came up correctly.   Once there I noticed that the access level was "restricted" so I changed it to public and hit save.  When it refreshed, it changed the urls from this:

    to this:

    And unbelievably that works.  

    HOWEVER, the deeper problem is that the links in OWA for some functions still don't work (like Calendar/Share/Change Sharing Permission and Calendar/Share/ChangePublishingSettings).  What is wrong with my system that is causing it to not properly create URL's in the OWA?

  • Hello Kevin,

    If you are publishing the calendar to the Internet, if you choose "restricted" it should not affect the person trying to view it.  If they have the URL it generates, they will be able to access the calendar and will not be prompted.  You can use DNS CNAMEs to redirect users to the link, but they should not be prompted, regardless of DNS setting or whether CNAME records are used. 

    If you are sharing the calendar internally, then users should be prompted for credentials, but this is a different issue entirely and should have a new case opened for it, if there are any problems.