No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

remote mailbox move fails with object can't be found

This question is not answered This question is not answered

Hi, when I try to move a mailbox from on-premise to office 365 I get the following error:


Summary: 1 item(s). 0 succeeded, 1 failed.
Elapsed time: 00:00:03


The operation couldn't be performed because object '<objectGUID>' couldn't be found on ''.
Click here for help...

Exchange Management Shell command attempted:
'9e7d43a4-7a10-49ef-a863-a756d4672437' | New-MoveRequest -Remote -RemoteHostName '<MRSproxy server>' -TargetDeliveryDomain '<office 365 domain>'

Elapsed Time: 00:00:00


As far as I can see the MRSproxy service is running, the hybrid configuration completed successfully, but I can't successfully completea remote move request.


Any help would be appreciated.




All Replies
  • Hi Alex,

    Based on the error information, the move process cannot locate the object at the cloud side.

    So could you try force Active Directory synchronization and move the mailbox again? To for Active Directory synchronization, please login to the server which has DirSync installed, go to Microsoft Online Directory Sync folder and run the DirsyncConfigShell.psc, this will bring up a Powershell Windows, then type Start-OnlineCoexistenceSync cmdlet and press enter. Also, you can launch c:\Program Files\Microsoft Online Directory Sync\SYNCBUS\UIShell\MIISClient.exe (default folder) to check the synchronization status.

    Lester Zhang

  • I ran the syncronisation as you suggested, checked the status and then retried the remote mailbox move with the same result.

  • Hi Alex,

    Thanks for the update.

    To check the could user status, please login to Microsoft Online Portal, go to User part and check if this user has been synchronized. Also, you may assign a license to this user account to see it will make any change.

    To double check the guide, please connect to Exchange Online through PowerShell as administrator, run Get-Mailuser user | FL *id* and check if ExchangeGuid has been set correctly to match the guid in the error message, which should be the same as the guid for this on-premise mailbox user.

    Does this issue happen to all users or just this specific one?

    Lester Zhang

  • Hi Alex,

    How is the thing going? Is there any update of this issue?

    Lester Zhang

  • I have the same issue and after running the AD sync it still gives me the same error.  When I attempt to license the user through the Office 365 portal, it just creates a separate mailbox on Office 365.  I had licensed before making the move by mistake, but even after undoing the license I am still unable to move this user.

  • Hi Alex,

    We had a similar issue with our organisation. The mailbox could not be migrated be cause of the same error, even though the account had been synchronised.

    We ended up disconnecting the cloud and on-premise objects from each other, forcing a "Full Confirming Import" in Synchronisation Service Manager, and manually removing the account from MSOL. In some cases even doing this didn't allow us to remove the object from MSOL and the UPN had to be renamed first.

    Once the account was disconnected and removed from MSOL, a new linked account was created and migration was successful.

    I hope this helps someone, but I guess your scenarion could be different.