No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Issue with multiple Exchange Office 365 accounts in Outlook 2010

This question is not answered This question is not answered

I am running Office 2010 on Windows 7 and I am trying to connect to 2 Office 365 Exchange accounts within our Office 365 account (i.e. 2 different email addresses that fall under the same domain in our Office 365 account).


It seems that once Outlook connects to 1 of the accounts, the other is never able to connect.  It seems to connect to the default account first, and then the 2nd Exchange account never connects.  We previously used a different Hosted Exchange provider (before Office 365) and it worked fine, so it seems that something at Office 365 is blocking this somehow ?


This is driving me crazy, so please help if you can !

1 out of 1 people found this post helpful.

All Replies
  • Your problem is most likely the AutoMapping feature. Do you have full mailbox rights to the users you can see in your outlook profile? If you have SP1 here is the fix:

    community.office365.com/.../office-365-exchange-2010-sp2-automapping.aspx

  • Hi Jorge,

    The link is broken.

    In any case, I don't think this will solve the problem.  We are trying to have multiple exchange accounts in the same profile using DIFFERENT credentials, so the mailbox rights shouldn't be a problem.

  • Just my 2 ct.;

    My experience is that if you make sure the first account has FullAccess (and no automapping) & SendAs permissions on the second account, then after adding the second exchange account in Outlook 2010, edit the account settings, go to the Security Tab and check the 'Always prompt for logon credentials'. When you click ok, you're asked for the credentials, enter the credentials for the FIRST(!) account. After that, it will NOT ask for permissions again. Likely because on attempting to access the second mailbox, it already finds it has the permissions it needs from the session set up for the first account.

    This will prevent the connectivity problems caused by 2 different user sessions to the same proxy server from the same machine. Since the first account already has full access to the second, why not use its credentials... No need to edit the host file or alter the proxy server or miss the ability to get the sent items in the folder belonging to the right account.

    PS. I've experienced once that when entering the credentials, the account name couldn't be looked up, it presented with =SMTP... etc. Just put in the plain e-mail address and it will look it up properly.

    Regards.

  • also experiencing the same issue ... however the above fix (opening the secondary mailbox on the 'advanced' tab of the primary profile) will not work for us.

    Our issue is in getting the secondary account's contacts to show up as an address book entry.  The second set of contacts will only be available to the address book if added as a second Exchange account in the profile (using the 'add account' button)

    The 'spoofproxy' fix seems to be working, but *yuck*.

    btw:  the whole shared contacts issue is another serious stumbling block and weakness in the Office365 offering, but that is a story for another thread.

  • To avoid confusion; the method I tried to describe doesn't use the advanced tab, it truly uses 2 Exchange accounts, the address books from both accounts are available when clicking the 'to' button in a new e-mail.

  • I'm also having this problem, with two boxes in one Outlook 2010 profile, only 1 box updates. Is this only specific to P1 plans though? I have tested with a E1 plan I also have and those boxes worked fine.

    Broken = P1, Outlook 2010 on WIn XP, two std user mailbox accounts in single Outlook profile, no powershell permissions changed.

    Works = E1, Outlook 2010 on Win XP, two Admin user mailbox accounts in single Outlook profile, no powershell permissions changed.

    Is it the P/E or Admin/Std user or just coincidence?

  • I have just confirmed making both users in the P1 admins  will fix the problem, for me anyway. I have not extensively tested this, just over the last 5 minutes opened and closed Outlook a couple of times.

    Could someone else with this issue also give both mailboxes account admin privileges via the Admin toolbox to replicate the fix?

  • We are still seeing the same problems as described in the begining of this thread at one of our customers sites. When adding two different exchange accounts from same office 365 tennant to the same outlook profile one of the accounts cannot connect.

    Please provide a fix asap microsoft.

  • I am having this issue as well - since teamlogicit.com switched to this O365. I was just told to setup both mailboxes and have fought this for days now. I have noticed that if I check name of the account that is not connecting then that inbox will connect the next time I open outlook. one or the other is always disconnected or trying to connect. I seem to be the only one in this office with the problem, 3 of us with multiple accounts setup. 
  • Brendan,  Thank you, Thank you Thank you.. Easy fix but 20 hours of banging my head against a wall. Solution is explained well.

  • The Office 365 Product Teams have investigated this issue and are close to determining a fix.  We believe the issue stems from using two separate accounts to access the mailboxes.  If anyone can help us confirm this, please test this workaround and let us know if it works.  The workaround is to grant one account permissions to both mailboxes.  

    To attempt to work around this issue, use the following two-pronged approach. First, remove the locally-stored credentials for the secondary mailbox. To see locally-cached credentials in Windows, click Start and type "Credential Manager".

    Of course, you still want access to the secondary mailbox. The second step makes this possible. Use the following Microsoft Knowledge Base article to connect to your Office 365 environment using Windows PowerShell and grant your user permission to the secondary or shared mailbox. The admin credentials should be used for this step.

    How to remove AutoMapping for a shared mailbox in Office 365

    support.microsoft.com/.../2646504

    Note If you do not have full permissions to the shared mailbox,  you can skip to step 3. Use step 3 to grant your account permission to the shared mailbox, while  leaving the Auto-Mapping option disabled.

  • Case# SRX1171088538ID

    I worked on for 2 hours today and we tried this,. I was not able to expand the second mailbox.

  • Just to be clear, did you grant Full Access permissions directly and also clear out the original credentials from Credential Manager?  Its possible Outlook was still using the cached credentials and would have still been in the broken state.  If you set up anymore new users with two mailboxes please try from the start with them only accessing with the one Full Access account.

  • Just to be clear do you want me to add both accounts in one profile or a single account granting permissions to the other account?

  • Please use Exchange Powershell to grant one user account permissions to a second mailbox, support.microsoft.com/.../2646504.  Leave Automapping disabled.  In Outlook add both mailboxes to the same profile using the one user account.