Issue with multiple Exchange Office 365 accounts in Outlook 2010

This question is not answered This question is not answered

I am running Office 2010 on Windows 7 and I am trying to connect to 2 Office 365 Exchange accounts within our Office 365 account (i.e. 2 different email addresses that fall under the same domain in our Office 365 account).

It seems that once Outlook connects to 1 of the accounts, the other is never able to connect.  It seems to connect to the default account first, and then the 2nd Exchange account never connects.  We previously used a different Hosted Exchange provider (before Office 365) and it worked fine, so it seems that something at Office 365 is blocking this somehow ?

This is driving me crazy, so please help if you can !

1 out of 1 people found this post helpful.

All Replies
  • I have not heard anything.  

  • Just to update our customers, Microsoft is deep into investigation regarding this issue.


    I have been able to reproduce this internally and we are currently testing multiple scenarios to find the root cause of this issue.


    As more information is available for our customers regarding a permanent fix, we will let you know.

  • We are having the same problems already for several months. It is really annoying and we are losing alot of productivity time because sometimes we don't receive mails for days.

    I thought office365 and outlook were a professional product, but considering all the bugs we have already experienced, as well office2010 and office365 can be hardly more called than beta versions. This thread has been started already in May, now we are almost December, well done microsoft!  Meanwhile we are paying for a product that doesn't work well. Could you please solve this problem and put some deadline on it, our business is suffering because of this.

  • Hi,

    we are facing the same problem at one our customers.

    Particularly frustrating is that putting multiple accounts in one profile was presented as a solution to me by Office365 hotline a couple of weeks ago. Now today, the same hotline tells me that this will definitely lead to problems.

    However, I applied this "hacking hosts file" fix and it seems to work for us. I'd like to point out - as I was confused by that -  that the other server names you put in your hosts file don't need to exist. So in my case there is:

    and I added:

    It doesn't matter that nslookup isn't able to resolve these names.

    Now I'll be eagerly waiting for a *real* fix to this...

    Lennart Schütz

  • When we started using O365 I was told by Microsoft support that adding accounts in this fashion (via the "Add Account" button) was the correct way to add multiple accounts to Outlook. They obviously had not fully tested this as many people are experiencing the same random disconnects when doing so. I ended up opening a new ticket on this issue recently, I was fully aware of it being a known issue but I wanted to see what direction the troubleshooting would take without all of this history. I learned that first level of O365 support definitely has no idea that this is a known issue. However, we did also figure out a way to make Outlook stable while containing multiple accounts. In fact, the guy I’m working with now at Microsoft said that the ONLY supported way to add a secondary account to Outlook is by doing it this way (the way I detail below). There is one catch - in doing it this way all emails that you send out from Outlook go into the primary mailbox's Sent Items folder, even the emails that you "Sent From" a secondary account. My ticket is still open with Microsoft and so they are also still looking for a way to change this behavior. But at least this will get multiple accounts working in Outlook without having to mess around with the hosts file and without having to modify server settings in your Outlook profile. Here is the process:

    1. Give your primary account permissions to access the mailbox of the secondary account – you can use the PowerShell command listed below to give yourself full rights to the whole mailbox, or alternatively you can open the secondary mailbox in its own Outlook profile and then right-click on the folders that you want to grant access to and do so in the Permissions tab. So you can grant access only to the Inbox, for instance, if you choose to do so. Otherwise here is the PowerShell command to give full rights: "Add-MailboxPermission –Identity –User –AccessRights FullAccess –InheritanceType All"

    2. Give your primary account permissions to “Send As” the secondary account – PowerShell command for that: "Add-RecipientPermission –Identity –Trustee –AccessRights SendAs"

    3. Give your primary account permissions to “Send on Behalf of” the secondary account – PowerShell command for that: "Set-Mailbox –Identity –GrantSendOnBehalfTo"

    4. Now your primary account has access to send emails as the secondary email address, and you have rights to view the secondary mailbox with your credentials (you no longer have to enter the separate credentials for the secondary account when adding it to Outlook)

    5. Add the account to your Outlook – You do NOT do this with the “Add Account” button. Instead, you go into “Account Settings”, choose your primary account that is listed, and click the “Change…” button. When this opens, click the “More Settings…” button. Then go to the “Advanced” tab. On this screen you can add the secondary account, and after you finish out the wizards you will then have the secondary account listed in your Outlook and you should not have connectivity issues.

    Like I said earlier, the only catch that I have found so far is that when you send emails as the secondary account, they do show up to the recipient correctly as coming from the secondary account, but they get dumped into the primary account’s “Sent Items” folder. So if you want them in the secondary mailbox’s Sent Items, you will either have to move them manually or create some kind of Outlook rule that moves them automatically.

  • We just switched from Google and are beginning to deeply regret it due to this issue.

  • I apologize this issue continues to drag on without a fix.  There are a lot of people working on it but its turned out to be complex to isolate.  We are keeping it a high priority until we get it resolved.  

  • @admin_tcw Just use the method Jordan posted and you will be golden. If you're not a PowerShell guru don't worry its not to bad start here:


    To install and commands to get connected and running:


    Send as post:


    Found this usefull too so everyone does not see shared mailbox's in the GAL:



  • @Ryan:

    This solution is golden?? It is a crappy solution which doesn't work well

    How will you solve the matter that all sent mails are saved in the correct folder and not in the individual folder where nobody else can read it? Or perhaps Microsoft can let one of their employees move the sent mails every hour for us manually

    We use for each of our companies a general info email address, and all our employees use this address to reply to customers. With this workaround nobody else can find any history or previous replies, which is not acceptable.

    As we pay for a license for each account, it should mean we also have full access to our account directly. Microsoft has been noticed in May about this problem, and cant solve it with several people working on their own designed software?

    We also regret migrating to office365 and putting a lot of time in it. I would not recommend any professional company to use it yet. Perhaps in one year when they get all the bugs out.

  • @Sandy

    If given full mailbox rights the account shows up in outlook and you see all the sent,deleted,drafts what have you.  I would think any mail sent from that account no matter who sent it, it would show in the mailbox's history.

  • @ Ryan

    The sent emails arrive always in the sent email box of the primary (personal) account, so nobody else can see them (unless you would give everyone access to everyones account). If u know a workaround/solution or setting that sends them to the correct folder I would be glad to hear it from you.

    We have spent long days on this matter and found no solution for it. Only some 3d party tools can do the job and offer the possibility to move sent mails to the correct folder, but even they don't work always well and for every user we have to purchase a license for this tool.

  • @Sandy

    Well that is not so golden sorry. If you did the send as, full access, and recipient permissions, I would think the behavior would be as you want.  The recipient permission is to make the mail look as tho it came from the general account so you would think it would put the sent items in the general account sent folder...

  • @ Ryan

    This is a common problem with outlook2010. You can google this and will find alot of threads with complaints about it...all without a solution

    Anyway, lets hope Microsoft solves this problem very soon and I hope the new Office software next year will work smoothly with Office365.

  • I used to use the DelegateSentItemsStyle registry key hack to fix this issue, it worked on and off (fine with 2007, but 2010 semi-works depending on what patches you have install).  For reliability, we just didn't waste any more of our time and configured additional shared accounts through IMAP w/Office 365 since the mapped accounts had so much overhead and issues to deal with.  With IMAP, after you configure the account and go back to the account properties you can specify the folder to put all sent email.

    If you are masochistic and determined to use the mapped accounts method, take a peek at:

  • Got the exact same Issue with multiple Exchange Office 365 accounts in Outlook 2010.