Issue with multiple Exchange Office 365 accounts in Outlook 2010

This question is not answered This question is not answered

I am running Office 2010 on Windows 7 and I am trying to connect to 2 Office 365 Exchange accounts within our Office 365 account (i.e. 2 different email addresses that fall under the same domain in our Office 365 account).


It seems that once Outlook connects to 1 of the accounts, the other is never able to connect.  It seems to connect to the default account first, and then the 2nd Exchange account never connects.  We previously used a different Hosted Exchange provider (before Office 365) and it worked fine, so it seems that something at Office 365 is blocking this somehow ?


This is driving me crazy, so please help if you can !

1 out of 1 people found this post helpful.

All Replies
  • Brendan

    This has been working well for us (as an interim measure). However I have one particular user where the alternate proxy server address is reverting back to the default setting.

    I have the local host set as

    127.0.0.1   autodiscover.goldenhotels.com.au        

    Is this correct. It seems to work for the other users. Any ideas?

    Regards Tim Jasper

  • What you have done is correct.  

    Have you been back to check if the entry is still in the hosts file?  Some Anti-Virus products clean the hosts file, so maybe it has been removed.

    I don't know of any other way an Outlook client can correct its settings apart from following the autodiscover record and updating itself.

  • Just wanted to update that Craig UK opened a support case and we will be using his case to investigate the problem.  In the meantime Brendan's workaround seems to be the best solution.  I'll update when we have more progress but wanted you to know its being worked on.

  • The latest update is that we were finally able to get a repro of the issue.  We were able to see the problem where when having multiple accounts one or both accounts would show as Disconnected or Trying to Connect.  Our Escalation Engineer has taken traces and has submitted a hotfix request.  I'll come back and update the forum thread as we continue to make progress on the issue.  

  • I sure hope this hotfix is sooner then later... Pulled my hair out yesterday on this issue, then stumbled on this post.

  • We've just rolled out 60 users on O365.  Only 2 out of 10 users that use multiple mailboxes are reporting the same issue.  We are not interested in a hack, we want a fix ASAP please.

  • Hi Brendan (and others),

    I've tried your solution of changing the proxy adress and adding this to the Hosts file. And indeed it works fine!

    However, it works just for a short time. After waiting for a while and starting / shutting / starting Outlook 2010 a couple of times, the proxy adress is changed automatically by Outlook to the original adress.

    Does anyone know, how I can prevent Outlook for doing this?

    Greetings Nick

  • Hi Nick,

    Did you add the autodiscover record to your hosts file?

    autodiscover.yourdomainname.com

    If you don't add this record, Outlook will correct itself after a while.  This might be the problem that you are having.

    Warm Regards,

    Brendan

  • What is happening is autodiscover is changing back to correct proxy. To prevent this from happening, you need to add a second line to your hosts file:

    127.0.0.1 autodiscover.yourdomain.com

    This will break the autodiscover, and prevent the proxy changing back. If you use Lync, it may also break exchange integration, as this also relies on autodiscover.

  • Still be nice to get a real fix for this...

  • Hey Guys,

    Thanks! I did add the second line of the autodiscover into the hosts file. However, made a little mistake there. Hopefuly Outlook will keep working now.

    And indeed, it still would be nice to get a real fix! Have spend some days on this issue before discovered this thread. And was stumbeld about the disability to share more accounts in Outlook. Almost all (Small) Businesses are having an info account (And the shared mailbox is not an option because of rules, receiving mail on phone, use signatures, etc. And the use of powershell is far from user friendly for our client as an non-IT small business! So, really no option there!)

    We just moved one cliënt with 4 mailboxes. Another client of us will be about moving approximately 3000 mailboxes.... With those kind of issues, I'm really asking myself we should do this already...

  • Hi Folks,

    I received an update from Microsoft on this issue via email:

    ==============================================

    Hi Brendan

    Thank you for the email

    Right now, product group is looking at this issue. Unfortunately I do not have a time as to a fix or a better workaround.  Hopefully I will have something in the next few days

    In the meantime, please let me know if you have any questions

    Thanks!

    ==============================================

    When i get more info, I will post here.

  • Hello,

    we seem to be having the same issue, the office has 4 users and one additional INFO@ mailbox, the additional mailbox was added to the 4 other Outlook Profiles. What was a bit strange, it seemed that when only one person was opening his personal and the extra mailbox, the issue didn't occur. When all the 4 client PC's had there Outlook 2010 opened...the issue was present on multiple workstations. Hope this info can help in fixing the issue? I had to reconfigure the Profiles so the client wasn't affected by the issue. Hope this Hotfix will arrive soon!

    Best regards,

    Philip

  • Hey Philip,

    What I've understand from the tech fora of Office, after Service Pack 1, Outlook 2010 give some trouble when an shared mailbox is (also) added as an extra Exchange Account in the same profile. It will be mixing the settings of the shared mailbox and of the exchange mailbox in the Outlook Profile.

    Sadly enough I can't find the announcement of MS anymore.

    Greetingz Nick

  • I wanted to provide an update what we found so far.  For one case we investigated there was some corruption in the autodiscover settings.  This caused the Server name to be prepended with extra characters.  The product team cleaned up the ones they found were incorrect.  Hopefuly this would address the issue for everyone else too.  We are still investigating in case any were missed or possibly another issue.

    If anyone still sees the issue happening please private message me your Outlook AutoConfiguration settings and your O365 email address.  Press the Ctrl key, right click the Outlook Icon in the Sys Tray and click Test E-Mail Autoconfiguration.  Please send the output on the XML tab.  

    Also, as a reminder that if you were using the fake proxy workaround remember to edit your hosts file to clear it out.