No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Issue with multiple Exchange Office 365 accounts in Outlook 2010

This question is not answered This question is not answered

I am running Office 2010 on Windows 7 and I am trying to connect to 2 Office 365 Exchange accounts within our Office 365 account (i.e. 2 different email addresses that fall under the same domain in our Office 365 account).

It seems that once Outlook connects to 1 of the accounts, the other is never able to connect.  It seems to connect to the default account first, and then the 2nd Exchange account never connects.  We previously used a different Hosted Exchange provider (before Office 365) and it worked fine, so it seems that something at Office 365 is blocking this somehow ?

This is driving me crazy, so please help if you can !

1 out of 1 people found this post helpful.

All Replies
  • Brendan, thank you so much for your post, it was very helpful!


    I was going to try an intermediate step, but I think I bumbled my way into an alternate method. Under the Exchange Proxy Settings, I simply replaced the proxy server address with it's IP and saved the settings. When I opened outlook it immediately connected and started syncing my folders. Looking back into the Exchange Proxy Settings it seems to have re-populated the exchange server address, however everything still seems to be functioning correctly! I did not make any changes to my host file.


    Thanks again!

  • Nisse,

    I went through the steps to double check and following the KB I am not seeing the problem of mails going to the wrong Sent Items folder.  Please go through the steps in the KB again,  

    The main things to be careful of are to make sure in step 3 -AutoMapping:$false.  If Automapping is true or enabled then the mailbox will be added automatically and this is not what we want to happen.  This KB explains how to update Automapping,

    The other thing to double check is that you did step 4 to grant Send As permissions,  This is a common mistake that causes the mail to go to the wrong Sent Items folder.

    Also, as Ben mentioned in the other thread make sure your From dropdown in Outlook shows the correct email address to send the email.

  • I may have celebrated too soon. The mailbox continued to work well all day on Friday, but now I'm back to having connectivity issues again. I will try Brendan's solution in full.

  • Look at this article and see if it doesn't help:

  • Is there no update on this issue? My clients are still experiencing troubles when connecting to more than one account on the same domain in Outlook.



    1 out of 1 people found this post helpful.

  • Hi Reinhard,

    unfortunately not. In January, a guy from Microsoft called me - promising that they're working hard on this issue and that he'd call back within the next days. Actually, he never did. Since then, I've not heard anything about my support call that still must be open until today.


  • bump

  • The fix for this issue shipped today in the June 2012 Cumulative Update  

    In the article click on the link in the top left "View and request hotfix downloads" to install it.

    0 out of 1 people found this post helpful.

  • Hi Gabriel,


    thanks für releasing the fix, but unfortunately i can´t install it. The installer tells me that the products do not match. We use MS Office 2010 professional plus with Outlook 2010 and with all updates. What can i do to use the fix?




    (Message is in german)


    Kind regards


  • Michl,

    When you click on the KB, and click Get Hotfix Now, please make sure you are downloading the right bitness.  The Hotfix is available for 32 or 64 bit installed build of Outlook 2010.  

    1 out of 1 people found this post helpful.

  • Hi Gabriel,

    indeed the downloaded package was broken. The correct one could be installed and the problem did not appear again up to now. Seems to be fixed.

    Best regards