No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Android Phone Setup - more

This question is answered This question is answered

Hi,

 

I have tried the instructions at http://community.office365.com/en-us/f/160/p/1423/4649.aspx and I almost get there. The phone is a HTC Desire running Andoid 2.2

 

The phone accepts my credentials, then moves to the next page asking "what do you want to sync" and offers Mail, Contacts and Calendar options. I have tried all possible combinations of the three from none to all, and I always get "Failed to create the account. Please try again later." after about a 2 minutes wait.

 

This phone had previously been connected to an in-house Exchange 2007 server and worked fine. We have moved to Office 365 and I really need to get the phone going.

 

Thanks.

1 out of 2 people found this post helpful.

Verified Answer
  • They are working on a beta fix, and I'm guessing they will have it out in the next few days. The developer has been fantastic in working on this.

    In the meantime you can connect directly if you can work out which server Office365 is trying to redirect you to. Touchdown has a really nice feature for debug logging. When you start it up, it will ask for configuration info. Don't go through this - go 'back' to the home screen, open the menu, then select 'diagnostics'. Down the bottom select 'Log Next Operation'. Now go back, and then go through the config process. Use the following settings:

    UserID - your Office465 email address

    Domain - leave blank

    Email address - your Office465 email address

    Password - your password

    Server - m.outlook.com

    It will fail. Go back to the Touchdown home screen, then the menu, and select & copy all the diagnostic text and email it to yourself (use your Google account - you presumably have one for the market, if not. get one just for this purpose - Android has a gmail app built in).

    Search the log for 'Error 451' and you will find something that looks like this:

    Error 451 (SERVER FAILOVER) : Response Headers: (Cache-Control=private),(Server=Microsoft-IIS/7.5),(X-MS-Location=pod51012.outlook.com/Microsoft-Server-ActiveSync),(X-AspNet-Version=2.0.50727),(X-Powered-By=ASP.NET),(Date=Wed, 20 Apr 2011 23:25:08 GMT),(Content-Length=0),

    Note the Location=https://://pod51012.outlook.com - this is the server that Microsoft is trying to redirect me to instead of m.outlook.com - yours will almost certainly be different.

    Now, go back through the config process but use that server name instead of m.outlook.com and it will all work.

    Note also: don't everyone just use pod51012 please! Most likely it will not work for you if you do anyway. Go through the process. It only takes 5 minutes!

    I might add that once you have the server name you can then use it with the normal Android Activesync connection as well, but Touchdown is a really nice app and I would encourage you to spend the $20 for it .. if you are using Activesync you probably have spent a heck of a lot more than that. It also gives you task syncing, which is why I moved from Google Apps in the first place.

    It would have been nice if Microsoft had documented this 'creative' use of the HTTP error message to make everyone's life easier.

All Replies
  • Hi,

    Firstly, please make sure that the device is configured correctly.  

    1. On the main application screen, locate and then tap the Email icon.
    2. At the first prompt, enter your email address and password. Then, tap Next .
    3. At the Domain\User prompt, enter your email address and password. Then, enter m.outlook.com as the server.
    4. Click to select the Accept all SSL certificates check box and the Use secure connections (SSL) check box, and then click Next .

    If the problem insists, pleae validate the connectivity to the Exchange server: 

    1. Confirm that the device can connect to Internet sites that are not Office 365 sites.
    2. Confirm that the device can connect to Microsoft Outlook Web App in Office 365.
    3. Verify that the ActiveSync policy that is assigned to the user is correct.
    4. Test connections to the server by using the Exchange Remote Connectivity Analyzer at the following site:
    5. Collect any errors that are generated from the test in step 4.
    6. Collect any errors from the ActiveSync Device logs. These logs are present on all Windows Mobile devices.
    7. Test connectivity to the account that is experiencing this issue by using another ActiveSync device.

    Hope it can help.

    Best regards,

    Daizy

  • Thanks, Daizy.

    My phone does not have the 'Accept all SSL Certificates' option. It is Android 2.2 (FroYo), the standard HTC release, not a hacked one or anything.

    Re your tests:

    1. All internet connections are fine.

    2. Outlook Web App in Office 365 works fine.

    3. In Office365 the user has Exchange ActiveSync enabled.

    4. Failed - results below.

    5. As below.

    6. This is an Android device.

    7. I don;t have any other ActiveSync devices handy, sorry.

    The results from www.testexchangeconnectivity.com were:

    Connectivity Test Failed

    Attempting to resolve the host name m.outlook.com in DNS.

    The host name resolved successfully.

    Additional Details

    Testing TCP port 443 on host m.outlook.com to ensure it's listening and open.

    The port was opened successfully.

    Testing the SSL certificate to make sure it's valid.

    The certificate passed all validation requirements.

    Test Steps

    Checking the IIS configuration for client certificate authentication.

    Client certificate authentication wasn't detected.

    Additional Details

    Testing HTTP Authentication Methods for URL m.outlook.com/Microsoft-Server-Activesync.

    The HTTP authentication methods are correct.

    Additional Details

    An ActiveSync session is being attempted with the server.

    Errors were encountered while testing the Exchange ActiveSync session.

    Test Steps

    Attempting to send the OPTIONS command to the server.

    Testing of the OPTIONS command failed. For more information, see Additional Details.

    Additional Details

    A Web exception occurred because an HTTP 401 - Unauthorized response was received from Unknown.

  • Hi, I am experiencing the same problem on HTC Hero running android 2.1

  • Hello Ozflip and Jono,

    If you are not able to see 'Accept all SSL Certificates' when setting up the accounts, it sounds as if this is a phone issue. Without SSL, you will not be able to access the mailbox. Is there a firmware update you can install?

    Thanks,

    David

  • The phone is completely up to date. It worked fine with my internal exchange server - it is only since I moved to the Office 365 beta that it has had a problem.

    I tried a complete phone manufacturer reset, with the same result.

    I tried downloading an application for the phone that uses it's own ActiveSync connection (not the phone's). It also failed to sync - here is the log from that app:

    Checking Certificate...

    Checking ActiveSync with SSL...

    m.outlook.com:Exception performing request

    ActiveSync version check returned negative, but still trying for 12.1

    Checking 2007 with SSL...

    m.outlook.com for operation: Subscribe-> Error renewing a subscription

    m.outlook.com:Exception performing request

  • I bought an app and the (very helpful) developer tracked down the problem for me after I took a log of the connection for him. In less than an hour from first trying the app,

    Office 365 is are abusing (i guess that's another name for innovation) the HTTP 451 error code to redirect the client to a different server. The fix was to change the server name to pod51012.outlook.com rather than m.outlook.com.

    And that fixed the issue. The problem is with Office 365, evidently.

    The app is TouchDown (available on the Android market, website is http://www.nitrodesk.com .. the developer is also working on a workaround for his software to try to deal with this after I brought it up.

    I might add .. great app for Exchange mail on Android! $20 is insanely cheap for these phone apps.

  • Did TouchDown figure out a work around?

  • They are working on a beta fix, and I'm guessing they will have it out in the next few days. The developer has been fantastic in working on this.

    In the meantime you can connect directly if you can work out which server Office365 is trying to redirect you to. Touchdown has a really nice feature for debug logging. When you start it up, it will ask for configuration info. Don't go through this - go 'back' to the home screen, open the menu, then select 'diagnostics'. Down the bottom select 'Log Next Operation'. Now go back, and then go through the config process. Use the following settings:

    UserID - your Office465 email address

    Domain - leave blank

    Email address - your Office465 email address

    Password - your password

    Server - m.outlook.com

    It will fail. Go back to the Touchdown home screen, then the menu, and select & copy all the diagnostic text and email it to yourself (use your Google account - you presumably have one for the market, if not. get one just for this purpose - Android has a gmail app built in).

    Search the log for 'Error 451' and you will find something that looks like this:

    Error 451 (SERVER FAILOVER) : Response Headers: (Cache-Control=private),(Server=Microsoft-IIS/7.5),(X-MS-Location=pod51012.outlook.com/Microsoft-Server-ActiveSync),(X-AspNet-Version=2.0.50727),(X-Powered-By=ASP.NET),(Date=Wed, 20 Apr 2011 23:25:08 GMT),(Content-Length=0),

    Note the Location=https://://pod51012.outlook.com - this is the server that Microsoft is trying to redirect me to instead of m.outlook.com - yours will almost certainly be different.

    Now, go back through the config process but use that server name instead of m.outlook.com and it will all work.

    Note also: don't everyone just use pod51012 please! Most likely it will not work for you if you do anyway. Go through the process. It only takes 5 minutes!

    I might add that once you have the server name you can then use it with the normal Android Activesync connection as well, but Touchdown is a really nice app and I would encourage you to spend the $20 for it .. if you are using Activesync you probably have spent a heck of a lot more than that. It also gives you task syncing, which is why I moved from Google Apps in the first place.

    It would have been nice if Microsoft had documented this 'creative' use of the HTTP error message to make everyone's life easier.

  • Hi Daizy,

    thnx for the How-To. For all people wondering if this fits to your HTC Desire Z: it does!

     EDIT:

    when I saved the account on my phone I didn't name it as I finally wanted it to be named. So I renamed it and now it keeps saying:

    "cannot create account, please try again later"

    Even if I delete the whole account now and try to install it all new.

    Device as already said: HTC Desire Z (Android 2.2)

    Anyone an idea?

     

    Regards,

    roby

  • Just got mail working with my Desire Z! The trick was to go to the web Outlook application - the necessary podXXXXX string will be at the head of the URL e.g. pod51014 in my case.

  • Works! Great, Thnx!

     

    Device: HTC Desire Z

    Software: Android 2.2.1

     

    Application: standard active sync (home -> menu -> accounts & sny -> add account -> active sync)

     

    email-adress: name@domain.com

    username: name@domain.com

    password: yourpw

    domain: leave blank

    server: podXXXXX.outlook.com (change to your Outlook Web App and take it from the URL)

    Secure Connection: Yes

     

    I just sent some testmails, they worked fine!

    cheerzR

  • Good to know it worked for more than just me!

    Ming.

  • No luck for me, tried bith podxxx... and just m.outlook.com

    Any other ideas?

  • Great help.  Had the same problem with my iPhone 3g.  Stopped working 5/27/11 around 5:30pm PST, removed the account from both the phone and from Office 365.  Entered m.outlook.com for server and it "said" it authenticated but then upon checking for mail it would say cannot connect to server.  I updated the server to pod5xxxx.outlook.com (our pod server email address) and right away I started receiving email on the iphone!  

  • Thank you, this was rather helpful and pointed me in the right direction, but there was no error 451 in the touchdown log...


    There is an easier way.

    Login to your Office365 mail account .

    You will see the following


    Outlook

    Read email and access your Outlook calendar, contacts, and tasks.

    • Inbox | Calendar | Options

    Click on Options.


    Look for and click on a link...

    Settings for POP, IMAP, and SMTP access... 

    If you don't see it check that you are on the following page tabs...

    *- Account (on the left - the default)

    *- My Account (at the top - the default)


    Then, your page title should be Protocol Settings, with the following information


    POP setting

    Server name: pod51016.outlook.com
    Port: 995
    Encryption method: SSL

    IMAP setting
    Server name: pod51016.outlook.com
    Port: 993
    Encryption method: SSL

    SMTP setting
    Server name: pod51016.outlook.com
    Port: 587
    Encryption method: TLS


    As mentioned, 

    *- your server will probably be different, i.e. pod#####.outlook.com

    *- enter this server name into your server address.


    Hope it helps, was driving me nuts!


    Also, IT managers can manage their organisation or other users by selecting from the drop the drop down list at the very top left of the page.