No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Few weird problems with public website sharepoint 2013

This question is answered This question is answered


I have two wierd problems that happened at the same time. Our public website is in czech language which contains accents.

First Problem: Pagefooter is missing(isnt dispalyed, file exists) and "edit site elements" button is greyed and i cannot acces it (i have all privileges).

Second problem: A made few applications - documents, every name contains "Documents (NameofTeacher) Example: Dokumenty (Pantlík). Then I displayed it on their pages. It worked ok. But now. When someone wants to view document. There is an error (Correlation ID: 00000000-0000-0000-0000-000000000000). If i click on the name of that application - page with all the files appears and everything is allright. Problem is - now files are not visible on teachers pages. Maybe problem is in accents. But week ago everything worked ok. URL:

Picture First problem

Picture Second problem 

Verified Answer
  • Hi Ondrej,

    From now on, I will work with you to resolve this issue.

    This is a known issue which happens in many tenants. Product team now is in the process of fixing it. Any updates, I wll let you know at the first time.

    Have a nice day!

  • I just received word that the fix is complete and is in the process of being rolled out. You should see an improvement soon.

All Replies
  • Same problema with footer/header noticed 2 days ago, and the problem is that i have a log-in link in the header to grant Access to contributors to my public site.

    I've opened a Service request and waiting for response

  • "But week ago everything worked ok. URL:"

    You must have been logged in then - O365 has never allowed anonymous users to interact with Sharepoint content. So folders/documents can't be opened - except for pdf's (though that seems to change on a weekly basis). .  .

    If you can get anonymous guest links to work you can add those to a page.  

    0 out of 1 people found this post helpful.

  • I have login link in the footer too.

  • Of course anonymous users can get files (we use ZIP and PDFs). And still they can get their documents, only in view on teachers page they cannot, but if tehy click on name of documents application, they enter it and can dwnload content. (public website for school would be useless without it). The problem is, that if document applications name contains accents, the strange error appears (but only on the teachers page with "view to the aplication) I am sorry i do not now correct english words (all sharepoint public server is in czech for me). One document applications name does not contain accents and works correctly. (Two weeks ago worked correctly (for anonymous users of course) everything.

  • Ondrej,

    "if tehy click on name of documents application, they enter it and can dwnload content. "

    By "document's application", do you mean if they click the library's title ie "Documents"? If they're not logged in, they wouldn't be able to access the library. But pdfs would still open from the site page regardless of permissions set.

    I'm not sure why special characters would suddenly cause a problem but anything is possible in O365. There was a time when pdfs didn't open at all and some users couldn't open folders within a library though they could open documents. Hopefully MSFT throws some light on this.

  • mchv2.0,

    " some users couldn't open folders within a library though they could open documents". That is it. They can download zip files or opens PDFs, but they cannot enter folder (in view on teachers page). But when they click on name of library (example: Dokumenty (Pantlík) ) They enter the library and can view content of the folder and download zip (or view PDF). This is oriblem only if  in the name of library there is accent. But I need it to work like in the past, And I am very sorry for my bad english.

    Try to click on any folder here:

    An error appears. If you click on name Dokumenty (Pantlík) you can normally open folders.

  • Hi Ondrej,

    I’ve reviewed this thread completely, and understood that you have run into the problems with the document library in public website, especially displaying the folders/files in one specific document library.

    I’d like to confirm how you add the Dokumenty (Pantlík) document library in the teacher page. According to my test on my side, if I create a default document library and then add it to the page, the files in this library cannot be viewed anonymously. However, if I create a document library using the Web Part page document template, all folders/files can be accessed anonymously. Below is the process for your reference.

    1. Create a document library using the Web Part page document template.

    Go to the right upper gear Settings>Add an app>Document Library

    Select Web Part page

    2. Add this library to the page you'd like.

    PAGE>Edit>INSERT>Web Part


    The following screenshot is my result:

    Could you please check whether this action also works for you or not? If there are any updates about this issue on your side, please post back. We’ll keep monitoring it.

    Mandy Meng

  • It's working as I described above here:

    Click the library link - Dokumenty (Pantlík) - I get the log in page

    Click on a folder in Dokumenty (Pantlík)  - I get an error

    As I said above you must be logged in if the library is opening.  

    You can see on this page, the behavior is the same with or without accents in the library/folder names so I don't think that's the problem:

    Unfortunately the confusion arises because the product is badly designed in so many ways:

    1/ No clear indication is given about whether or not you're logged in or who is logged in - so often you can be logged in without realizing it.

    2/ No clear policies about what should and shouldn't work regarding libraries on public site pages

    3. Unexplained inconsistencies between accounts/site collections

    4/ Vague and inaccurate documentation

  • Mandy,

    I haven't found what you say about libraries using the web part page template behaving differently from other libraries to be true, but I have noticed unexplained inconsistencies. Even if it is true, it's a ridiculous concept that as you can see just causes unnecessary confusion. Why on earth would someone select "web part page" as the template for a document library? How would they know to do that?

    Please provide authoritative documentation that explains the behavior of web parts inserted on public site pages, so we can stop guessing. Or is trial and error the only way to figure out how 365 is supposed to work?.

  • But until two weeks ago, our pupils could open document library and now they cannot :( If i am logged in and i click on any folder i still get an error. That error is not dependent on loging in. And you are right if i am not logged in, i cannot acces the whole library. So why it works here:

    when you click on "sportovní akce".

    When we cannot share files with our pupils, sharepoint public web is not very useful It is a pitty.

    But thank you.
    And why there is something like document library on public web, when public cannot access it? Sorry do not answer it. I am angry.

    EDIT:  I tried to chenage name to Dokumenty (Pantlik) and now it works exactly how you (mchv2.0)said.

    (The link above still normally works. Is there any posibility to have files public?

  • I'm seeing the same behavior for

    Document library requires log in

    All folders open fine (with or without accents in the name).

    So I think we've ruled out the accents causing the problem. I've asked many times but never seen an explanation from MSFT as to why you can add libraries to public pages but not interact with their contents. It's an irrational design. Generally I recommend users host their public web sites on a better designed platform that allows them to do whatever they want.

  • Hello Mandy, is there any way to change it on existing library?

    EDIT. No it does not work, anynomos user still cannot acces files. But thank you.

    you can see it here https://[tenant domain is masked by moderator]

    Pokus (Pantlík) is made with your instrucitons.

  • As school we have this for free. It is only reason. We will share our files elswere (dropbox or mega). Thank you very much.

  • And please, the first prolbem with missing display of footpage? Does anyone know what to try?

  • Hi Ondrej,

    I’ve also accessed the public website to check whether the folder can be opened. It seems that the folder which stores only PDF/zip can be opened without errors, and some folders which may contain like word cannot be accessed. Is it right for your situation?

    Regarding “Pokus (Pantlík) is made with your instrucitons.”you mentioned, do you mean that you create a new document library using the Web Part page document template, and then add it to the pantlík ondřej page by selecting the web part? If yes, since the folder containing word/excel file can be opened without problems on my side, the issue on your side may be a little bit special. We’ll continue to research it further. Actually the public website is mainly used to promote the brand of company or institution to visitors, and storing or sharing files is one feature in the private site (like Team Site).

    Also, about the problem with missing the display of footpage, how long have you run into the issue? Did you edit the public website using SharePoint Designer before? Does the symptom of the grayed out Edit Site Elements button persist in any browser (IE, Chrome, etc.)?

    Mandy Meng