No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Unexpected Error when creating site template

This question has suggested answer(s) This question has suggested answer(s)

I invested a lot of time in creating a site, but now am unable to create a template from it.  I received the unexpected error:

Sorry, something went wrong

Error exporting the site field named "HashTags"

Well, I had never created a field named that, but when I went into my Site Columns list, it was there under the Custom group.  There were actually TWO "HashTags" columns, named exactly the same, configured the same as far as I could tell.  Eventually I decided to delete one of them.

After I did that, both of the HashTags fields disappeared from my Site Columns list.  When I tried to create a template, I got a similar error:

Sorry, something went wrong

Error exporting the site field named "HashTags_0"

I have since tried manually creating a HashTags and HashTags_0 columns, tied them to metadata, then deleted them.  Didn't work.  I tried to delete a HashTags item I found in my Term store management area, to no effect.

Can someone please point me in the right direction?  Sharepoint is useless to me if I can't create a site template.

My subscription is Small Business Premium, if that matters.

All Replies
  • Hi Brian,

    I understand that you received this issue error message when using the site as template, is it right?

    If this is the case, I tried to reproduce this issue, I checked the site column list in the team site, I did not see the HashTags column. Then I created a new sub-site under my team site. I did see the HashTags column in Site Columns. However, I could save the sub-site as template successfully.

    To narrow down the root cause of this issue, could you please create a simple sub-side under your team site and try saving the new created site as template. Let me know if there are any error messages returned. Or you can save your top level team site as team site directly and check to see if the issue persists.

    Since all works well on my side, I'd like to confirm if you have customized your site, if yes, what kind of the customizations you have made? Per the information, I can look into this issue more deeply.

    Allen Qiu

  • Thank you for your prompt response.  I need to roll out this template ASAP and do not have time to rebuild it by hand.

    I did as you suggested, and created a new site (all are subsites under the Team Site in 365).  I then successfully created a site template from the site, and it showed up in my solutions gallery.  I have successfully done this before as well.

    I haven't done any customization except to create several lists that are linked by lookup to each other, and one that links to a list in the parent Team Site.  I did experiment with a couple of free market web parts but none of that is still installed.  I did rename the site at one point.

    I am afraid that my "fix" made things worse, when I tried to delete the duplicated HashTags field, leaving a field I cannot seem to access called "HashTags_0" that it errors on.

  • Hi Brian,

    As far as I know, the "HashTags" column is related to the Trending #tags in user's personal site, and it's a built-in column.

    I'd like to suggest you Reset to site definition in the site settings page. And then save the site as template, navigate to the problematic site and move to site settings page, click Reset to site definition under Site Actions, choose reset all pages in this site to site definition version, that will remove all customizations from the pages(won't affect the lists and libraries in your site), for your reference:

    In addition, I'd like to confirm if you can see "HashTags_0" in the site columns list? If yes, you can try removing it and check to see if the issue persists.

    Let me know if the issue persists after doing the steps above.

    Allen Qiu

  • Hi Brian,

    I am writing to follow up on my previous reply, any updates will be highly appreciated.

    Allen Qiu

  • Hi +Allen Qiu.  I did not receive  notification of your previous suggestion until this morning.  However, I just did as you suggested, and there was no effect- I was still unable to create a template from my troubled site after:

    1. Reseting all pages to site definition

    2. Verifying there was no Hashtags_0 (or any other Hashtags Site Column) in the site.

    Can you offer another suggestion?  Is there a way to export and then import my list definitions so I can recreate my site more quickly?  A way to totally disable the Hashtag system (nothing seemed obvious in "Site Features").

  • Hi Brian,

    To save the list or library definitions, you can navigate to list/library settings. Then click save list/library as template.



    After doing the steps above, you can use the new created template to create a library or list.
    For instance, you can create a new sub-site, and then add an app, you will find the template in the list.

    Let me know if there is anything unclear.

    Allen Qiu

  • Hi Brian,

    I am writing to follow up on my previous reply, feel free to post back if there are any issues when doing the steps above.

    Allen Qiu

  • I have the exact same problem on my site. I tried everything recommended below and Microsoft has been trying to fix this problem for 2 months now with no success. I can create new sites and creating a template from them works perfectly fine. I just can't save my site as a template where the users actually work. This has been a very bad experience that no one can seem to fix.

  • Hi JSRNJ,

    I understand that you have the similar issue, I'd like to collect the following information for further troubleshooting: 
    1. If you are using Office 365 post upgrade, you can check it out here: Am I using Office 365 after the service upgrade?

    2. When you created the broken site? Before the service upgrade or after the service upgrade?

    In addition, if you have raised a service request for this issue, I'd like to collect the service request reference number, so we can help to monitor the status.
    I have sent a private message to you about this issue, and you can check the private messages with the following steps:
    • Go to the Your details section on the right side of the community site.
    • Click Private messages.
    • Click the subject title of the response to read the message.
    • You can reply by using the form in this display.
    • Click Submit Reply.

    Allen Qiu

  • Hi Allen,

    We've got the same issue as the original poster, we're currently using the A2 plan of Office 365, we started using Office 365 this summer on Wave 15 so there hasn't been an upgrade to the best of my knowledge.

    We too were trying to save a template of a site and received the message: Error exporting the site field named "HashTags"

    When we looked at the 'Site Columns' we noticed that we had 4 instances of the 'HashTags' under 'Custom Columns' when we deleted one of them the other 3 disappeared too ...

    Now when trying to save a site as a template we get the message: Error exporting the site field named "HashTags_0"

    We've tried resetting all pages to site definitions but the problem persists.

    Have there been any developments?

    Many thanks,


  • Hi Ben,
    Unfortunately, the issue has not been worked out a resolution. I fully understand the inconvenience you have suffered caused by this issue. If it's convenient, you can save your libraries and lists as templates and then recreate your site.
    To get the dedicated support for the issue from your side, could you please create a new post in the community, then our support engineer will follow up on the thread you created? Thanks for your cooperation in advance.
    Best Regards,
    Allen Qiu
  • Hi,

    I has the same issue and managed to fix it by:

    Hope this helps.

    2 out of 2 people found this post helpful.