No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

PDF and Office 365

  • Hi Guys

    Browser refuses to open PDF's in Acrobate reader directly, instead you need to save it localy first and then open the file from a local storage. 

    The possibility to open a PDF document directly in Acrobate Reader (via Internet Explorer) is just a setting on the Web App service on the SharePoint server. Security From Strong to Weak - I've set this on different SharePoint servers and PDF's open in reader - Why is'nt this a default setting on Office 365?

    I have used SharePoint 2003, 2007 for years and the way Office 365 SharePoint handles PDF's are unseen so fare.

    MOSS 2010 Enterprise behaves exactly like Office 365, until you change from strong to weak on the server side, the browser will not open PDF's directly into Adobe Reader. But change to weak - same behavior as earlier versions!

    I have tested this on different servers and I know this is correct!

    This is NOT a client configuration issue! - If it is, please inlighten me! 

    This is a major issue to my customers since all of them are using PDF's!

    By default (configuration) in Office 365 you must save a PDF locally before you can view the PDF.

    Will Microsoft change this setting or is it any workarounds?

     There are other different discussions going on about PDF handling:

    The issue concerning PDF handling is a  big issue for me - all my customers are using PDF's.

    Please inform.



    6 out of 6 people found this post helpful.

  • You can contribute to the existing topics regarding PDFs and Office 365, there's no need to open a new thread for the same discussion...

  • Hi again Chris

    If you read the existing threads - they are all marked ANSWERED - but there are realy no solutions or there are incorrect solutions in them.

    So therefore - A new topic for a de facto solution.

    The threads I'm refering to is closed with status Answered, but they ar not!


    PS: You did not give any last reply in the "dead" threads - so why follow up this one?



  • Anyone pls?

  • If it remains true that Office 365 can't open PDF's directly in a browser..

    This renders Office 365 unusable for my customers....and I got a bunch waiting for this.

    Sad, for me and ms


  • This is old stuff from the Beta period.

  • I would rather not have the ability to open PDF files in one step, that to have anything on a shared server set to weak. If you Firefox it will appear that it is doing it, but all it does is save then open in one step.

  • FireFox is a fantastic browser - but I'm bound by policies to use MS Iexplorer.

    I also love that superstep your describing Robert - But it's not for me :-) 

    PS: Weak is = as before. It is not THAT weak

  • This also affects html and probably other file types. I think the other threads were marked answered because MS realizes this was an error and has "promised" to change it in a future release. When, we don't know.
  • I agree MCH - but this is rather catastrophich to resale and usage for all of us!

    In my simple mind - I can't understand why this is done by MS?

    Why dosent they change their configuration?


  • smilward,

    You are correct this is the server side browser file handling setting which is set to strict.  Feel free to keep posting and open a support request.  Also tag your comments with 'permissive browser file handling' which appears to be one of the most used tags.

    Here's a sampling of the many threads:

    Here's a description of the limitation:


  • Hi Jbooker

    I will do that - I will also open a support request with Microsoft!

    I already got the information yoy have provided, but thank you for beeing informativ and correct!

    This issue need to be solved - I will start kicking in MS doors tomorrow - BIG TIME!!!!

    I love SharePoint/Office 365 - therefore I'm pretty angry!!!


  • OK :-)

  • Collaboration ?

  • Hi smilward,

    There are a myriad number of reasons why this is not not enabled, chiefly amongst which are that security settings need to be lowered in order for this to be achieved, followed closely by the fact that the environment is multi-tenant.

    A change like this, while convenient for a lot of folks, would affect everyone within the farm.  One other thing to remember is this: the product was just released a few weeks ago.  It may not be a feature at this point in time, but it may be something considered in the future!