No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Anonymous Access

  • Adrian,

    Nice job-it works really well even on a P1 account..  And the instructions are easy to follow. Can the wsp be adapted to work on any list?

  • Thanks all (specially MCH and Adrian)!  

    I'll try it on my public survey I was trying to put together and move from the blog running SP 2010 On-premise.  


  • For sure, I will publish it on the weekend.

  • Oha, I spent a little bit more time to finalize the implementation the planed. Finally it’s ready and I am proud to publish my anonymous access configurator solution:


    Example for Calendaer, Custom List or Document Library:

    Example for Survey:


  • Adrian,

    I forgot to thank you for figuring this out and posting it. I especially like the way you got the icon into the ribbon. Now all we need is for MSFT to enable list publishing on the public web site as they did with the OLSB service. 

  • I still get the 404 Error

    I created a website collection

    and imported your solution

    When create a calendar (or List, or a blog)

    I still get 404 FILE NOT FOUND once I click on anonomous access.

    Please advise,

    best regards


  • Describe exactly what you're doing.
    I created an Attachment for this Reply with the Details I configured!
  • Maybe it's my browser but I can't open your pdf.
  • I fixed the small bug. Unfortunately it will not help you a lot. The solution will just display the failure that you have no anonymous access on your site collection. You have to create a public web application. There you can create the lists or a sub site and enable it. As far as I know is Office 365 not support anonymous access on the private site collections.

    You can download the new solution here:

    Be aware to clean all your browser caches after installing it. Otherwise it will not work.

  • Thanks for clarification. It works in the public area.

    Best regards


  • Now I have this 404 problem on an E account and a P account.  Nothing has changed but all of a sudden I cannot assign anonymous permissions to lists. Well, oddly a custom list or 2 it still works on but not lists that are part of a blog sub site. So technically, the solution still works but in this site it can't find the right url. I checked against an account where it is still working and all settings are the same so I'm dumbfounded. Tried deleting and reloading but still not working.