No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

External invites - permissions problem

This question is not answered This question is not answered

Can I control permissions for external users or not? In a P1 account, I've added an external user with an @Live id and they show up in the Members and Visitors groups. When I try to grant permission to the user id to access the team site, nothing happens - they don't get added. When I try to log in with the id, I just get access denied.

Is this feature ever going to work as promised or not?

All Replies
  • admintmnebr,

    You mean  it doesn't work for you? To be honest the instructions above aren't very clear to me,  so  I don't know if I'm doing them right or not. I think  "share site"  should simply mean what it says, and you should also be able to add users manually and then invite if you want.There shouldn't really be a need for any discussion about it. 


  • Ok, it definitely isn't working. I just tried again with a brand new account and an old account.

    New account: click share site and get this:

    Invitations to users outside your organization are currently disabled.

    Please add at least one user to the site.
    Checked and external invites is activated. There are several users with SP licenses in the site. Why would you have to have "one user" in a group? That isn't mentioned anywhere I can see.

    Old account: tried it both ways-adding a user to a group first and just sending the invite. Neither work.

  • I waited a while and checked and an invitation sent to an mos address that was confirmed as "sent"  was never received. So how do we get this to work?

    I think there's another place where you have to activate external invites in manage site collections but the global admin "doesn't have permission" to access the settings there. Really?  

  • Please try to help with this - it makes no sense whatsoever.

    I clicked "share site" and invited another MOS id

    I got the email and clicked the accept invite. 

    Error: Access Denied

     Current User
    You are currently signed in as:
    Sign in as a different user

    Of course I'm signed in with otherwise how would I be able to get the email? This is nuts!

  • Despite the bogus error message, I checked and the user did get added. So I added them to the owners group with full control. But they don't have "owner" permissions and can't see docs or anything they should be able to as an "owner.

    They're in the owners group

    The owners group has permission to access anything.

    The invited id doesn't have that permission


    So we're back to the original question.of this thread. What am I missing?

  • The messages are now getting even sillier:

    Invite from an E account to the only user of another P account. when I click the accept invite:


    The user does not exist or is not unique.

    Troubleshoot issues with Microsoft SharePoint Foundation.

    Correlation ID: 11b2a0c5-a8bd-489d-a78c-fe2f3dccdf25

    Date and Time: 5/14/2012 2:23:02 PM


    I don't even know what that means. 

  • Hello Mchv2.0,

    I have sent you a private message so you may start a service request for your issue. Make sure that you check the link to the Private Messages as it may not register that you have one.

    I will continue to monitor this thread for further posts or questions.

  • Was the LiveID that the invitee used a standard or account? Or was it a regular business account that had been associated to the LiveID system; sometimes referred to as EasiID? The EasiID feature was not working until we completed the latest service update. It is now working, but at the time you started this thread, that portion of external sharing was not working. Once they are into the site, you should be able to add them to a second group, beyond the one you specified when first sending the invite. You would look them up in the people picker from another permission group and add them manually.

  • Mark,

    I mentioned it was a MOS id. (