Personne n’a répondu à cette discussion depuis au moins un an. Par conséquent, ces informations peuvent être obsolètes. Si vous recherchez des informations sur ce sujet, recherchez une discussion plus récente ou publiez une nouvelle question.

Can't delete a sub site in P1

This question is not answered This question is not answered

I go to the parent site settings>sitesworkspaces and click delete and just get an error:

There is no Web named "/test-client".

Troubleshoot issues with Microsoft SharePoint Foundation.

Correlation ID: 19fb9bd5-41fd-4e0f-b746-08040fa00e31

Date and Time: 2/24/2012 10:45:14 AM

How the heck are you supposed to delete a sub site?

All Replies
  • mch,

    To delete a sub-site navigate to the sub-site's site settings -> delete site (under site actions)

  • Giaky,

    Thank you - I couldn't seem to find that. Still curious though why the X is there in the list of sub sites if it doesn't work?

  • Not sure...I noticed and tried that too.  I'm sure we'll hear a reason why and that in a future release Microsoft will have a fix for it, as we do with all issues.

  • Hi mch,

    This is Jonis from Microsoft Online SharePoint Support.

    I just deleted a blog site from Sites and Workspaces using the black X.  I then went into the recycle bin and restored the blog site.  I wonder if this is another intermittent XP Operating System issue.

    I am glad that you were able to find a way to get the site deleted.

    I will continue to monitor this thread for any additional posts or questions.

  • I had the same problem with some sub-sites. There's at least two ways I know to view the sub-sites and at least two ways to remove them. I used the same delete method but found the site still lingered in the list of sub-sites. It was also still accessible at it's URL. Maybe one method uses a different request or the system is slow to update?

  • Hi Jonis,

    With the help of a MSFT support rep I was able to resolve the button issue - it wasn't related to XP. This is also in another account without that issue, not mine  so I don't think that's it.



    When I delete it using the above method from Giaky it gets trashed immediately.  

  • Sorry for confusion, mch, I didn't specify which method. I had meant the method posted by Jonis with the delete icon doesn't seem to erase all reference to the site. The method posted by Giaky is the only way I've found to delete it successfully.