No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Workflow Edit Error : Failed to load the configuration file for the workflow

  • Hi!
    I am getting now strange error message "Failed to load the configuration file for the workflow" when I try to edit any Workflow.

    Please help!


  • Hi AmitKB

    I've not had this as a problem in Office 365, however I have seen this as a message when attempting to access material in an On-Premise version of SharePoint.

    We identified that this was a User Permissions issue, and when I came across it, it was simply that I'd logged in using the wrong account!!!  I'm certain that will not be your problem, however I would think back to when it last worked with your login, and see if changes to permissions etc have been made in any way since then.

    I hope this works for you.

    Regards  Alan C.

  • Hi AmitKB,

    This is Jonis from Microsoft Online SharePoint Support.

    Merley 72 presents a good point, as workflow permissions change based on the last user account that saved the workflow.  That is a good place to start trouble shooting the issue.

    I would like to include the following link to an article dedicated to the resolution of workflow errors: Troubleshoot Workflow Errors

    If that does not solve your question please let me know as I will continue to monitor this thread for any additional posts or questions.

  • Hi!

    I am using the login id of SharePoint admin and still getting same error, even the workflows are created by me.

    Please take a look at this video:



  • Hi Amit

    Thanks for the follow up and video of the problem.  I notice that some of the workflows you are attempting to change were the reusable versions and not the List workflows.  I've read somewhere that if you are attempting to modify a generic workflow that has been built for one language with a different language, then that can cause problems.  However you were also trying to change a List workflow as well so that shouldn't give the problem.

    Have you tried creating a List based workflow directly yourself, and then editing that a number of times?  If you can create one and then not edit a 'new' one that really would be odd.

    I have had another thought though which is to consider the basic language you are using on the site.  What is that set to and is there an implication of any choices you have / haven't made at that level.  This takes me into an area I know absolutely nothing about, but I do wonder if there is something around the 'Configuration File' that they are referring to being the language pack?  

    Thanks for the video clip and I do hope this is a problem you eventually get to the bottom of.

    Regards  Alan C.

  • Hi Alan,

    Thanks for the reply.

    I have tried creating a new workflow for a list several times but on second time publishing I get the error.

    I am using English version.

    In the video I showed you earlier, I tried to show you that every workflow produces the error and no workflow works fine.

    If you wish I can start a TeamViewer session and you can take a look.



  • Amit

    In order to see if there was anything that might give a hint about the problem, I did an internet search and came up with this piece of information - you've probably already found it, but it is worth a mention.

    In the document I looked for the word 'configuration' and came across the information by Jing Wa which suggests that changing the basic user groups can adversely affect matters.  I don't know if this is so, but I guess that you are prepared to look at anything to try and resolve things.  I hope that is worth considering.

    Also I had another thought - when you created the Workflow, did it have any particular input fields you added?  Again if permissions were messed up some way, then the input page (an XOML document) could be a problem, whereby inability to 'use' the input form might result in the 'Failure to Load...' message.  

    And finally, even though you get the error message when trying to edit the workflow, is it still possible to run the workflow against a document in the list/library itself?  If you can run the Workflow and it performs as required, then it truly DOES hint at being a permission problem in SPD.

    I hope the above helps or gets you thinking in different directions as none of the above is a definitive answer and I've run out of ideas.

    Regards  Alan C.

  • Hi Alan,

    I will take a look in the details  you have provided.

    I am not sure if I had mentioned that the problem in on SharePoint online Public Facing site.

    I am also going to check the security things related to Public facing site.



  • Hi AmitKB,

    This is Jonis from Microsoft Online SharePoint Support.

    Sorry for the delay in retuning to this post.

    Were you able to verify that you have well-formed XML in your workflow?  It is possible that the XML configuration file of the workflow contains invalid XOML markup.  To verify this from SharePoint Designer use the following steps.

    In Office SharePoint Designer, in the folder list, select the plus sign next to Workflows library to expand it

    1. Next select the plus sign of the workflow in question to expand it
    2. Double-click the configuration file (Workflow_name.xoml.wfconfig.xml) to open it
    3. Right-click on the page, and then select Verify well-formed XML
    4. Correct any errors and save the file
    5. Reopen the workflow to test

    Thank you for your reply and for using the Microsoft Online SharePoint Services Forums.  I will continue to monitor this thread for any additional posts or questions.

  • Hi Jonis!

    Thanks for your reply.

    I did as you instructed, but no error shown.

    I got the message "The document appears well nested and well formed".

    Also when I check for error, it don't shows any error and passes the error, but when I publish it I get error.

    What to do next?

    Once again I am saying that whatever I do, on the second time I try to publish the workflow, it throws error. Also it got publised on first time but not works.

    Just a question
    Can you tell me if workflows are allowed to send email on public facing site of Office 365 (SharePoint online).

    Please help we are stuck and project is stopped due to this.


  • Amit

    I think at this point you ought to take a step back, and consider the levels of complexity here.  I would then start right at the beginning and create the simplest of workflows on an internally facing simple list.  

    Initially create a manual workflow, and then don't try and edit it, simply see if it will run and change a document.  If that works using try switching to a different user Login and try running it.  If that works, then go back to the WF and try editing.  From that point build up the create, test, different user, add input page, CHANGE etc etc until you get to a point where something doesn't work.  At least you will be able to figure out the limitations and where things 'break'.  Hopefully that should give you some ideas about why things are going wrong as well.

    Sorry, but it is back to basics time I think.

    Regards   Alan C.

  • Hi Alan,

    Thanks for  you reply, I really appreciate it.

    Manual Workflow
    I tried to create a worflow manually but getting "User cannot be found" error. Take a look at video or screenshot.

    There is some more error on the site, I have contacted the support team to resolve those.

    I am trying to consult the support team about the this and other errors. I will keep everyone informed here if something got fixed.


  • Amit

    I hope that all problems get resolved in time, however one aspect that I got caught out by in normal SP land was that sometimes the Admin type role or accound cannot initiate a Workflow.  So even though Admin might be great to create the WF, try using an ordinary user's role to run it on a list item.

    Sorry that I can't come up with a solution, however hope that you get things resolved soon.

    Alan C.