No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

"Go To A Page" Button not working

  • I am converting a large website from Office Live to Office 365.


    The "Go To A Page" button on the development screen is not producing a dropdown list.


    This is slowing migration around the site during development.


    Does anyone know what might be causing this?


    Thanks in anticipation.

  • Hi CMCTWebmaster,
    This is Bob from Microsoft Office 365 SharePoint Support.  Thank you for reaching out to the community with your concerns about the Go to Button not working. 
    I have seen similar issues as far as buttons not working and what I had to do to fix it was reset my browser back to default.  I am not sure what caused this may be a corrupted cache file or an extension.  It may also be a limitation of the browser that you are using here is a link that explains the limitations 
    If this does not fix the issue you may have to create a service request as this may have to be escalated to our operations department.
    Please let me know if there is anything else that you may have questions on as I will be monitoring this thread over the next few days. 
    Kind Regards,
  • Thanks for that Bob.

    The Browser that I am using is Windows Internet Explorer 9 - so that should not have any limitations.

    I also tried it on Firefox and had the same issue.

    Could you please tell me what you mean by "Rest my Browser back to default" Is there a guide on how to do that?

    One completely separate issue.  Is there a way to set the default font for the website - my navigation buttons are in a different font to everything else. There certainly was on Office Live.

    Thanks for your help.

    I have to say thatconvering 570 pages (some very complex) from OL to 365 is proving a bit of a nightmare. Particularly as formating and spaces are  lost when pages are copied.


    aka CMCTWebmaster

  • Hi Jon,

    Thank you for your reply and I apologize in my delayed response. 

    I have been looking this issue up and seen that there can be a multitude of issues that can cause this.  The first thing I would want you to try is to reset the Browser as I mentioned before.  To do this in IE9 go to tools > Internet options, go to the Advanced tab you will see the section to Reset Internet Explorer settings click the Reset button.  If this does not help then I would suggest that you create a service request as this may need to be escalated to our operations department.  I will send the information to create a service request via private message.  Note that the PM may not show that you have one and you should click the link to the PM’s on the forum page to see if you have anything there. 

    Thank you,

  • CMCT,

    There've been reports of problems with various editor buttons for over a year now with no resolution. Aside from that, 365 isn't really designed for a web site of the scale you describe. Since you have to rebuild anyway with no assistance, I'd look at other options that make the job easier. There are plenty of free hosting services that will be much easier to work with and don't have the same bugs as 365.   

  • After getting frustrated with this damn Community Forum not being able to provide any useful answers, I decided to take things into my own hands.

    I went to the Feedback team.

    I have been in constant email conversations with them for many weeks, and NOW we've just solved the problem of having the 'go-to' button not operating.

    The problem was basic and the solution was extremely simple: Take all '&' (ampersand) symbols out of any Page Titles on your site. Simply rename them "and". The fix was that simple.

    Hope that helps some of you out there.

  • Englipedia

    I would not say it is that simple, my goto page works fine on my Win 7 box, and on 1 account on my Vista box, the other account on the Vista box has the problem. Since I am using the same software on Vista for all users, and since all 3 places I just mentioned I use with the same site, I there is more to it.

    BTW if click the the refresh or compatibility button a few time sometimes it fixes the problem where it does not work

  • I tested it out in XP - added an ampersand to title and the go to stopped working. Removed it and it worked again. Since there's a history of ampersands causing conflicts with the xslt used in OLSB (& is a resticted character in xslt)  it wouldn't surprise me  at least for XP machines this is the fix. Can't comment on Vista. What DOES surprise me is a user has to figure this out.
  • Englipedia,

    Thank you very much for your post. I agree with you regarding the difficulty in getting sensible answers. However your suggestion is 100% correct. I have taken all the ampersands (&) out of my Page Titles and now the drop down works. So I am now back in business.

    By the way, do you know how to set a default font for the site? I could do it in Office live but have failed in


    Thanks again for your assistance.

    CMCT Webmaster.

  • Bob,

    The problem is solved.

    It is simply a matter of removing "&" from Page Names.

    CMCT Webmaster

  • @CMCT, don't know about default font, sorry. I would say it would be as simple as throwing something into the CSS box on the site. But what's the code for that? Don't know...