Created by / user name invalidates rss feeds (blog site)

This question is not answered This question is not answered

How do I change the user name so I don't get an rss feed error for a blog sub site? It worked fine for a while but then broke.  The "created by" or "author" name comes from "user" I assume so I changed it in admin to an email address format but it still isn't valid. No problem with other blog feeds so it's a Sharepoint thing.

Invalid email address: matt howell (2 occurrences) [help]

      <author>matt howell</author>


You can see it here:
http://wb2-web.sharepoint.com/Pages/blog.aspx


All Replies
  • I removed the reference to the name/author in the list view and a few hours later that seems to have fixed this. Be nice if MSFT would at least comment though on the problem.

    http://wb2-web.sharepoint.com/Pages/blog.aspx 

  • Hi mch,

    This is Justin with Microsoft Online SharePoint support.  Thanks for posting.

    Just to get a better understanding on this site, can you provide information on how this blog was created?  If so, I can attempt to reproduce the blog page and posts to investigate errors.  Also, which list view are you speaking of when removing the name of the poster?  Please let me know so that I may research this.

    Thanks,

    Justin Ronan
    Microsoft Office 365 SharePoint Support

  • Justin,

    It's an rss feed of a blog sub site created under the public site in SPO. I converted the feed url to a javascript so it could be embedded on the public site. This works well with blogger and WordPress feeds.

    I'm not sure if removing or changing the user name actually did anything. But the fact that it wasn't an "email address" was the reason given when I checked if it was a valid feed. It seems when I edit a post it throws the error and then an hour or so later, it appears fine again.

    Any ideas?

  • Hi mch,

    I apologize for the delay of response.  However, the scenario you have described is unfortunately outside the support boundaries of my team as a custom solution is being used to create the blog site.  You may have luck posting this information to the MSDN SharePoint customization forum.

    Thanks,

    Justin Ronan
    Microsoft Office 365 SharePoint Support

  • What's up with the rss feeds? It was working for a while but now just shows a link to the blog posts instead of embedding them which it did before.

    http://wb2-web.sharepoint.com/Pages/blog.aspx