No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Setting up a public facing website

  • I had a website for a Homeowners Association on Office live. I moved it to Office 365 per the instructions. It is up and working. But I need a public facing sit that neither residents or visitors have to sign in. How do I make this happen? The website is "fairfieldindunwoody.com"
  • Brian,

    I accessed your website by entering: fairfieldindunwoody.com

    and I got in without using a login or password.

    It usually take 6 to 12 hours for everything to start working right after you perform the last step inmoving you domain over to O365

    1 out of 1 people found this post helpful.

  • Hi Brian,

     

    This is Tim with Microsoft Office 365 SharePoint Support.

     

    The website that we are able to see is public-facing anyone that browses to your domain will land on the site that Ken has posted a screen shot of.

    I will continue to monitor this thread if you have any additional questions.

    Thanks,

    Tim Muth

    Microsoft Office 365 SharePoint Support

    1 out of 1 people found this post helpful.

  • OK, first, thank you for your reply. I should have been more specific. I have documents that residents and visitors pull up. When I click on a doc and open it, the Office 365 log in comes up. If I delete it the doc opens, but how do I stop the log in from coming up? Thanks again.

  • Hi Brian,

     

    People are getting prompted because the document is located on the secured portion of your SharePoint site. Please follow the steps below to resolve this issue.

     

    1. Browse to the library where the documents are located.

    2. Open one of the documents so that it opens in the Web App.

    3. Copy the URL listed in the address bar.

    4. You will need to edit the hyperlink that you have created for each of the documents.

    5. When you edit the hyperlink, you will need to choose the "Web Site" option and the paste the URL.

     

    After you save the page, the links will update and people will be able to open the documents in browser.

     

    Thanks,

    Tim Muth

    Microsoft Office 365 SharePoint Support

    0 out of 1 people found this post helpful.

  • Thanks for your help, but I still have some issues.

    1. Browse to the library where the documents are located.

    This means to go into the Admin  page Edit Website and go to the Documents listing?

    2. Open one of the documents so that it opens in the Web App.

    Right click to open the doc to get the URL? It did open in the web app.

    3. Copy the URL listed in the address bar.

    Did that

    4. You will need to edit the hyperlink that you have created for each of the documents.

    Went to Edit Website, pulled up the page where doc link is shown, right clicked on hyperlink, clicked on "create/edit hyperlink",

    5. When you edit the hyperlink, you will need to choose the "Web Site" option and the paste the URL.

    Chose "Web Site". Pasted URL. When I go to the public website and pull it up, it opens in the Web App. How can I get it to open directly into the proper format (Word or Excel).

    Also if I go to open it in Word, the sign on screen pops twice before it opens in Word.

  • Thanks for your help, but I still have some issues.

    1. Browse to the library where the documents are located.

    This means to go into the Admin  page Edit Website and go to the Documents listing?

    2. Open one of the documents so that it opens in the Web App.

    Right click to open the doc to get the URL? It did open in the web app.

    3. Copy the URL listed in the address bar.

    Did that

    4. You will need to edit the hyperlink that you have created for each of the documents.

    Went to Edit Website, pulled up the page where doc link is shown, right clicked on hyperlink, clicked on "create/edit hyperlink",

    5. When you edit the hyperlink, you will need to choose the "Web Site" option and the paste the URL.

    Chose "Web Site". Pasted URL. When I go to the public website and pull it up, it opens in the Web App. How can I get it to open directly into the proper format (Word or Excel).

    Also if I go to open it in Word, the sign on screen pops twice before it opens in Word.

  • If you want it to trigger the local program (Word etc) just link directly to the doc stored in your public site's doc gallery  in the hyperlink tool (same as in OLSB).  Browsers can't render Word or Excel so your viewers will have to have a compatible version of the application to download/open them. If you have any pdfs which would normally open in the browser with an add on, they won't in 365 because most file types are blocked.

    0 out of 1 people found this post helpful.

  • I went through the steps Tim Muth listed in another thread but I am still getting the Off 365 login screen before the doc opens. This was never a problem in OLSB. How do I get rid of the login screen?

  • OK, I went back through and right clicked on each doc in the library, hit "copy shortcut", removed the old link, did "create/edit link" and pasted into the web site URL box and this worked. Thank you very much