No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

LyncSetup.exe cannot download but other downloads OK. Not in the cloud? Too many Hops?

This question is not answered This question is not answered

I am on a business trip, staying at the Intercontinental Hotel in the Philippines, and am not able to download Lyncsetup.exe to get started with Office 365.


The process has been started and stalled numerous times over the past 24 hours. I have read many other discussions in the Office 365 forums on troubles of this various nature and have noticed that the discussions seem to have stopped with private emails and do not have resolutions.


The screen clipping am providing shows a comparison to Office 2010 SP1 download happening simultaneously. LyncSetup.exe is repeatedly interupted or lost.


I believe that this LyncSetup.exe is not residing on the cloud and it has to go through too many hops over the internet to get where I am and is constantly broken up. Whereas Office 2010 SP1 download, which is 6 times larger in size (439MB vs. 71MB) is still downloading without any interuptions.


I do not see any alternative site to retrieve LyncSetup.exe from. Already the impressions for Office 365 setup are hard to process.


On another subject, Office 2010 continually crashes upon startup after the Office 365 emal account was used. I cannot start it even in the safe mode...


So, maybe these two are related but maybe not. I think the setup process needs to be made much smoother or Office 365 will get some bad press.





All Replies
  • Hi Daniel,

    I have tried to reproduce this issue and can download the Lync installation file properly. At this point, I suggest trying to download the LyncSetup.exe from the following site according to your system type. When the download window appears, please click Save.

    For 32 bit system:
    For 64 bit system:

    If the download still fails, please try to download the file again in Clean Boot Mode. To enter Clean Boot Mode, please refer to Step 1: Perform a clean boot in the following KB article:

    Mindy Pan


  • Hi Daniel,

    Has the LyncSetup.exe download issue been resolved yet?

    Mindy Pan
  • It was resolved only after I tried downloading it in the middle of the night. There is a need on the part of Microsoft to spread the location of this setup file to other parts of the world. As I wrote before, I could download a 545 MB file but could not download this 70 MB file and I tried more than 20 times in two different cities.

    It was not my internet explorer, but rather, it was the many hops the connection had to go through to get to the download point.  I did a traceroute to and it contains 18 hops and a ping time of 163ms. So, it kept getting timed out along the way. It is funny that Office365 is on the cloud but not this setup file for Office 365.

    Thank you for following up. I see many others have a similar problem and that is probably because these setup files are either on small servers or not mirrored anywhere else.


  • Hi Daniel,

    Thank you for your reply.

    I understand that the Lync installation file can be downloaded in the middle of the night. I appreciate the time you have invested testing this issue.  I have sent the feedback to our feedback collect team.

    Again, thank you for your feedback, and have a nice day.

    Best regards,
    Mindy Pan

  • Just to add some feedback to this group, I am seeing the same thing today.  I am trying to download the 64-bit version from the link you provided above.  It starts off fine and then at 2% completed it slows down.  Eventually in gets completely interrupted.  I have tried downloading this with IE and Chrome and have had the same experience so I believe there is some issue with this file or with the server it is being hosted on.  Obviously this is frustrating.  

  • Hi Sean,

    I have checked the links provided by Mindy and every file can be downloaded successfully. Have you also tried to download the file in Clean Boot mode as the steps provided by Mindy? If not, please try it again. If the issue recurs, I recommend you download the file in Safe Mode with Networking.

    Josephine Meng