No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Exchange Online with Android 4.2.1 (Samsung) erro message

This question has suggested answer(s) This question has suggested answer(s)

Hello,

 

with a Samsung Galaxy Nexus I get the following (error) message:

 

"De server m.outlook.com vereist dat u de server toestemming geeft bepaalde beveiligingsfuncties van uw Android- apparaat extern te bedienen. Wilt u het instellen van dit account voltooien"

"Annuleren / OK"

 

Translated this will give something like:

 

"The server m.outlook.com requires that you autherize the server to enable certain securityfeatures

to be remotely controlled. Do you want to continue the configuration of this account?"

"Cancel / OK"

 

This account has worked propperly until  16-12-2012. FYI I have tried to fix the problem by deleting the account and set up a new account, but to no avail

 

The Android version is 4.2.1 build JOP40D

All Replies
  • Hi Paul,

    In some cases, Android mobile devices may experience connection problems using m.outlook.com as the server name.
    If you are having connecting issue, please use the Host name as the server name for your device.

    To determine the Host name, please follow the steps below:
    1. Log in to the Office 365 portal (https://portal.microsoftonline.com/).
    2. Click "Outlook" to open "Microsoft Outlook Web App".
    3. In the upper-right corner of the page, click the "Help" icon (the question mark), and then click "About".
    4. On the "About" page, note the "Host address".

    For more detailed information, please refer to the following link:
    http://blogs.technet.com/b/exchange/archive/2012/02/07/cross-site-redirection-exchange-activesync-clients-in-office-365.aspx

    Thanks,
    Edward Qu

  • Hi Paul,

    How are things going on?

    Thanks,
    Edward Qu

  • Problem still excist. Did the second Galaxy Nexus within this company (which went to another company of which I do the IIT as well) and I have the same problem. It is a Microsoft Exchange online issue and nothing else. Both Samsung were working, received no updates (I double checked that on both devices) and did come up with this error.

    From what I see is that Exchange Online is trying to force a certain security policy which the Samsung will or can not accept (a script error???) What it looks like is a policy pushed to iPhones with modern Exchange servers which force the use of a PIN key to be entered on accessing the iPhone

  • Hi Paul,

    Please try the following steps below to troubleshoot this issue:
    1. Login to Office 365 Portal with an Office 365 administrator account.
    2. Click "Manage" under "Exchange" on the "Admin" page.
    3. Navigate to "Phone & Voice", and then click "ActiveSync Device Policy".
    4. Select "Default Policy", and then click "Details".
    5. Check "Allow devices that don't fully support these policies to synchronize", and then click "Save".

    6. Click "Myself" under "Select what to manage".

    7. Go to "Phone", click "Mobile Phones" tab.
    8. Delete your Mobile Phone.

    9. Re-configure your Office 365 account on the mobile phone.

    Thanks,
    Edward Qu

    0 out of 1 people found this post helpful.

  • Hi Paul,

    How is everything going? Do you have any updates about the status of the issue?

    Thanks,
    Edward Qu

  • Edward,

    It is not my phone but one of a of my clients. I hope to have the phone available next week. I will give you an update ASAP.

  • Hi Paul,

    We will monitor this thread. If you have any update or need further assistance, please feel free to post back.

    Thanks,
    Bourne Zhang

  • Hi Paul,

    How are things going on? Do you have any updates about this issue?

    Thanks,
    Edward Qu

  • I have checked this setting, but "allow devices that don''t fully support these policies to synchronize" was already checked so that's not the solution

  • Hi Paul,

    Please run Microsoft Exchange ActiveSync Connectivity Tests at https://www.testexchangeconnectivity.com/. If there is any error message, please post it here.

    Meanwhile, you are able to refer to the KB article to troubleshoot this issue:
    http://support.microsoft.com/kb/2563324

    Thanks,
    Edward Qu

    0 out of 1 people found this post helpful.

  • Hello,

    The problem is solved through a "work-around"

    FYI I have NO problems with a iPhone 4 or older HTC or a Samsung SII. All those works fine. The solution was to swap a privatly held Samsung SII with the company owned Nexus I. The SII did only Google mail, which the Nexus I also does. The SII is now connected to Exchange Online and working.

    So it is very likely that the problem is restriced to the Samsung Nexus I only and it might even be a Dutch (language version) only problem.

    I will solve the problem with the other Nexus I in a similar way.

    Case closed (as far as I'm concerned) :-)

  • Hi Paul,

    I am glad to hear you have resolved the issue by using a workaround. Meanwhile, I appreciate you share the solution with us. This is very beneficial to other users.

    Best Regards,
    Edward Qu

     

  • FYI: the issue is NOT solved. I have found a work-around. That is something totaly different. In all fairness I should say that I assume the the problems lays with Samsung and only partly with Exchange Online.

    The annoying things is that it has worked (with Exchange Online) till somewhere mid January 2013. Either Microsoft or Samsung (or both) did some update which causes this problem.

    However I'm not going to fight windmills, so this "work-around" is good enough for me and accepted by both involved clients.

  • Hi Paul,

    Thanks for sharing your experience.

    The workaround solution may help other users to resolve the similar issue.

    Best Regards,

    Keats Ge