No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Lync 2010 not saving conversation history

This question is answered This question is answered

Hi,

 

I am running Windows 7 64bit with Office 2010 64 bit Version 14.0.6112.5000. I am using Lync 2010 64bit and my conversation history is not saving in Outlook.

 

I know this was a problem with Office Communicator but I assumed it would be resolved once we moved to Lync.

 

Does anyone know a fix for this issue?

 

Thanks for your help

Verified Answer
  • I found a hotfix for Lync and now it is working.

All Replies
  • Unfortunately I do not have Office 64 bit installed to try to test this.  I do assume that you have configured the Lync client to save conversations to Outlook under Tools\Options\Personal?

    I will say that although Microsoft does publish Office 2010 in a 64 bit version, they still recommend the 32 bit version.

    0 out of 1 people found this post helpful.

  • Yes everything is configured correctly

  • Yes it is configured correctly.  Is this issue just with you or all employees?  does everyone have Office 64 bit installed?

    0 out of 1 people found this post helpful.

  • Hi Jon,

    After checking your screenshot, I noticed that the settings on Lync client are configured properly. To troubleshoot this issue, I suggest you to run Desktop setup to configure your Outlook and Lync to work with Office 365: click Downloads on the right site of your Portal page, then click Set up of Set up and configure your Office desktop apps.

    If the issue persists, you can refer to the steps in the following KB articles about how to troubleshoot the integration issue between Lync and Outlook client.

    support.microsoft.com/.../2436962

    support.microsoft.com/.../2000886

    Best regards,

    Nancy Xie

    0 out of 1 people found this post helpful.

  • Hi Jon,

    Did you find the above posts helpful?

    I will continue to monitor this thread if you have any additional questions.

    Best regards,

    Nancy Xie

    0 out of 1 people found this post helpful.

  • No your response did not resolve anything. I have been through these steps plenty. Everything is configured correctly everything has been run that can be. It is sporaticly synching the conversation history but it is about 5 days behind. All users on 32bit seem to have no problems and most users on 64bit are working as well.

  • It is absolutely absurdly ridiculous to suggest going to 32bit Office 2010. Why use a 64bit operating system and run 32bit software??????

  • Hi Jon,

    Thank you for your response.

    By default, Microsoft Office 2010 installs the 32-bit version of Office 2010 even if your computer is running 64-bit editions of Windows.

    The 32-bit version of Office 2010 is the recommended option for most people, because it prevents potential compatibility issues with other 32-bit applications, specifically third-party add-ins that are available only for 32-bit operating systems.Thank you for your understanding.

    About additional information,See Choose the 32-bit or 64-bit version of Office


    Thanks,

    Keats Ge

    0 out of 1 people found this post helpful.

  • Hi Jon,

    Please refer to Keats' information. If you still have questions about this issue, please feel free to post in our forum.

    Best regards,

    Nancy Xie

    0 out of 1 people found this post helpful.

  • THANK YOU MICROSOFT TECHS FOR BEING YOUR USUAL UNHELPFUL SELVES!!!!!! Seriously is there not anyone that works for Microsoft that actually knows how to fix a problem?????? Great job reading from your manual you were provided.

  • Hi Jon,

    Sorry for the inconvenience caused by this issue. The compatibility issues always influence our computer and service performance.

    When you use the 64-bit version of Office, all add-ins you need to run for Office must also be 64-bit editions. However, not all add-ins have 64-bit editions currently, which is the reason why we recommend our customers to install the 32-bit version of Office because of the occasionally compatibility issues.

    We are working on these compatibility issues to improve the performance between 32-bit version and 64-bit version. Before this issue been resolved totally, I’d like to suggest you to use the 32-bit version of Office to avoid the problem. You can also give Feedback to Microsoft for your concern to help us improve our service.

    Thanks for your understanding.

    Best regards,

    Nancy Xie

    0 out of 1 people found this post helpful.

  • I realize there are some applications who do not have a 64bit add-in but we are not talking about a bunch of different applications we are talking about a Microsoft developed product that has a 64bit version.

    I believe your solution is completely ridiculous but I gave it a try anyway and well it turns out my assessment of this proposed solution was correct.

    You cannot even install Microsoft Lync 2010 32bit on a Windows 7 64bit operating system. Please explain to me how you think it would be better to run Office 2010 32bit and Lync 2010 64bit and not have any compatibility issues?

    Could someone with some technical knowledge of this issue please help?  

  • Just to clarify for anyone reading this article. THIS IS AN ISSUE WITH MICROSOFT LYNC 2010 NOT ANY 3RD PARTY APPLICATIONS.  

  • Hi Jon,

     

    I notice that the conversation history has ever been saved successfully. To troubleshoot the issue, I would recommend you delete some caches of Lync client to see if it can solve the problem.

     

    To delete the endpoint cache, follow these steps:

        1. Locate the local application data folder:

          Windows Vista and Windows 7:  

          %LOCALAPPDATA%\Microsoft\Communicator\<\">sip_address@contoso.com>\

        2. Delete the file that is named EndpointConfiguration.CACHE.

        3. Restart Lync 2010, and then try to sign in to Lync Online.

     

    To delete the Crypto RSA key container, do as following:

        1. Open Windows Explorer and locate the C:\Documents and Settings\<User>\Application Data\Microsoft\Crypto\RSA\ folder. (For Windows Vista and Windows 7, the location is C:\Users\<User>\AppData\Roaming\Microsoft\Crypto\RSA)

        2. Delete the RSA key subfolder. The name of the RSA key subfolder consists of a long string of numbers and characters. For example:

                 S-1-5-21-433994307-1646369186-2100375486-500

        4. Restart the computer, and then try to sign in to Lync Online. If the issue persists, please check the issue again by using the Step 3.

     

    Furthermore, please check if the conversation history is saved in OWA and Lync client.

     

    Thanks,

    Nancy Xie