No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Skydrive Pro won't sync. Credentials required and nothing happens

This question has suggested answer(s) This question has suggested answer(s)

I have Office 365 small biz premium.  Skydrive pro on desktop will not sync and keeps telling me I have to "credentials required".  When I click on "enter credentials", nothing happens.  I tried logging in online per other forum suggestions.  nothing.  i restarted the laptop and tried logging in online before syncing the destop skydrive.  nothing.  what next?

All Replies
  • Hi Atan,

    I would like to confirm the following information:

    Can you find the “SkyDrive - Pro Up to date” icon on the right corner of the taskbar after clicking the “SkyDrive Pro 2013” from the Start menu?
     If so, I suggest you perform the following steps to reproduce this issue.

    1. Click “Stop syncing a folder …” after clicking the “SkyDrive - Pro Up to date” icon.

     2. Select the folder that can’t be synced from the “Microsoft SkyDrive Pro” window.
    3. Click the “Stop syncing” button.
    4. Click “Yes” when you receive the pop-up message window as below: 
    5. Click the “SkyDrive Pro 2013” program, you will receive the window “Microsoft SkyDrive Pro” window. Please select “Sync a different library instead”.
    6. Copy a new library URL from the SharePoint site and paste it in the window under “Which library do you want to sync?”. Then click the “Sync Now” button.
    7. Select the folder from the list under “Select the library you want to sync” window, and click “Sync selected”.
    8. Click the “Show my files…” button in the above window. 
    9. You can add a file to this folder, and then check if it is show up to library in the Team Site.

    If it syncs correctly, the issue is caused by the temporary connection issue. You can remove the previous sync folder and add the folder again to troubleshoot this issue.

    If the error message "credentials required” appears again, please capture a screenshot for further research. I will continue following up with you to fix it.

    Monica Tong

    0 out of 1 people found this post helpful.

  • Hi Atan,

    I’m writing to follow up on the previous thread we worked together on. Has the issue been resolved? If so, please let us know how you fixed the issue. If not, please share with us the current situation for further research.

    Monica Tong

  • Permanently stopping sync and doing it again works.  thanks.

  • Hi Atan,

    I am glad to hear that the issue is resolved.

    Best Regards,
    Monica Tong

  • Hi, I am having EXACTLY the same problem.  Won't sync, says credentials required, but when I click nothing happens.  I am working on a Surface Pro and I cannot find the SkyDrive Pro menu Monica refers to, so I cannot stop syncing.  If I click on SkyDrivePro it just opens the copy on my computer.

  • Hi Julia,

    To further investigate this issue, could you help to collect the following information?

    What’s the type of your Office 365 subscription? E.g. Office 365 Small Business, Office 365 Small Business Home Premium, Office 365 Enterprises
    Have you installed the SkyDrive Pro feature in Surface Pro?
    Could you capture a screenshot of the icon you can view in the Surface Pro?

    Monica Tong

  • Monica,

    I am having exactly this issue myself - it has started this morning.  I will try deleting and Resyncing - what is the root cause of the issue though?



  • Hi Mark,

    Is the issue fixed after deleting the synced list and re-syncing it again? If so, the issue might be caused by the corrupted connection between SkyDrive Pro sync and the SharePoint Online site.

    If the issue persists, to further investigate the issue, could you capture a screenshot of the latest error message?

    Best Regards,
    Monica Tong

  • I desperately need some assistance to help me understand SkyDrive Pro and its use of credentials.

    I have the same Skydrive Pro synch issue as above, when I select ‘Enter credentials’ nothing happens.

    If I then select 'Stop synching a folder..' and re-synch the document library, I get the message 'We can't connect to the specified SharePoint site'.

    I spent several hours exploring various options until I happened across another sub site on our Team Site that SkyDrive pro was happy with.  I looked at the Site Permissions and one by one removed users and groups until I discovered that as soon as I removed my Microsoft ID (which happened to be in the ‘Members’ group which has Contribute permissions), SkyDrive Pro had a problem with ‘credentials’.  As soon as I added my Microsoft ID back to the ‘Members’ group to the library SkyDrive Pro worked again perfectly.

    It appears SkyDrive Pro is somehow selecting my Microsoft ID credentials, and not my Office 365 ID to access SharePoint.  How do I check what credentials SkyDrive Pro is using?

    I am using Windows 8 (logged on as the Microsoft ID mentioned above).  My Office 365 ID has admin privileges to the Office 365 subscription which is P1.  I have ‘Microsoft Office Professional Plus 2013’ 15.0.4420.1017 32bit installed.

  • Monica,

    his is still happening almost every day.  My perception of Skydrive Pro is now very low and is pretty much the worst software feature I have ever worked with.  So much so I am going to remove it and move everything to dropbox which is at least stable.

    Here is a screenshot of the message I get, clicking the enter credentials box does nothing other than clear this dialog.

  • I too have a Organisational account and a personal LiveID with the same email address.

    I have tried to close my LiveID account but it tells me I can't as I have a subscription associated with it, but I don;t  - it's two copies of Visio 2013 I have bought outright not on subscription.

    I have tried to talk with some MS personnel but can't even get through to the right personal to talk to.

    This is simple doing my head in and getting me very frustrated.

    Time to move back to dropbox.

  • Hi Mark,

    We have received some question from users’ about the “Enter credentials” as you mentioned. Before moving on, I suggest installing the hotfixes for SkyDrive Pro in the following two articles:

    1. Description of the SkyDrive Pro update: July 9, 2013
    2. Description of the SkyDrive Pro hotfix package (Groove-x-none.msp): August 13, 2013

    If the issue persists, have you checked Microsoft ID in Members group as John mentioned? It’s a good point to narrow down this issue.

    From the current symptom, the issue is a little specific. I’m sorry for the inconvenience this has caused. Thanks for sharing the tests you performed and your understanding as we work to investigate further.

    To further research this issue, I would like to collect the following information:
    1. Both your vanity domain and the onmicrosoft domain (
    2. Your geographic location, such as EMEA, LATAM, APAC, North America...
    3. The default language for your site.
    4. The Team Site URL
    To protect your privacy, I have sent you a private message on this. It was responded in a private message with a subject of "Information Request".
    a. Please go to the "Your details" section on the right side of the community site.
    b. Click "Private messages".
    c. Click the subject title of the response to read the message.
    d. You can reply by using the form in that display to provide the information requested.
    @John, from the information I received, it uses Office 365 credentials to sign in to the SkyDrive Pro. What’s Microsoft ID you mentioned? You can provide the information in a private message. I will further check it.

    Best Regards,
    Monica Tong

  • Hi Monica,

    SkyDrive Pro started working for me after I installed the hotfix kb2727104, the second of your two options above.  I have run it now for two days and not once received the credentials issue.

    This is very good news indeed, thank you very much for sending us this.  Please can you feed this back to the technical team involved so they can recommend it's formal release.


  • Hi John,

    Thank you for sharing with us the good news. I am very glad to hear that the issue has been fixed by the hotfix KB2727104. I have forwarded your comments to the technical team internally. We appreciate your efforts on the suggestions.

    I believe others who encounter the similar issues will be benefit by your feedback.

    Best Regards,
    Monica Tong

    0 out of 2 people found this post helpful.

  • Hi Monica,

    I'm afraid the problem is back.  SkyDrive Pro is again using the Microsoft Account credentials and NOT the Office 365 account credentials when I logged back in today.

    I would appreciate you forwarding this feedback to the technical team and also could you ask how you check what credentials are being used.