Unable to ping webdir.online.lync.com

This question has suggested answer(s) This question has suggested answer(s)

I am trying to connect to lync 2013 with my android device and I get a continuous "signing-in" progress.

 

When I tried to ping webdir.online.lync.com and I got:

 

C:\Users\dimitri.robin>ping webdir.online.lync.com -t

Pinging webdir.online.lync.com [132.245.1.28] with 32 bytes of data:
Request timed out.
Request timed out.
Reply from 10.22.112.206: Destination net unreachable.
Reply from 10.22.112.206: Destination net unreachable.
Reply from 10.22.112.206: Destination net unreachable.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Reply from 10.22.112.206: Destination net unreachable.
Reply from 10.22.112.206: Destination net unreachable.
Request timed out.
Reply from 10.22.112.206: Destination net unreachable.
Reply from 10.22.112.206: Destination net unreachable.
Reply from 10.22.112.206: Destination net unreachable.

All Replies
  • Hi DrobinIT,

    Sorry for the inconvenience cause by the issue. However, the current release of Lync 2013 for Android smartphones isn't supported on Android media tablets or on other non-phone Android form factors (hardware models).

    For more information, click the following article number to view the article in the Microsoft Knowledge Base: 2829747 Android smartphone devices that are supported for use with Lync 2013 for Android.

    Moreover, please refer to the article to troubleshoot the issues with Microsoft Lync 2013 for Android: http://support.microsoft.com/kb/2834018

    If is it not your situation then could you please provide us detailed information with capture a screenshot? So that we can further assist you to find a solution.

    Thanks for your patience and understanding.

    Best regards,
    Shyamal

  • Hi Shyamal,

    I never mentioned that I was using a tablet. I am using a galaxy S3 on android 4.1.2 and according to support.microsoft.com/.../en-us it is supported. When I DO somehow connect, I get the following:

     

    Lync 2013 Mobile Version

     

    According to some sources found during my research, it seems as though this error is caused by not running the latest version of Lync Server
    2013. 

    The fix is to Make sure you have at least the February Cumulative Update 1
    patch applied to your server.  Without this patch, the Lync client will
    not be able to login.

     

    The problem that I have is that my office 365 is cloud based and we don't have a server. I need to confirm that you guys have the patch installed.

  • Hi DrobinIT,

    Sorry we are unable to see the error message, which you have attached screenshot. To post the screenshots, please refer to the following steps:

    1. Use rich formatting to post your reply.
    2. On the top ribbon, click on Insert Image, and then browser the picture to upload.
    3. Click Insert.
      
     
    In addition, I would like to confirm the following information with you:

    1. Have you tried to sign in on another device such as iPhone/Windows Phone?
    2. Can you sign in on a different network—for example, at home, or at a public wireless access point?
    3. Have you tried manually add Lync server settings?
    To do this, please refer to the following steps:
    1. On the Lync sign-in screen, tap More Details (Windows) or Show Advanced Options (iPhone, iPad, or Android).
    2. Turn off Auto-Detect Server.
    3. In both the Internal Discovery Name and External Discovery Name boxes, enter sipdir.online.lync.com:443

    For more information:
    Microsoft Lync 2013 for Mobile Clients
    Get started with Lync 2013 for Android

    I have sent you a private message with the subject <Please provide us domain name>.

    Here are the steps to access the private message.
    1. Please go to "Your details" section on the right side of the community site.
    2. Click Private Messages.
    3. Click the subject title < Please provide us domain name > to read the message.

    Best regards,
    Shyamal

  •  

     

     

    According to some sources found during my research, it seems as though this error is caused by not running the latest version of Lync Server
    2013. 

    The fix is to Make sure you have at least the February Cumulative Update 1
    patch applied to your server.  Without this patch, the Lync client will
    not be able to login.

     

    The problem that I have is that my office 365 is cloud based and we don't have a server. I need to confirm that you guys have the patch installed.

  • Is it possible for you to send me the PFX CERT for *online.lync.com?

     

    when I travel to https://lyncdiscover.gemaire.com, I get the following:

     

    lyncdiscover.gemaire.com uses an invalid security certificate. The certificate is only valid for the following names:

     

    *.online.lync.com , meet.lync.com , *.infra.lync.com , sched.lync.com , *.lync.com

     

    (Error code: ssl_error_bad_cert_domain)

     

    I want to try to install the cert directly to my phone to confirm that this indeed might be the source of the problem. I say this because our IPHONE users use the app just fine. We have found out that IOS does not try to validate the SSL cert when using the app (whether that was intentional or not is up in the air) while ANDROIDS try to verify the Cert. My phone does not give an error but the LYNC CONNECTIVITY ANALYZER emulator shows the error:

     

    "An error occurred while sending the request.
    The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.
    The remote certificate is invalid according to the validation procedure."

  • Hi DrobinIT,

    I have checked your Lync Online DNS setting with the Lync Remote Connectivity Analyzer (RCA). The test result are successfully examines all four DNS records that are required by Lync Online to correctly configure. Unfortunately you got the error messages. I totally understand your situation and what you concern about this case, therefore before involving the Escalation Team to investigate this issue. I would like to collect the following information to determine if it is a server side or a device setting issue.

    • How many users are affected by this issue?
    • Have the same issue with all the users using Android device?
    • Has the problem recently appeared to the user?
    • Which kind of environment do you setup? Is it Hybrid/ADFS deployment or purely cloud based? However, you have already mentioned ”The problem that I have is that my Office 365 is cloud based and we don't have a server.“ Just for the double confirmation.

    Moreover, Lync 2013 for Android provides transport layer security (TLS) and perimeter/internal network protection without requiring a VPN. We recommend download the latest updated October 2013 app version 5.1.0000. Please refer to the blog for downloading: Lync 2013 Mobile Client for Android

    Your patience and cooperation are highly appreciated.

    Best regards,
    Shyamal

  • Hi DrobinIT,

    I’m writing to follow up on this thread. Do you have any updates on this issue? Please post back at your convenience.

    Best regards,
    Shyamal

  • - ALL android users are affected by this issue

    - ALL android users have the same issue

    - The problem has been present as soon as user was configured and attempted to use android device

    - The Environment is PURELY cloud Based

    - We ARE using the latest APP version 5.1.0000

     

     

    Our CNAME lyncdiscover.gemaire.com points to webdir.online.lync.com and when you navigate to https://lyncdiscover.gemaire.com/ you get the following:

     

     

    lyncdiscover.gemaire.com uses an invalid security certificate. The certificate is only valid for the following names:

     

    *.online.lync.com , meet.lync.com , *.infra.lync.com , sched.lync.com , *.lync.com (Error code: ssl_error_bad_cert_domain)

     

    THIS Shyamal, is the problem. we need to resolve THIS issue.

  • Hi DrobinIT,

    I really appreciate your patience and cooperation. Please try navigating to http://lyncdiscover.gemaire.com/. Instead of https, type http and then check this issue.

    Moreover, try to manually add Lync server settings.
    1. On the Lync sign-in screen, tap More Details (Windows) or Show Advanced Options (iPhone, iPad, or Android).
    2. Turn off Auto-Detect Server.
    3. Enter addresses in the boxes:
    • Internal discovery address*:
    https://webdir.online.lync.com/Autodiscover/autodiscoverservice.svc/Root
    • External discovery address*:
    https://webdir.online.lync.com/Autodiscover/autodiscoverservice.svc/Root

    Please let me know if you still have any problems, so that we can further assist you.

    Best regards,
    Shyamal

  • Hi Shyamal,

     

    When I navigate to http://lyncdiscover.gemaire.com/ , I get the following in IE, Firefox, and Chrome:

     

    <resource rel="root" href=" https://webdir0b.online.lync.com/Autodiscover/AutodiscoverService.svc/root?originalDomain=gemaire.com"><link rel="user" href=" https://webdir0b.online.lync.com/Autodiscover/AutodiscoverService.svc/root/oauth/user?originalDomain=gemaire.com"/><link rel="xframe" href="https://webdir0b.online.lync.com/Autodiscover/XFrame/XFrame.html%22/%20originalAttribute=%22href%22%20originalPath=%22>

     

    As far as those sign-in steps that you gave me, I get a message "We can't sign you in. Please try again" :

     

     

    I also tried to connect over my carrier:

     

  • Hi DrobinIT,

    It’s really strange, we have checked and found that your organization has been set up ADFS/DirSync environment. Moreover, to narrow down this issue I’ve sent you a new account in my tenant via private message. You can test connect to Lync 2013 with android device and let me know the result.

    Here are the steps to access the private message.
    1. Please go to "Your details" section on the right side of the community site.
    2. Click Private Messages.
    3. Click the subject title < Please check user account details > to read the message.

    Best regards,
    Shyamal

  • Hi Shyamal.

     

    using the login credentials you provided me in the Private Messages area  along with the internal and external address of:

     

    https://webdir.online.lync.com/Autodiscover/autodiscoverservice.svc/Root

     

    I was able to connect:

     

     

    There also was an update to the APP itself, but to no effect, I STILL cannot sign in with my gemaire credentials.

  • Hi Shyamal,

     

    While troubleshooting things on my end, I noticed some things. to further DEBUG the lync app, I used another app that shows me the PORTS that specific apps connect to and what IP address they use. To begin my search I used NSLOOKUP to find what IP webdir.online.lync.com points to. That answer was:

     

    Name:    webdir.online.lync.com
    Addresses: 132.245.1.24

     

    Then I used the app to find out which IP I connected to and what port. I noticed that when I first run the LYNC APP, it connects to port 80:

     

     

     

    Once I put my credentials and try to connect. the connection changes to port 443 and changes IP:

     

  • Hi Dimitri,

    Sorry for the inconvenience caused by the issue.

    I have read through the whole posts. According to the information you've provided,  the test user can log into the mobile device without issue, it could be related to the federated users instead of the mobile device.

    As @Shyamal mentioned above, your organization has enabled ADFS based on our research. To narrow down the issue, can you please perform the following tests:

    1. Navigate to https://testconnectivity.microsoft.com/?tabid=o365.
    2. Perform the Office 365 Lync Domain Name Server (DNS) Connectivity Test and Office 365 Single Sign-On Test listed in the page both in internal network and external network.
    3. Send the detailed test logs to me via the PM sent by @Shyamal before, you can find the steps in @Shyamal’s post about how to find the PM.

    At the same time, to check if the issue is related to the federation settings, I suggest you change one of the users’ UPN to a non-federated domain (like the default onmicrosoft.com), then use the account to log into Lync mobile on the device. So that we can compare the differences with federation enabled or disabled.

  • Hi Dimitri,

    Thanks for providing the logs.

    From the logs, we can see that both the DNS records for Lync and the settings for ADFS are correct. I noticed that you’ve mentioned that the iPhone users are working fine. To further narrow down the issue, can you please confirm are these Android devices are using the same version of Android OS (like 4.3 or 4.2)? At the same time, please try the following steps to collect the sign in logs for Lync client on Android:

    1. Open Lync 2013 for Android, click the more settings icon in the lower right and select “Options”.
    2. Scroll down the screen until you see the “Logging” setting, change the setting to “ON”.
    3. Back to the login screen, use the problematic user to log into Lync, wait for it fails.
    4. Back to the “Logging” setting, click “Send log Files” and send it to your mailbox.
    5. After you receive the log file, please send the log file to me via the ways showed in the PM I’ve sent to you.