No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Sharepoint saying excel files do not contain visible names

This question is not answered This question is not answered
I recently had a friend of mine set up my sharepoint by creating a folder and mapping it to sharepoint. Everything seems to work fine except for Excel. When I open up my spreadsheets some of them open in sharepoint just fine. However, when I go to open other spreadsheets it will not open them but instead displays a message saying "Workbook can not be opened as it does not contain any visible names". When I check the box next to the Excel file in sharepoint and click edit documents it will open up any spreadsheets with no issues. I have read several post, blogs etc. and none of those solutions seem to help. Please review and advise
All Replies
  • Hello Victory5211,

    This is Jason Burnside from Microsoft Office365 SharePoint Support.

    Thanks for coming to the communities with your concerns about opening an Excel document in the browser.

    Please try the following instructions:

    1)      Go to the Excel document on your local computer and open it using your client application

    2)      Click the File tab

    3)      Click Save & Send

    4)      Click the Save to SharePoint option

    5)      Click the Publish Options

    6)      Click the Show tab

    7)      Click the Entire Workbook dropdown and make sure that All Sheets has a check mark in the check box

    8)      Save

    9)      You may choose a recent location to save the document to or upload it to SharePoint from SharePoint

    I will continue to monitor this thread for further posts or any additional questions.

    1 out of 1 people found this post helpful.

  • Hello Victory5211,

    Did you have any further questions?

     

    I will continue to monitor this thread for further posts or questions.

    1 out of 1 people found this post helpful.