No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Office 365 P1 - "Cannot open file template" error when a user clicks an Office document link

  • I'm using Office 365 Plan P1. I get a "Cannot open file template" error when I try to create a new Word, PowerPoint, or OneNote file from the Office 365 "Home" page.

    The behavior is exactly as described in the following knowledge base article: http://support.microsoft.com/kb/2540236. The article states that the error is caused by missing template files and describes a process for importing the files to the site.

    Unfortunately, I am not able to complete the steps described in the knowledge base article because the All Files link does not show when I open my site in SharePoint Designer. I'm guessing that this is because I am using the P1 plan and that this functionality is not available.

    Any other ideas or options?

    Thanks,
    David

  • Hi David,

     

    This is Tim with Microsoft Office 365 SharePoint Support.

     

    When you connected to your SharePoint site using Designer, did you set it up so that it goes to http://%3cdomain%3e.sharepoint.com/teamsite or http://www.%3cdomain%3e.com/teamsite? If it is connected properly, you should see the all files as in the screen shot below.

     

     

    I will continue to monitor this thread and wait for your reply.

    Thanks,

    Tim Muth

    Microsoft Office 365 SharePoint Support

  • Thanks for the reply, Tim. Unfortunately, still no luck solving the issue.

    I am able to successfully connect SharePoint Designer to both my Public Site and my Team Site using these versions of the links: http://www.[domain].com/ and http://www.[domain].com/TeamSite/.

    The following alternate versions would not connect: http://[domain].sharepoint.com/ and http://[domain].sharepoint.com/teamsite. I assume this is because I selected my SharePoint website as the home page for my domain.

    When connected to SharePoint Designer, neither my Public Site nor my Team Site have the All Files link as shown in the screenshots below. I'm still wondering if this is because I am using Plan P1 rather than one of the enterprise plans and I simply don't have permission to access All Files. (I don't see the Master Pages link either.)

    Appreciate your continued help with getting the Office web app links working again from my Office 365 Home page!

    David

  • Tom, any word on getting the Office web app links working again from my Office 365 Home page? Just following up since I hadn't heard anything after my 4/14 reply to your questions.

    Thanks,
    David

  • Sorry, meant to direct the prior post to Tim.
  • Hi David,

     

    I am sorry for my delay in responding. Is your user account a site collection administrator? I have check with other P1 subscriptions, and they all have the "All Files" option. It is looking to me like you do not have full site collection administrator permissions and that is why you are not able to see the "All Files". 

     

    Thanks,

    Tim Muth

    Microsoft Office 365 SharePoint Support

  • Tim,

    I'm going to show my ignorance now. How do I determine if my account is a site collection administrator?

    I looked through the Site Settings, particularly the section on Users and Permissions, but I didn't see any mention of site collection administrator.

    Thanks
    David

  • Hi David,

     

    If you do not have the "Site Collection Administrators" under Users and Permissions in the Site Settings. You are not a site collection administrator. Please refer to the screen shot below for the exact location of the "Site Collection Administrators" option.

     

     

    Thanks,

    Tim Muth

    Microsoft Office 365 SharePoint Support

  • Tim,

    "Site collection administrators" does not show under Users and Permissions in my Site Settings (see screen shot below). How do I fix this?

    Thanks,
    David

  • Tim,

    Any word on how to re-enable my "site collection administrator" permissions for my P1 site?

    Thanks,
    David

  • Hi David,

     

    Since you do not have the option for "Site Connection Administrator" under "Users and Permissions" in the Site settings, you will need to create a service request to get your permissions back. I have sent you a private message with the information that you will need to create the service request.

     

    Thanks,

    Tim Muth

    Microsoft Office 365 SharePoint Support