No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

Forwarding and Auto Replies not working.

This question is answered This question is answered

Hi,

 

I cannot believe that such a basic feature can be malfunctioning or so hard to configure at all...

 

Automatic Replies is not working.

I have selected "Send automatic replies", checked "Send automatic reply messages to senders outside my organisation", and selected "Send replies to all external senders".

I send an email from Gmail to my O365 account and I did not recieve any automatic replies in Inbox, Spam or Junk.

 

Forwarding is also not working as expected.

I unchecked "Leave a copy of forwarded messages in Outlook Web App". But it still keeps the mail in the inbox. I do not want to keep mail in the inbox.

 

My email domain is exheat.com.sg

 

Any help please? Thanks.

Verified Answer
  • Hello Jake,

    Thank you for your update.

    If you require both feature of forwarding and automatic replies.  For a workaround, you can refer to steps below to archive this.

    Note: With this option, mailbox will keep a copy of forwarded messages.

    1. Stop forwarding by clicking Stop Forwarding under Connected Account page.

    2. Create a Inbox rule to forward all emails to another mailbox referring to steps in article below.

       New Inbox Rule
       http://help.outlook.com/en-us/140/ms.exch.ecp.newinboxrule.aspx

    3. Disable the automatic replies settings and enable them again.

    Thank you.

    Jack Sun

    1 out of 1 people found this post helpful.

All Replies
  • Hello Jake,

    To address your concern clearly, I would like to answer your questions one by one.

    Question 1, Automatic Replies is not working when you configured forwarding for mailbox.

    Answer 1, Yes, when you configured both Automatic Replies and Forwarding options for your mailbox, the mailbox will not send automatic replies. I have tested the scenario and reproduced the same result from my side.

    Question 2, I unchecked "Leave a copy of forwarded messages in Outlook Web App". But it still keeps the mail in the inbox. I do not want to keep mail in the inbox.

    Answer 2, To troubleshoot this problem, please try the steps below and check if the problem can be fixed.

    1. Access your mailbox via OWA.

    2. Stop forwarding by clicking Stop Forwarding under Connected Account page.

    3. Input the destination email address for email forwarding, uncheck the option "Leave a copy of forwarded messages in Outlook Web App" and start forwarding again.

    If the issue persists, please post back the result of following cmdlet after connecting windows powershell to Exchange Online.

    Get-Mailbox alias | fl DeliverToMailboxAndForward

    Thank you.

    Jack Sun

  • Automatic Replies

    Then what can you suggest I do to achieve both forwarding and automatic reply?

    My purpose is to automatically inform senders that the email account is obsolete; and then forward the incoming mail to the new account.

     

    Forwarding 

    Before I stop forwarding I check and get

    DeliverToMailboxAndForward : True

    After I stop forwarding and start it back again, I also get

    DeliverToMailboxAndForward : True

     

    However, it seems that I do not recieve the incoming mails already (they are discarded). Will monitor this again.

     

    Please advice on best approach for the Automatica Replies. Thanks.

  • Hello Jake,

    Thank you for your update.

    If you require both feature of forwarding and automatic replies.  For a workaround, you can refer to steps below to archive this.

    Note: With this option, mailbox will keep a copy of forwarded messages.

    1. Stop forwarding by clicking Stop Forwarding under Connected Account page.

    2. Create a Inbox rule to forward all emails to another mailbox referring to steps in article below.

       New Inbox Rule
       http://help.outlook.com/en-us/140/ms.exch.ecp.newinboxrule.aspx

    3. Disable the automatic replies settings and enable them again.

    Thank you.

    Jack Sun

    1 out of 1 people found this post helpful.

  • Hello Jake,

    Can both forwarding and automatic replies features work well with workaround mentioned in the previous post? Thank you.

    Jack Sun

  • Thanks Jack. The workaround you provided works, except that emails are still piling up in the old mailbox. But I can live with that for now.

    I can understand why it works the way it works, that auto reply and forward cannot go hand in hand, but it should have been made smarter, perhaps an instruction to explain this and suggest alternatives.

    Thanks for your help again.

  • I'm having this issue as well. Your workaround *almost* works, except that the forwarded mail shows up in the external account as a winmail.dat attachment, which is useless for this user.

    I changed the rule to redirect the message instead of forwarding, then disabled automatic replies, then enabled them again. This finally seems to work. There's no granular control on how often an autoreply is sent (only once per person, as far as I can tell), but I can live with that for now.

    This has been unbelievably frustrating. I'm half a day behind schedule just because I couldn't figure out something that takes literally one minute to do with our other mail provider (Tuffmail).