No one has responded to this discussion for at least a year, so this information may be out of date. If you're looking for information about this topic, please search for a more recent discussion or post a new question.

When sending an email, I can't attach a file from a SharePoint Worksapce local folder

  • 2 Followers
  • 7 Replies |
  • This post has 0 verified answers |
Not Answered This question is not answered

I have an office365 account and utilize the SharePoint team site, most importantly, the Documents. I have downloaded a local copy of this SharePoint site to my computer, and all of the documents also download to my computer as well. I can make a change to the local copy of the office file (i.e. Word), and it will sync up to the server.  I can make a change to the server copy of the file (via the office browser app), and it will sync down to my local store.  This works nicely. The local documents are stored in: [user]\Workspaces\Office365\Documents\.

The problem is accessing the files in the local store on my computer.  This is a bit difficult, and it appears as if there are quite a few restrictions. I have several questions in regard to the local files:

1- Can I change the location where Windows 7 or SharePoint stores these local documents? Can I store these local documents in My Documents?

2- I am unable to attach of these local documents from the local store on my computer ( [user]\Workspaces\Office365\Documents\) to an email.  The files do not show up when I go to attach them to the email.   Is there a way around this?

 

Thank you.

 

 

 

 

  • Post Points: 20
All Replies
  • Hi eGroup,
    If you open SharePoint Workspace and locate the document that you want to send via email you can right click on it and choose Send To > Mail recipient, this should open Outlook with the file already attached.  All you will have to do is enter in the contacts name and Body of the message.
    Bob Kasper
    Microsoft Office 365 SharePoint Support
    • Top 100 Contributor
    • Post Points: 0
  • Dear Bob:

     

    Thank you for the update.

     

    I am aware that this can be done, but it does not solve my issue.  As an example, what if I want to attach multiple files?  

     

    Am I totally unable to use the "attach file" icon in Outlook to attach a file to an email if the file is an a workspace store?  This seems totally illogical.  

     

    In addition, if I use Windows Explorer to open the folder on my computer where the local files are stored ([user]\Workspaces\Office365\Documents\), I can not copy and paste, nor can I drag the file(s) into the email to be attached.

     

    Do I have something configured wrong, or is this truly a restriction?

     

    Regards,

    Andrew

    • Not Ranked
    • Post Points: 0
  • Hi Andrew,
    Thank you for clearing up this issue for me.  You have the path correct, but this is not a true file path since this profile does not exist on the hard drive.  It’s difficult to explain but if you searched the hard drive for this user profile you won’t find it. 
    This is why you are unable to attach files in this manner and it will not allow you to drag and drop them either.  The only way to accomplish this is by opening workspace itself.   So to answer your question it is a limitation.
    Another solution is to connect a mapped network drive to your SharePoint site this will allow you to use the attach file from Outlook.
     
    Bob Kasper
    Microsoft Office 365 SharePoint Support
    • Top 100 Contributor
    • Post Points: 0
  • Hi Andrew,
    Just checking to see if my answer made sense, it is rather difficult to explain.  Let me know if there is anything that I can clear up if needed.
    Thank you,
    Bob Kasper
    Microsoft Office 365 SharePoint Support
    • Top 100 Contributor
    • Post Points: 0
  • Bob:

     

    Thank you for the follow up.

     

    It does answer my question, the files are restricted.

     

    This brings up another question though.  I understand that the user profile is not "actually" on the computer.  However, the files/documents are actually on the computer, correct?  I know that I can access them.   I put a short cut in Documents to the files using ([user]\Workspaces\Office365\Documents\), and I can access the files just fine that way.    I can only access these through Windows Explorer though, and not as an attachment in an email as I said earlier.

     

    The question is, are the files actually on my computer, or is my shortcut in Documents just a map to SharePoint site?

     

    Thank you for all of your assistance.

    • Not Ranked
    • Post Points: 0
  • Hi eGroup,
    Yes in a way the files are located on the computer, they are located in a cache file.  The only thing is that it only caches 1800 full documents and the rest are just headers until needed. 
    The file path for the cache is c:\users\(username)\AppData\Local\Microsoft\Office\14.0\ (for Win 7 users) or c:\Documents and settings\(username)\Local Settings\Application Data\Microsoft\Office\14.0\  (for XP users) also make sure hidden files are visible.
    Bob Kasper
    Microsoft Office 365 SharePoint Support
    • Top 100 Contributor
    • Post Points: 0
  • Hi eGroup,
    Were you able to locate the cache file?  Let me know if you have any more questions.
    Thank you,
    Bob Kasper
    Microsoft Office 365 SharePoint Support
    • Top 100 Contributor
    • Post Points: 0
Page 1 of 1 (8 items)