I can't install Office on my desktop. The page https://c2rsetup.officeapps.live.com is not available, it says.

  • 2 Followers
  • 5 Replies |
  • This post has 0 verified answers |
Answered (Not Verified) This question has suggested answer(s)
I use a trial version of Office 365 and when I want to install te desktop programs, it says the page is unavailable. I tried with IE and Firefox.
  • Post Points: 20
All Replies
  • Hi Peter,

    What subscription of Office 365 you are using? First, please make sure that you have been assigned the license for Office 365 ProPlus or Office 365 Small Business Premium.

    Then, please refer to the steps in the following link to install Office 365 ProPlus on your computer:

    office.microsoft.com/.../install-office-on-your-pc-or-mac-with-office-365-HA102822111.aspx

    Thanks,

    Nancy Xie

    • Top 50 Contributor
    • Post Points: 0
  • Hi Nancy,

    First of all thank you for your quick reply.

    I am using the trial version "Office 365 Small Business Premium Trial". As far as I know it includes 10 licenses for the Desktop versions of Office.

    I can select a language and choose between the 32 and 64 bit version. I can click the "Install" button, but then it says:

    -------------------------------------------------

    This page can't be displayed

    •Make sure the web address c2rsetup.officeapps.live.com is correct.

    •Look for the page with your search engine.

    •Refresh the page in a few minutes.

    •Make sure TLS and SSL protocols are enabled. Go to Tools > Internet Options > Advanced > Settings > Security

    -------------------------------------------------

    I also tried to reset IE, without result. I am using W7 Professional with IE10 and/or Firefox 20.

    Regards,

    Peter

    • Not Ranked
    • Post Points: 0
  • Hi Peter,

    Please try the following steps to see if the problem is related to the browser settings and troubleshoot it:

    1. Will the issue occur when you are using Firefox?

    2. Open IE, click Tools > InPrivate Browsing, and then try installing Office in this browsing mode.

    3. Close InPrivate Browsing, go to Tools > Internet Options > Advanced > Settings > Security, enable "enhanced protection mode".

    Thanks,

    Nancy Xie

    • Top 50 Contributor
    • Post Points: 0
  • Hi Nancy,

    The problem is solved. It turned out the internet connection was the cause.

    Regards,

    Peter

    • Not Ranked
    • Post Points: 0
    Suggested by
  • Hi Peter,

    Thanks for your update and sharing the cause. And I'm very glad to hear that the issue has been resovled.

    If you have any other questions, please feel free to post in the forum.

    Regards,

    Nancy Xie

    • Top 50 Contributor
    • Post Points: 0
Page 1 of 1 (6 items)