Outlook 2010 keeps asking for credentials.

  • We have about reached the end of our patience with the reliability of the hosted Exchange part of Office 365. If it isn't fixed soon, we will either dump the service and go with an internal Exchange server, or go with a competitor's solution. Microsoft tech support has not been able to solve the issue, which has been going on for about a month now and they seem unwilling to escalate the issue.

    The issue is that Outlook keeps prompting most of our 87 Outlook users for the Exchange account credentials, and there is no pattern to it. Some never get prompted, some get prompted more than once a day. On some days, IT is constantly running around putting in the credentials (due to all the issues, we have not let them pick their own yet).  We do not have an ADFS, as this is identified as an optional item, and have no plans to implement one.

    The odd thing is that the reliability issues started about 90 days after we had gone live with the service, after a successful trial of the beta with a limited subset of users. When the passwords started aging out, we found that Office 365 does an extremely poor job of informing the user that their password has expired. We have also found that some user's passwords stop being accepted by OWA for no apparent reason, forcing us to reset the passwords on those accounts.

    IT's reassurances that this is a new service and MS is going to fix it is wearing thin with our CEO and Exec VP, who is not a fan of Microsoft in the first place. So, my question is, what is it going to take to fix this?

     

    Jerry Riedel

    IT Manager

  • Ok so without ADFS you are using online accounts and this post has information about the Password policy for online accounts, community.office365.com/.../office-365-password-policy.aspx

    What version of Outlook are you using?  Have you run the "Setup and Configure your Office Desktop Apps" from the download page on the Portal?

  • Hi Jerry,

    I appreciate the effort you have invested on troubleshooting this Outlook issue. I understand that after the original password expired, Outlook keeps asking for credentials. Resetting the password doesn’t fix this issue.

    This issue can be caused if one of the following factors is true:
    1. The Always prompt for logon credentials box is checked.
    2. Office 365 Desktop Setup has not been run, or the Microsoft Online Services Sign In Assistant is out of date.
    3. The personal certificate needs to be refreshed.

    Based on this situation, please perform the following steps to troubleshoot this issue.  

    Check Outlook settings
    ==================
    1. Open Outlook 2010. Click File>Account Settings>Account Settings.
    2. Click the E-mail tab, click the Exchange Online mailbox, click Change…
    3. Click More Settings…. Click the Security tab, make sure the Always prompt for logon credentials box is unchecked.

    Run Office 365 Desktop Setup Apps
    =============================
    To do so, please log on Office 365, click Downloads under Resources on the right panel, and then click Set up under Set up and configure your Office desktop apps.

    Delete the personal credentials
    ===========================
    If you are running Windows 7, please also remove the user’s stored credentials in Windows Credential Manager. To do this, follow these steps:
     a. Click Start, click Control Panel, and then click Credential Manager.
     b. Locate the set of credentials that is used to connect to Exchange. The credentials should be shown as MS.Outlook: username@domain.onmicrosoft.com or username@your vanity domain.com
     c. Expand the set of credentials, and then select Remove from Vault.
     
    Please check whether the issue is resolved or not.

    I realize that you have contacted tech support. If the issue persists, please let me know the Service Request ID. I would like to check the status of the Service Request for you.

    Thanks,
    Mindy Pan


  • The password policy is not the problem. The issue with continually getting prompted for the password was triggered when the passwords expired at the default period of 90 days. In the meantime, MS tech support provide us with a script to change the pw policy so that the passwords never expire, in an attempt to sort out what is going on.

    FYI, Office 365 comes with Outlook 2010 Pro.

  • No, resetting the password fixes the issue, for a while. It will run fine for a day, or several days, then Outlook will ask for the password again. Sometimes, reentering the same password will restore operation, sometimes it will not. When it doesn't, we reset the password again and enter it into Outlook again, it works and the cycle starts over.

    This happens even though the 'save password' box was checked when we entered the new password. If the 'always prompt' checkbox had been checked, it would prompt for the password everytime, and it does not do that. One interesting clue is that a number of the Outlook accounts now have a different Exchange server in the account settings than the one that we were originally given by Microsoft. It seems as though the account information is not being accurately replicated between the clustered Exchange servers, but our level 1 support guy doesn't seem to have a way to verify that. The issue is compounded by the fact that we can't get anyone on the phone right at the time the issue is occurring. We could take a Wireshark trace, if that would help.

    Note that it has not be established with certainty whether the issue is on the Exchange side, or the Outlook side. Since the password is encrypted, MS would have to have a way to decrypt the password that Outlook is using in a failure case and read it back to us to verify that Outlook is remembering the correct password. Restoring operation by re-entering the same password is an indication that the issue in on the Outlook side, but is not conclusive because that act may 'refresh' the authentication cycle. My suspicion is that the issue is on the hosted Exchange side, but in any event, the authentication mechanism is not reliable.

    The service request # is [Service Request number is removed by moderator]


  • Hi Jerry,

    I noticed that you have set password never expiration for your users. At this point, please check if the users can log on Outlook Web App using the current passwords. If the Outlook Web App works properly, we can determine that this issue is more Outlook client related.

    To further narrow down the issue, you may also configure a problematic mailbox on a clean operating system. To do so, please install Office Professional Plus, run Office 365 Desktop Setup App, and then configure Outlook. If the original issue doesn’t occur on this computer, you can try to fix the issue for other users by creating a new Outlook profile.

    Thanks,
    Mindy Pan

  • Mindy,

    We have been using the OWA logon to troubleshoot in the way that you suggest, if the known/current password does not work in Outlook. In all but a couple cases, when the password did not work in Outlook, it did not work in OWA either. Like I said, the issues started occuring when the passwords started expiring. We also ran into an issue on Monday where all computers prompted for the Outlook password after a Windows Update reboot. In this case, the password field in Outlook was blank, but entering the known password restored operation.

    Yesterday, Office365 tech support provided an update to the signon assistant component that is now supposed to inform the user that their password has expired and give them the means to change it. We will be testing that and pushing that out when we can. In the meantime, the issue seems to have died down even though we made no changes on this end, other than pusing Windows and Office 2010 updates. The only one that had to be entered yesterday was for an employee that had not logged on since last week, so we are going to wait and see.

    Jerry Riedel

  • Hi Jerry,

    Thank you for your reply and updating the status of the issue.

    The original issue disappeared after installing Windows and Office 2010 updates. You have updated Microsoft Online Service Sign In Assistant and will wait for several days to check the results. Given this situation, if you have any other questions regarding this issue, please do not hesitate to contact us. It is always our pleasure to be of assistance.

    Thanks,
    Mindy Pan

     

  • I did all that, and my Office is up to date with patches. I still get prompts for passwords.

  • I am also having the same problem.  My password is accepted fine by Sharepoint, web outlook, mobile phone, etc.  Only Outlook seems to have the problem.  It is sporadic in that it will work fine for a couple of hours, then prompt for password and get stuck at trying to connect.  If I close out and go back in it will work fine for a while, then prompt for password again.

  • Hi HilaryCF,

    I understand that you are prompted for credentials when using Outlook. At this point, you can try to troubleshoot this issue referring to http://support.microsoft.com/kb/2637629.

    If the issue persists, I recommend creating a new dedicated thread for this issue, so that we can dig deeper on this issue. Thank you for your understanding.

    Best regards,
    Mindy Pan

    0 out of 1 people found this post helpful.

  • Hi all,

    I'm dealing with the same issue but on a Mac. Sometimes (very rarely) I can keep on working for a few hours but all of a sudden, the system keeps on prompting time after time asking to reenter my credentials.

    Pleas keep us posted !

    Regards,

    Wouter

  • My problem is specific to the account associated with Office365 and started when we started the migration from Online services to Office365 so I'm not sure how it is any different from the issue reported here.

  • Hello HilaryCF,

    From your description, I suggest refer set up the desktop for Office 365 to see if it works.
    http://onlinehelp.microsoft.com/en-us/office365-enterprises/ff637594.aspx
    For tips, if you have installed or don’t need Lync 2010 and Microsoft Office Professional Plus for Office 365, you may skip steps 3 and 4 of the article above.

    In addition, if you need further assistance on the issue, I sincerely suggest post detailed information about the issue, such as some screenshots, in a new thread in the forum. This is so your question will be answered quickly.

    Thanks for understanding,
    Claud

    0 out of 1 people found this post helpful.

  • Hello Wouter,

    From the description, I suggest check and install the latest update of the current mail client, such as Outlook 2011, on your MAC to see if it works.

    In addition, if you need further assistance on the issue, I sincerely suggest post detailed information about the issue, such as MAC OS version, Outlook client version and some screenshots, in a new thread in the forum. This is so your question will be answered quickly.

    Thanks for understanding,
    Claud  

    0 out of 1 people found this post helpful.